Connectivity Automation Objects [Connectivity Automation Reference: CAR]

Connectivity Automation Objects

Connectivity Automation Objects (CAO) support the following dbConnect features:

  • Event Notifications
  • Key Descriptions
  • Key Values
  • Label Templates
  • Labels
  • Link Templates
  • Links
  • Queries
You can also create dbConnect objects.

Beginning with AutoCAD 2002, CAO supports the following objects, methods, and properties:

  • Objects and methods: CAO objects include the LabelTemplates collection, LabelTemplate object, Label object, Queries collection, and Query object, along with their corresponding methods. The KeyDescriptions and KeyValues collections are independent objects. KeyDescriptions no longer derives from the LinkTemplate object, and KeyValues no longer derives from the Link object. The KeyValues Add method accepts two arguments: field name and value, rather than a single object argument.
  • Properties: The KeyDescription Type property is now a CAO data type, rather than an OLEDB data type.
  • Event notifications: The DbConnect object uses event notifications.

You can find sample code demonstrating the use of CAO in the AutoCAD sample\Database Connectivity\CAO directory.

Topics in this Section:

  • CAO Objects, Methods and Properties
  • Migrate Projects


 CAO Objects, Methods, and Properties [Connectivity Automation Reference: CAR]

CAO Objects, Methods, and Properties

Beginning with AutoCAD 2002, the following objects, methods and properties are supported by Connectivity Automation Objects (CAO).

CAO objects and their methods and properties introduced in AutoCAD 2002
Object | Methods | Properties
Label | Hide, Refresh, Reload, Show | DbConnect, DisplayValues, Document, LabelTemplate, LeaderObjectId, Link, MTextObjectId
LabelTemplate | Hide, Refresh, Reload, Show | Catalog, Color, Datasource, DbConnect, DisplayableAttributes, Document, Format, LeaderAttachment, LeaderOffset, Linetype, Name, Rotation, Schema, Table, TextAttachment, TextHeight, TextStyle, TipOffset
LabelTemplates Collection | Add, Delete, Item | Count, DbConnect, Document
Queries Collection | Add, Delete, Item | Count, DbConnect, Document
Query | None | Catalog, Datasource, DbConnect, Document, Name, Schema, Table, Text

Existing objects and their methods and properties introduced in AutoCAD 2002
Object | New Methods | New Properties
DbConnect | Connect, GetLabelTemplates, GetLinksByKey, GetLinksBySQLCond, GetLinksByLabelTemplate, GetQueries, IsConnected | None
KeyDescriptions Collection | Add | None
Link | None | Label
Links Collection | Intersect, Subtract, Union | None
LinkTemplate | CreateLabel | None
LinkTemplates Collection | Add, Delete | None


 Migrate Projects [Connectivity Automation Reference: CAR]

Migrate Projects

In general, an AutoCAD 2004 automation project created in the VBA IDE or created with Visual Basic 6 should work with AutoCAD 2005.

AutoCAD 2005 automation projects use the same type library (acax16enu.tlb) as AutoCAD 2004 automation projects. The type library is located in the following folder: C:\Program Files\Common Files\Autodesk Shared.

AutoCAD 2005 automation projects also use the same version-dependent ProgID for the CreateObject, GetObject, and GetInterfaceObject methods. For example, if you are using the CreateObject function in an AutoCAD 2005 automation project, you use CreateObject ("AutoCAD.Application.16"). If an automation project uses version-independent ProgIDs, change the project to use version-dependent ProgIDs.


Object Model [Connectivity Automation Reference: CAR]

Object Model

Click an object to view the corresponding description.

KeyValueObj KeyValuesColl KeyDescriptionObj KeyDescriptionsColl DbConnectObj Hotspot 10 LabelObj LinkObj LinksColl QueryObj QueriesColl LabelTemplateObj LabelTemplatesColl LinkTemplateObj LinkTemplatesColl


List of Objects [Connectivity Automation Reference: CAR]

Objects

DbConnect object

KeyDescription object

KeyDescriptions collection

KeyValue object

KeyValues collection

Label object

LabelTemplate object

LabelTemplates collection

Link object

Links collection

LinkTemplate object

LinkTemplates collection

Queries collection

Query object


DBConnect [Connectivity Automation Reference: CAR]

DbConnect Object

An instance of the AutoCAD DbConnect object.

VBA class name: DbConnect

Create using: For VB and AutoCAD VBA:

AutoCAD.GetInterfaceObject("CAO.DbConnect.16")

Access via: N/A

Methods

Connect

DisConnect

GetLabelTemplates

GetLinks

GetLinksByKey

GetLinksBySQLCond

GetLinksByLabelTemplate

GetLinkTemplates

GetQueries

IsConnected

ReloadLabels

Properties

Version

DataSourceLocation

Events

OnConnect

OnDisconnect

OnLabelTemplateCreated

OnLabelTemplateDeleted

OnLabelTemplateModified

OnLinkTemplateCreated

OnLinkTemplateDeleted

OnLinkTemplateModified

OnQueryCreated

OnQueryDeleted

OnQueryModified


KeyDescription [Connectivity Automation Reference: CAR]

KeyDescription Object

Defines a key field for a link template object.

VBA class name: KeyDescription

Create using: KeyDescriptions.Add

Access via: LinkTemplate.KeyDescriptions.Item

Key fields are used by a link template to uniquely identify a record from a database table.

To edit or query a KeyDescription, use the following methods and properties:

Methods

None

Properties

DefinedSize

FieldName

NumericScale

Precision

Type


KeyDescriptions [Connectivity Automation Reference: CAR]

KeyDescriptions Collection

Defines a set of key fields in a link template.

VBA class name: KeyDescriptions

Create using: ACADApplication.GetInterfaceObject("CAO.KeyDescriptions.16")

Access via: LinkTemplate.KeyDescriptions

To select a specific KeyDescription, use the Item method. To edit or query the KeyDescriptions collection, use the following methods and properties:

Methods

Add

Item

Properties

Count


KeyValue [Connectivity Automation Reference: CAR]

KeyValue Object

Specifies a single key value in a link.

VBA class name: KeyValue

Create using: KeyValues.Add

Access via: Link.KeyValues.Item

To edit or query a KeyValue, use the following methods and properties:

Methods

None

Properties

FieldName

Value


KeyValues [Connectivity Automation Reference: CAR]

KeyValues Collection

A set of key values in a link.

VBA class name: KeyValues

Create using: ACADApplication.GetInterfaceObject("CAO.KeyValues.16")

Access via: Link.KeyValues

To add a new member to the collection, use the Add method. To select a specific KeyValue, use the Item method. To edit or query the KeyValues collection, use the following methods and properties:

Methods

Add

Item

Properties

Count


Label [Connectivity Automation Reference: CAR]

Label Object

A multiline text object that displays data in an AutoCAD drawing from selected fields in an external database table.

VBA class name: Label

Create using: LinkTemplate.CreateLabel

Access via: Link.Label

A Label object can be obtained from a Link object if the link type is either an attached label or a freestanding label. You cannot update the properties of a label object.

To delete a label, delete its associated link. To edit or query a label, use the following methods and properties:

Methods

Hide

Refresh

Reload

Show

Properties

DbConnect

DisplayValues

Document

LabelTemplate

LeaderObjectId

Link

MTextObjectId


LabelTemplate [Connectivity Automation Reference: CAR]

LabelTemplate Object

Defines what fields from the database table are displayed in the label, and how the label text is formatted.

VBA class name: LabelTemplate

Create using: LabelTemplates.Add

Access via: LabelTemplates.Item

A label template can be updated only if there are no links associated with it.

Label templates have database properties and graphical properties. Database properties correspond to table column references. Graphical properties control the appearance of label text in the drawing area. To update data retrieved from a database, use the Reload method. To update label text, use the Refresh method.

To create a label template, use the Add method of the LabelTemplates collection. To edit or query a label template, use the following methods and properties:

Methods

Hide

Refresh

Reload

Show

Properties

Catalog

Color

Datasource

DbConnect

DisplayableAttributes

Document

Format

LeaderAttachment

LeaderOffset

Linetype

Name

Rotation

Schema

Table

TextAttachment

TextHeight

TextStyle

TipOffset


LabelTemplates [Connectivity Automation Reference: CAR]

LabelTemplates Collection

The collection of label templates from an AutoCAD drawing.

VBA class name: LabelTemplates

Create using: N/A

Access via: DbConnect.GetLabelTemplates

To add a new member to the collection, use the Add method. To select a specific label template, use the Item method. To edit or query the LabelTemplates collection, use the following methods and properties:

Methods

Add

Delete

Item

Properties

Count

DbConnect

Document


Link [Connectivity Automation Reference: CAR]

Link Object

A link between a database table record and an AutoCAD graphical object.

VBA class name: Link

Create using: LinkTemplate.CreateLink

Access via: Links.Item

A link establishes a dynamic relationship between an AutoCAD graphical object and an external database table. In order to create links, you must first create a link template that specifies the database table and key fields used by all links based on that template. There are three types of AutoCAD links:

  • Entity links associate link information with an AutoCAD graphical object.
  • Attached labels associate link information with an AutoCAD graphical object and create a corresponding multiline text label object.
  • Freestanding labels associate link information with an multiline text label object.

To create an entity link, use the CreateLink method of the LinkTemplate object. To create labels, use the CreateLabel method of the LinkTemplate object. To edit or query a link, use the following methods and properties:

Methods

Delete

Properties

DbConnect

Document

KeyValues

Label

LinkTemplate

LinkType

ObjectId

Updatable


Links [Connectivity Automation Reference: CAR]

Links Collection

A collection of links and labels from an AutoCAD drawing.

VBA class name: Links

Create using: N/A

Access via: DbConnect.GetLinks

To add a new member to the collection, use the CreateLink method of the LinkTemplate object. To select a specific Link, use the Item method. To edit or query the Links collection, use the following methods and properties:

Methods

Intersect

Item

Subtract

Union

Properties

Count

DbConnect

Document


LinkTemplate [Connectivity Automation Reference: CAR]

LinkTemplate Object

Specifies the external database table and key fields that are used by links based on this template.

VBA class name: LinkTemplate

Create using: LinkTemplates.Add

Access via: LinkTemplates.Item

Link templates are used to establish relationships between AutoCAD graphical objects and a particular database table. Link templates specify the table and key fields that are used by all links based on that template.

To edit or query a link template, use the following methods and properties:

Methods

CreateLabel

CreateLink

Properties

Catalog

DataSource

DbConnect

Document

KeyDescriptions

Name

Schema

Table


LinkTemplates [Connectivity Automation Reference: CAR]

LinkTemplates Collection

The collection of link templates from an AutoCAD drawing.

VBA class name: LinkTemplates

Create using: N/A

Access via: DbConnect.GetLinkTemplates

To select a specific LinkTemplate, use the Item method. To edit or query the LinkTemplates collection, use the following methods and properties:

Methods

Add

Delete

Item

Properties

Count

DbConnect

Document


Queries [Connectivity Automation Reference: CAR]

Queries Collection

The collection of queries from an AutoCAD drawing.

VBA class name: Queries

Create using: N/A

Access via: DbConnect.GetQueries

To add a new member to the collection, use the Add method. To select a specific query, use the Item method. To edit or examine the Queries collection, use the following methods and properties:

Methods

Add

Delete

Item

Properties

Count

DbConnect

Document


Query [Connectivity Automation Reference: CAR]

Query Object

A stored database query.

VBA class name: Query

Create using: Queries.Add

Access via: Queries.Item

To create a query, use the Add method of the Queries collection. To edit or examine a query, use the following properties:

Methods

None

Properties

Catalog

Datasource

DbConnect

Document

Name

Schema

Table

Text


List of Methods [Connectivity Automation Reference: CAR]

Methods

Add

Clear

Connect

CreateLabel

CreateLink

Delete

Disconnect

GetLabelTemplates

GetLinks

GetLinksByKey

GetLinksByLabelTemplate

GetLinksBySQLCond

GetLinkTemplates

GetQueries

Hide

Intersect

IsConnected

Item

Refresh

Reload

ReloadLabels

Show

Subtract

Union


 Add [Connectivity Automation Reference: CAR]

Add Method

Adds a new object to the specified collection.

See Also

Signatures: Overview

KeyDescriptions

RetVal = object.Add(Name, DataType [, Precision] [, Scale])

KeyValues

RetVal = object.Add(FieldName, Value)

LabelTemplates

RetVal = object.Add(DataSource,Catalog, Schema, Table, Name, DisplayAttributes)

LinkTemplates

RetVal = object.Add(DataSource, Catalog, Schema, Table, Name, KeyDescriptions)

Queries

RetVal = object.Add(DataSource, Catalog, Schema, Table, Name, SQLText)

Signatures: Detail

RetVal = object.Add(Name, DataType [, Precision] [, Scale])

Object

KeyDescriptions Collection
The object or objects this method applies to.

Name

String; input-only
The name of the column to be added.

DataType

CaoDataType enum; input-only
The data type of the column being added. Specify one of the following constants:

kCaoTypeText

kCaoTypeNumeric

kCaoTypeInteger

kCaoTypeDouble

kCaoTypeDate

kCaoTypeTime

kCaoTypeTimestamp

kCaoTypeBit

kCaoTypeBlob

Precision

Integer; input-only; optional
The meaning of Precision depends on the DataType specified, as follows:

kCaoTypeNumeric: Precision of numeric data.

kCaoTypeText: Length of data in symbols.

kCaoTypeBlob: Length of data in bits.

Precision is ignored for all other data types.

Scale

Integer; input-only; optional
Numeric scale for kCaoTypeNumeric. Ignored for all other data types.

RetVal

KeyDescription
The newly added object.

RetVal = object.Add(FieldName, Value)

Object

KeyValues Collection
The object or objects this method applies to.

FieldName

String; input-only
The name of the field to be added.

Value

Variant; input-only
The value of the field being added.

RetVal

KeyValue
The newly added object.

RetVal = object.Add(DataSource, Catalog, Schema, Table, Name, DisplayAttributes)

Object

LabelTemplates Collection
The object or objects this method applies to.

DataSource

String; input-only
Data source name.

Catalog

String; input-only
Catalog name.

Schema

String; input-only
Schema name.

Table

String; input-only
Table name.

Name

String; input-only
Label template name.

DisplayAttributes

Variant (String or array of strings); input-only
Column names to be displayed as label or format strings. Where a single string is specified, CAO assumes the string is a format string. An array of strings is interpreted as a list of column names.

Format strings are compatible with MTEXT format strings. Refer to database table columns in format strings using the following syntax:

#(<column name>)

For example:

#(name)

Column names are converted to the following format string:

#(<column name 1>\P#(<column name 2>)

RetVal

LabelTemplate
The newly added object.

RetVal = object.Add(DataSource, Catalog, Schema, Table, Name, KeyDescriptions)

Object

LinkTemplates Collection
The object or objects this method applies to.

DataSource

String; input-only
Data source name.

Catalog

String; input-only
Catalog name.

Schema

String; input-only
Schema name.

Table

String; input-only
Table name.

Name

String; input-only
Link template name.

KeyDescriptions

KeyDescriptions collection; input-only
Key descriptions for the link template.

RetVal

LinkTemplate
The newly added object.

RetVal = object.Add(DataSource, Catalog, Schema, Table, Name, SQLText)

Object

Queries Collection
The object or objects this method applies to.

DataSource

String; input-only
Data source name.

Catalog

String; input-only
Catalog name.

Schema

String; input-only
Schema name.

Table

String; input-only
Table name.

Name

String; input-only
Link template name.

SQLText

String; input-only
The SQL statement.

RetVal

Query
The newly added object.


 Clear [Connectivity Automation Reference: CAR]

Clear Method

Empties the specified collection.

See Also

Signature

object.Clear()

Object

KeyValues Collection
The object or objects this method applies to.

Remarks

This method is obsolete and is being maintained for backward-compatibility.


 Connect [Connectivity Automation Reference: CAR]

Connect Method

Connects to a data source.

See Also

Signature

object.Connect(Datasource [, Username] [, Password] [, Prompt])

Object

DbConnect
The object or objects this method applies to.

Datasource

String; input-only
The name of a .udl file in the Data Links directory.

Username

String; input-only; optional
User name with which you are connecting.

Password

String; input-only; optional
Password for connecting.

Prompt

Boolean; input-only; optional
Specifies whether users are prompted to specify connection properties.

TRUE: Prompts users to specify required connection properties, if some are missing.

FALSE: Does not prompt users to specify connection properties.

Remarks

If the data source is already connected, nothing happens.


 CreateLabel [Connectivity Automation Reference: CAR]

CreateLabel Method

Creates an attached or freestanding label.

See Also

Signature

RetVal = object.CreateLabel(Arg1, KeyValues, LabelTemplate [, DisplayValues])

Object

LinkTemplate
The object or objects this method applies to.

Arg1

Long for object ID, or Variant (three-element array of Doubles); input-only
The graphical object to attach the label to, or the insertion point for a freestanding label.

KeyValues

KeyValues collection; input-only
The key field values for the label.

LabelTemplate

LabelTemplate object, or String naming a label template; input-only
The label template for the label object.

DisplayValues

Variant (array of Variants); input-only; optional
Values to be displayed in the label if no matching key field is found in the database table.

RetVal

The new label object.

Remarks

The values displayed in the created label depend on which arguments are passed to CreateLabel. Those values may be affected by a subsequent call to the Reload method. CreateLabel behaves as follows:

  • If a DisplayValues argument is supplied, the argument values are displayed in the label.
  • If DisplayValues is not specified, CAO attempts to retrieve a linked row from the database. If successful, values from the row are displayed in the label. If a linked row cannot be obtained (for example, no connection exists or key values have no match in the database), an error occurs.
  • If a DisplayValues argument is supplied, but you follow CreateLabel with a call to the Reload method, CAO attempts to retrieve a linked row from the database. If successful, database values are displayed in the label; if a linked row cannot be obtained, an error occurs.


 CreateLink [Connectivity Automation Reference: CAR]

CreateLink Method

Creates a link to an AutoCAD entity.

See Also

Signature

RetVal = object.CreateLink(ObjectID, KeyValues)

Object

LinkTemplate
The object or objects this method applies to.

ObjectID

Long; input-only
The entity ID of the object to link to.

KeyValues

KeyValues collection; input-only
The key field values for the link.

RetVal

The new link object.


 Delete [Connectivity Automation Reference: CAR]

Delete Method

Deletes a specified object.

See Also

Signature

object.Delete(Index)

Object

LabelTemplates Collection, Link, LinkTemplates Collection, Queries Collection
The object or objects this method applies to.

Index

Variant; input-only
The index location in the collection. The index must be either an integer or a string. If an integer, the index must be between 0 and N-1, where N is the number of objects in the collection or selection set.

Remarks

When you delete an object in a collection, all remaining items in the collection are reassigned a new index based on the current count.


 Disconnect [Connectivity Automation Reference: CAR]

Disconnect Method

Disconnects from a data source.

See Also

Signature

object.Disconnect(Datasource)

Object

DbConnect
The object or objects this method applies to.

Datasource

String; input-only
The name of a .udl file in the Data Links directory.


 GetLabelTemplates [Connectivity Automation Reference: CAR]

GetLabelTemplates Method

Gets a LabelTemplates collection from an AutoCAD document.

See Also

Signature

RetVal = object.GetLabelTemplates([Document])

Object

DbConnect
The object or objects this method applies to.

Document

AcadDocument; input-only, optional
The AutoCAD document from which to obtain the label templates collection. If no value is specified, the collection is obtained from the active document.

RetVal

LabelTemplates collection;
The label templates collection.


 GetLinks [Connectivity Automation Reference: CAR]

GetLinks Method

Gets a Links collection.

See Also

Signature

RetVal = object.GetLinks([LinkTemplate] [, ObjectIDs] [, LinkTypes] [, Document])

Object

DbConnect
The object or objects this method applies to.

LinkTemplate

LinkTemplate object, or a string identifying a link template; input-only; optional
If specified, indicates the link template whose links are returned.

ObjectIDs

Variant (array of Longs); input-only; optional
If specified, each long is the object ID of an AutoCAD entity whose links are to be returned.

LinkTypes

Variant; input-only; optional
Specifies the type of links to return. Any combination of the following link types can be specified:

  • kEntityLinkType returns entity links.
  • kFSLabelType returns freestanding labels.
  • kAttachedLabelType returns attached labels.

If no value is specified, only entity links are returned.

Document

Document object; input-only; optional
This argument is ignored if a LinkTemplate object is passed as the first argument. If neither a LinkTemplate or a Document argument is specified, the document object is identified as follows:

  • If the LinkTemplate argument is a string naming a link template, the current document is used.
  • If the LinkTemplate argument is a LinkTemplate object, the link template document is used.
  • If no LinkTemplate argument is supplied, the current document is used.

RetVal

Links collection;
The Links collection for the specified link template.

Remarks

If no arguments are specified, GetLinks returns all entity links associated with the current document.


 GetLinksByKey [Connectivity Automation Reference: CAR]

GetLinksByKey Method

Gets a Links collection based on link template, link key values, and (optionally) link type.

See Also

Signature

RetVal = object.GetLinksByKey(LinkTemplate, KeyValues [, LinkTypes] [, Document])

Object

DbConnect
The object or objects this method applies to.

LinkTemplate

LinkTemplate object, or a string identifying a link template; input-only
Specifies the link template whose links are returned.

KeyValues

KeyValues collection; input-only
The KeyValues collection containing the key values to search for.

LinkTypes

Integer; input-only; optional
Specifies the type of links to return. You can specify any combination of the following link types:

kEntityLinkType: Entity links

kFSLabelType: Freestanding labels

kAttachedLabelType: Attached labels

If no value is specified, only entity links are returned.

Document

Document object; input-only; optional
This argument is ignored if a LinkTemplate object is passed as the first argument. If this argument is not specified, the document object is identified as follows:

  • If the LinkTemplate argument is a string naming a link template, the current document is used.
  • If the LinkTemplate argument is a LinkTemplate object, the link template document is used.

RetVal

Links collection
The Links collection for the specified keys.


 GetLinksByLabelTemplate [Connectivity Automation Reference: CAR]

GetLinksByLabelTemplate Method

Gets a Links collection containing the label links associated with the specified label template.

See Also

Signature

RetVal = object.GetLinksByLabelTemplate(LabelTemplate, [, LinkTypes] [, Document])

Object

DbConnect
The object or objects this method applies to.

LabelTemplate

LabelTemplate object, or a string identifying a label template; input-only
Specifies the label template whose links are returned.

LinkTypes

Integer; input-only; optional
Specifies the type of links to return. You can specify any combination of the following link types:

kFSLabelType: Freestanding labels

kAttachedLabelType: Attached labels

If no value is specified, all label links are returned.

Document

Document object; input-only; optional
This argument is ignored if a LabelTemplate object is passed as the first argument. If this argument is not specified, the document object is identified as follows:

  • If the LabelTemplate argument is a string naming a label template, the current document is used.
  • If the LabelTemplate argument is a LabelTemplate object, the label template document is used.

RetVal

Links collection;
The Links collection meeting the specified conditions.


 GetLinksBySQLCond [Connectivity Automation Reference: CAR]

GetLinksBySQLCond Method

Gets a Links collection based on link template, SQL condition, and (optionally) link type.

See Also

Signature

RetVal = object.GetLinksBySQLCond(LinkTemplate, Condition [, LinkTypes] [, Document])

Object

DbConnect
The object or objects this method applies to.

LinkTemplate

LinkTemplate object, or a string identifying a link template; input-only
Specifies the link template whose links are returned.

Condition

String; input-only
The WHERE clause of the SQL statement, identifying the conditions to be met.

LinkTypes

Integer; input-only; optional
Specifies the type of links to return. You can specify any combination of the following link types:

kEntityLinkType: Entity links

kFSLabelType: Freestanding labels

kAttachedLabelType: Attached labels

If no value is specified, only entity links are returned.

Document

Document object; input-only; optional
This argument is ignored if a LinkTemplate object is passed as the first argument. If this argument is not specified, the document object is identified as follows:

  • If the LinkTemplate argument is a string naming a link template, the current document is used.
  • If the LinkTemplate argument is a LinkTemplate object, the link template document is used.

RetVal

Links collection;
The Links collection meeting the specified conditions.

Remarks

You must connect to the data source identified by LinkTemplate before issuing GetLinksBySQLCond.

The SQL conditions are applied to every linked row in the database, and the corresponding link object is returned if the conditions are met.


 GetLinkTemplates [Connectivity Automation Reference: CAR]

GetLinkTemplates Method

Gets the LinkTemplates collection from an AutoCAD document.

See Also

Signature

RetVal = object.GetLinkTemplates([Document])

Object

DbConnect
The object or objects this method applies to.

Document

AcadDocument; input-only; optional
The AutoCAD document to get the link templates collection from. If no value is specified, gets the collection from the active document.

RetVal

LinkTemplates collection;
The link templates collection.


 GetQueries [Connectivity Automation Reference: CAR]

GetQueries Method

Gets a Queries collection from an AutoCAD document.

See Also

Signature

RetVal = object.GetQueries([Document])

Object

DbConnect
The object or objects this method applies to.

Document

AcadDocument; input-only, optional
The AutoCAD document from which to obtain the Queries collection. If no value is specified, the collection is obtained from the active document.

RetVal

Queries collection;
The queries collection.


 Hide [Connectivity Automation Reference: CAR]

Hide Method

Makes the specified objects invisible in the AutoCAD drawing.

See Also

Signature

object.Hide()

Object

LabelTemplate, Label
The object or objects this method applies to.


 Intersect [Connectivity Automation Reference: CAR]

Intersect Method

Returns the set of Link objects that are members of each of the specified Links collections.

See Also

Signature

Retval = object.Intersect(LinkSelection)

Object

Links collection
The current object or objects this method applies to.

LinkSelection

Links collection
The Links collection with which to intersect the current object.

RetVal

Links collection
The Link objects that were found in both of the specified Links collections.

Remarks

Intersect returns only those Links that appear in both of the specified collections.


 IsConnected [Connectivity Automation Reference: CAR]

IsConnected Method

Indicates whether a connection to a data source exists.

See Also

Signature

RetVal = object.IsConnected(DataSource)

Object

DbConnect
The object or objects this method applies to.

DataSource

String; input-only
The name of a UDL file in the Data Links directory.

RetVal

Boolean
Identifies whether or not a connection to a data source exists.

TRUE: A connection to the data source exists.

FALSE: No connection exists.


 Item [Connectivity Automation Reference: CAR]

Item Method

Gets the member object at a given index from a collection.

See Also

Signature

RetVal = object.Item(Index)

Object

LinkTemplates Collection, KeyDescriptions Collection, KeyValues Collection, Links Collection, Queries Collection
The object or objects this method applies to.

Index

Variant; input-only
The index location in the collection for the member item to query. The index must be either an integer or a string. If an integer, the index must be between 0 and N-1, where N is the number of objects in the collection or selection set.

RetVal

The object at the given index location in the specified collection.


 Refresh [Connectivity Automation Reference: CAR]

Refresh Method

Refreshes the display of labels in the drawing area.

See Also

Signature

object.Refresh()

Object

LabelTemplate, Label
The object or objects this method applies to.

Remarks

Refresh does not affect label values, only their appearance (for example, text height and color). Use Reload to update label values from their data source.

Refresh does not require a connection to the data source.

Specifying a LabelTemplate object causes all labels associated with that label template to be refreshed.


 Reload [Connectivity Automation Reference: CAR]

Reload Method

Reloads from the database any objects you specify that are connected to their data source.

See Also

Signature

object.Reload()

Object

LabelTemplate, Label
The object or objects this method applies to.

Remarks

Specifying a LabelTemplate object causes all labels associated with that label template to be reloaded.

Reloading does not affect label attributes such as text height or color. Use Refresh to update label attributes in the drawing area.


 ReloadLabels [Connectivity Automation Reference: CAR]

ReloadLabels Method

Reloads the labels in the specified AutoCAD drawing.

See Also

Signature

object.ReloadLabels([ObjectIDs] [, Document])

Object

DbConnect
The object or objects this method applies to.

ObjectIDs

Variant; input-only; optional
Array of longs. Each long specifies an AutoCAD entity object ID. If not specified, reloads all labels in the specified document.

Document

AcadDocument; input-only; optional
The AutoCAD document to reload the labels in. If not specified, reloads the labels in the active document.


 Show [Connectivity Automation Reference: CAR]

Show Method

Makes the specified objects visible in the AutoCAD drawing.

See Also

Signature

object.Show()

Object

LabelTemplate, Label
The object or objects this method applies to.


 Subtract [Connectivity Automation Reference: CAR]

Subtract Method

Returns the set of Link objects resulting from the subtraction of one Links collection from another.

See Also

Signature

Retval = object.Subtract(LinkSelection)

Object

Links collection
The current object or objects this method applies to.

LinkSelection

Links collection
The Links collection to subtract from the current object.

RetVal

Links collection
The Link objects remaining after subtracting LinkSelection from Object.

Remarks

The resulting collection contains all members of the current object that do not appear in the LinkSelection collection.


 Union [Connectivity Automation Reference: CAR]

Union Method

Returns the set of Link objects that are members of either of the specified Links collections.

See Also

Signature

Retval = object.Union(LinkSelection)

Object

Links collection
The current object or objects this method applies to.

LinkSelection

Links collection
The Links collection to merge with the current object.

RetVal

Links collection
The Link objects that were found in either of the specified Links collections.

Remarks

Union adds the members of both Links collections and returns the result. Links that appear in both collections are included only once in the resulting collection.


List of Properties [Connectivity Automation Reference: CAR]

Properties

Catalog

Color

Count

DataSource

DataSourceLocation

DbConnect

DefinedSize

DisplayableAttributes

DisplayValues

Document

FieldName

Format

KeyDescriptions

KeyValues

Label

LabelTemplate

LeaderAttachment

LeaderObjectId

LeaderOffset

Linetype

Link

LinkTemplate

LinkType

MTextObjectId

Name

NumericScale

ObjectId

Precision

Rotation

Schema

Table

Text

TextAttachment

TextHeight

TextStyle

TipOffset

Type

Updatable

Value

Version


 Catalog Property [Connectivity Automation Reference: CAR]

Catalog Property

Holds the catalog name value.

See Also

Signature

object.Catalog

object

LabelTemplate, LinkTemplate, Query
The object or objects this property applies to.

Catalog

String
The name of the table catalog.


 Color Property [Connectivity Automation Reference: CAR]

Color Property

Specifies the color of label text.

See Also

Signature

object.Color

object

LabelTemplate
The object or objects this property applies to.

Color

acColor enum
Indicates the label text color. The value returned is a color index number from 0 to 256. When setting Color, you can specify one of the constants listed here:

acRed (1)

acYellow (2)

acGreen (3)

acCyan (4)

acBlue (5)

acMagenta (6)

acWhite (7)


 Count Property [Connectivity Automation Reference: CAR]

Count Property

Holds the number of objects in the specified collection.

See Also

Signature

object.Count

object

KeyDescriptions Collection, KeyValues Collection, LabelTemplates Collection, Links Collection, LinkTemplates Collection, Queries Collection
The object or objects this property applies to.

Count

Long; read-only
The number of objects in the collection.


 DataSource Property [Connectivity Automation Reference: CAR]

DataSource Property

Holds the data source name value.

See Also

Signature

object.DataSource

object

LabelTemplate, LinkTemplate, Query
The object or objects this property applies to.

DataSource

String
Specifies the name of the data source.


 DataSourceLocation Property [Connectivity Automation Reference: CAR]

DataSourceLocation Property

Specifies the default storage location of data source configuration files.

See Also

Signature

object.DataSourceLocation

object

DbConnect
The object or objects this property applies to.

DataSourceLocation

String; read-only
Specifies the path of data source configuration files.


 DbConnect Property [Connectivity Automation Reference: CAR]

DbConnect Property

Gets the DbConnect object.

See Also

Signature

object.DbConnect

object

LabelTemplate, LabelTemplates Collection, Link, Links Collection, LinkTemplate, LinkTemplates Collection, Queries Collection, Query
The object or objects this property applies to.

DbConnect

Object; read-only
The DbConnect object.


 DefinedSize Property [Connectivity Automation Reference: CAR]

DefinedSize Property

Specifies the maximum field width of the specified object.

See Also

Signature

object.DefinedSize

object

KeyDescription
The object or objects this property applies to.

DefinedSize

Long
The maximum field width allowed for the KeyDescription object.


 DisplayableAttributes Property [Connectivity Automation Reference: CAR]

DisplayableAttributes Property

Specifies the database table columns to be displayed in labels.

See Also

Signature

object.DisplayableAttributes

object

LabelTemplate
The object or objects this property applies to.

DisplayableAttributes

Variant (array of Strings); read-only
Indicates the table columns to be displayed in labels based on the specified LabelTemplate object.

Remarks

Displayable attributes can be set using the Format property of the LabelTemplate object.


 DisplayValues Property [Connectivity Automation Reference: CAR]

DisplayValues Property

Contains the label values derived from data in an external database table that you want displayed.

See Also

Signature

object.DisplayValues

object

Label
The object or objects this property applies to.

DisplayValues

Variant (array of Variants); read-only
The label values obtained from the database table.


 Document Property [Connectivity Automation Reference: CAR]

Document Property

Gets the AcadDocument object.

See Also

Signature

object.Document

object

LabelTemplate, LabelTemplates Collection, Link, Links Collection, LinkTemplate, LinkTemplates Collection, Queries Collection, Query
The object or objects this property applies to.

Document

Object; read-only
The AcadDocument object.


 FieldName Property [Connectivity Automation Reference: CAR]

FieldName Property

Indicates the field name of the specified object.

See Also

Signature

object.FieldName

object

KeyDescription, KeyValue
The object or objects this property applies to.

FieldName

String
Specifies the field name of the object.


 Format Property [Connectivity Automation Reference: CAR]

Format Property

Identifies the data to appear in the label.

See Also

Signature

object.Format

object

LabelTemplate
The object or objects this property applies to.

Format

String
Indicates the text and table columns to be displayed in labels based on the specified LabelTemplate object. Specify columns using the following notation:

#(<column name>)

For example:

"#(Tag_Number)\P#(Manufacturer)\P#(Equipment_Description)"

Remarks

The following example specifies a label that includes the Tag_Number and Equipment_Description columns from a database table:

object.Format = "Details are as follows : \P#(Tag_Number)\P#(Equipment_Description)"

You can use the DisplayableAttributes property of the LabelTemplate object to obtain a list of table columns associated with the label template.


 KeyDescriptions Property [Connectivity Automation Reference: CAR]

KeyDescriptions Property

Gets the KeyDescriptions collection of the specified object.

See Also

Signature

object.KeyDescriptions

object

LinkTemplate
The object or objects this property applies to.

KeyDescriptions

Object
The KeyDescriptions collection of the specified object.


 KeyValues Property [Connectivity Automation Reference: CAR]

KeyValues Property

Returns the KeyValues collection for the specified object.

See Also

Signature

object.KeyValues

object

Link
The object or objects this property applies to.

KeyValues

Object
The key values of the specified object.


 Label Property [Connectivity Automation Reference: CAR]

Label Property

Gets the label associated with the link.

See Also

Signature

object.Label

object

Link
The object or objects this property applies to.

Label

Label object; read-only
The label associated with the link.

Remarks

A Label object is returned only if the link type is either a freestanding label or an attached label.


 LabelTemplate Property [Connectivity Automation Reference: CAR]

LabelTemplate Property

Specifies the label template for the label.

See Also

Signature

object.LabelTemplate

object

Label
The object or objects this property applies to.

LabelTemplate

LabelTemplate object; read-only
The label template on which the label is based.


 LeaderAttachment Property [Connectivity Automation Reference: CAR]

LeaderAttachment Property

Specifies the leader attachment point for labels.

See Also

Signature

object.LeaderAttachment

object

LabelTemplate
The object or objects this property applies to.

LeaderAttachment

AcAttachmentPoint enum
A number indicating the attachment point. Specify one of the following constants:

acAttachmentPointTopLeft - Top Left

acAttachmentPointTopCenter - Top Center

acAttachmentPointTopRight - Top Right

acAttachmentPointMiddleLeft - Middle Left

acAttachmentPointMiddleCenter - Middle Center

acAttachmentPointMiddleRight - Middle Right

acAttachmentPointBottomLeft - Bottom Left

acAttachmentPointBottomCenter - Bottom Center

acAttachmentPointBottomRight - Bottom Right


 LeaderObjectId Property [Connectivity Automation Reference: CAR]

LeaderObjectId Property

Gets the object ID of the object attached to a label leader.

See Also

Signature

object.LeaderObjectId

object

Label
The object or objects this property applies to.

LeaderObjectId

Long; read-only
The object ID of the object attached to the leader. If the specified label object is a freestanding label, 0 is returned.


 LeaderOffset Property [Connectivity Automation Reference: CAR]

LeaderOffset Property

Specifies the leader offset point for labels.

See Also

Signature

object.LeaderOffset

object

LabelTemplate
The object or objects this property applies to.

LeaderOffset

Variant (array of Doubles)
The 3D WCS coordinates specifying the offset point for leaders in labels based on the specified label template.


 Linetype Property [Connectivity Automation Reference: CAR]

Linetype Property

Specifies the linetype for labels.

See Also

Signature

object.Linetype

object

LabelTemplate
The object or objects this property applies to.

Linetype

String
The linetype for labels.


 Link Property [Connectivity Automation Reference: CAR]

Link Property

Gets the link associated with the label.

See Also

Signature

object.Link

object

Label
The object or objects this property applies to.

Link

Link object; read-only
The link associated with the label.


 LinkTemplate Property [Connectivity Automation Reference: CAR]

LinkTemplate Property

Indicates the link template used by the specified object.

See Also

Signature

object.LinkTemplate

object

Link
The object or objects this property applies to.

LinkTemplate

Object; read-only
Indicates the link template used by the specified link.


 LinkType Property [Connectivity Automation Reference: CAR]

LinkType Property

Indicates the link type of the specified object.

See Also

Signature

object.LinkType

object

Link
The object or objects this property applies to.

LinkType

LinkType enum; read-only
Specifies whether the link is an entity link, a freestanding label, or an attached label. LinkType values are as follows:

2 - Entity link

4 - Freestanding label

8 - Attached label

1 - Unknown

Remarks

When referring to a LinkType value, you can use the following constants:

  • kEntityLinkType
  • kFSLabelType
  • kAttachedLabelType
  • kUnkownLinkType


 MTextObjectId Property [Connectivity Automation Reference: CAR]

MTextObjectId Property

Gets the object ID of the multiline text for the label.

See Also

Signature

object.MTextObjectId

object

Label
The object or objects this property applies to.

MTextObjectId

Long; read-only
The object ID of a label's MText object.


 Name Property [Connectivity Automation Reference: CAR]

Name Property

Stores the name of the specified object.

See Also

Signature

object.Name

object

LabelTemplate, LinkTemplate, Query
The object or objects this property applies to.

Name

String
Indicates the name of the specified object.


 NumericScale Property [Connectivity Automation Reference: CAR]

NumericScale Property

Indicates the numeric scale of the specified object.

See Also

Signature

object.NumericScale

object

KeyDescription
The object or objects this property applies to.

NumericScale

Integer
Specifies the number of decimal places of accuracy for the KeyDescription object.


 ObjectId Property [Connectivity Automation Reference: CAR]

ObjectId Property

Stores the object identification of the AutoCAD entity that the specified object is associated with.

See Also

Signature

object.ObjectId

object

Link
The object or objects this property applies to.

ObjectId

Long; read-only
The object ID of the entity the specified object is associated with.


 Precision Property [Connectivity Automation Reference: CAR]

Precision Property

Indicates the numeric precision of the specified object.

See Also

Signature

object.Precision

object

KeyDescription
The object or objects this property applies to.

Precision

Integer
Indicates the maximum number of digits allowable for a KeyDescription object.


 Rotation Property [Connectivity Automation Reference: CAR]

Rotation Property

Specifies the rotation angle for labels.

See Also

Signature

object.Rotation

object

LabelTemplate
The object or objects this property applies to.

Rotation

Double
The rotation angle in radians.

Remarks

The rotation angle is relative to the X axis of the object's WCS, with positive angles going counterclockwise when looking down from the Z axis toward the origin.


 Schema Property [Connectivity Automation Reference: CAR]

Schema Property

Holds the schema name value.

See Also

Signature

object.Schema

object

LabelTemplate, LinkTemplate, Query
The object or objects this property applies to.

Schema

String
The name of the database schema of the specified object.


 Table Property [Connectivity Automation Reference: CAR]

Table Property

Holds the table name value.

See Also

Signature

object.Table

object

LabelTemplate, LinkTemplate, Query
The object or objects this property applies to.

Table

String
The name of the database table for the specified object.


 Text Property [Connectivity Automation Reference: CAR]

Text Property

Specifies the SQL text of the query.

See Also

Signature

object.Text

object

Query
The object or objects this property applies to.

Text

String
The SQL statement of the query.


 TextAttachment Property [Connectivity Automation Reference: CAR]

TextAttachment Property

Specifies the text attachment point for labels.

See Also

Signature

object.TextAttachment

object

LabelTemplate
The object or objects this property applies to.

TextAttachment

AcAttachmentPoint enum
A number indicating the attachment point. Specify one of the following constants:

acAttachmentPointTopLeft - Top Left

acAttachmentPointTopCenter - Top Center

acAttachmentPointTopRight - Top Right

acAttachmentPointMiddleLeft - Middle Left

acAttachmentPointMiddleCenter - Middle Center

acAttachmentPointMiddleRight - Middle Right

acAttachmentPointBottomLeft - Bottom Left

acAttachmentPointBottomCenter - Bottom Center

acAttachmentPointBottomRight - Bottom Right


 TextHeight Property [Connectivity Automation Reference: CAR]

TextHeight Property

Specifies the text height for label text.

See Also

Signature

object.TextHeight

object

LabelTemplate
The object or objects this property applies to.

TextHeight

Double
The height for label text.


 TextStyle Property [Connectivity Automation Reference: CAR]

TextStyle Property

Specifies the text style for label text.

See Also

Signature

object.TextStyle

object

LabelTemplate
The object or objects this property applies to.

TextStyle

String
The name of the style used for label text.


 TipOffset Property [Connectivity Automation Reference: CAR]

TipOffset Property

Specifies the tip offset for label text.

See Also

Signature

object.TipOffset

object

LabelTemplate
The object or objects this property applies to.

TipOffset

Variant (three-element array of Doubles)
The tip offset for label text.


 Type Property [Connectivity Automation Reference: CAR]

Type Property

Specifies the data type of the current object.

See Also

Signature

object.Type

object

KeyDescription
The object or objects this property applies to.

Type

CaoDataType enum
The data type of the object. Can be one of the following constants:

kCaoTypeText

kCaoTypeNumeric

kCaoTypeInteger

kCaoTypeDouble

kCaoTypeDate

kCaoTypeTime

kCaoTypeTimestamp

kCaoTypeBit

kCaoTypeBlob


 Updatable Property [Connectivity Automation Reference: CAR]

Updatable Property

Indicates whether a particular link can be updated.

See Also

Signature

object.Updatable

object

Link
The object or objects this property applies to.

Updatable

Boolean; read-only
Specifies whether the link can be updated. If, for example, a link is on a locked layer, it cannot be updated until the layer is unlocked.


 Value Property [Connectivity Automation Reference: CAR]

Value Property

Holds the value for the specified object.

See Also

Signature

object.Value

object

KeyValue
The object or objects this property applies to.

Value

Variant
Stores the value for the KeyValue object.


 Version Property [Connectivity Automation Reference: CAR]

Version Property

Identifies the ASE version of the DbConnect object.

See Also

Signature

object.Version

object

DbConnect
The object or objects this property applies to.

Version

String; read-only
Indicates the version of the DbConnect object.


Event Reference [][AAR - ActiveX and VBA Reference: AAR]

Events

OnConnect Triggered when a connection to the data source is established.

OnDisconnect Triggered when the connection to the data source is closed.

OnLabelTemplateCreated Triggered when a new LabelTemplate is saved in the drawing.

OnLabelTemplateDeleted Triggered when a LabelTemplate is deleted from the drawing.

OnLabelTemplateModified Triggered when LabelTemplate changes are saved in the drawing.

OnLinkTemplateCreated Triggered when a new LinkTemplate is saved in the drawing.

OnLinkTemplateDeleted Triggered when a LinkTemplate is deleted from the drawing.

OnLinkTemplateModified Triggered when LinkTemplate changes are saved in the drawing.

OnQueryCreated Triggered when a Query is saved in the drawing.

OnQueryDeleted Triggered when a Query is deleted from the drawing.

OnQueryModified Triggered when Query changes are saved in the drawing.


 OnConnect [Connectivity Automation Reference: CAR]

OnConnect Event

Triggered when a connection to a data source is established.

See Also

Signature

object.OnConnect(Datasource)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Datasource

String; input to the handler
The name of the data source.


 OnDisconnect [Connectivity Automation Reference: CAR]

OnDisconnect Event

Triggered when a connection to a data source is closed.

See Also

Signature

object.OnDisconnect(Datasource)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Datasource

String; input to the handler
The name of the data source.


 OnLabelTemplateCreated [Connectivity Automation Reference: CAR]

OnLabelTemplateCreated Event

Triggered when a new label template is saved in a drawing.

See Also

Signature

object.OnLabelTemplateCreated(Document, LabelTemplateName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document in which the label template was created.

LabelTemplateName

String; input to the handler
The name of the label template that was created.

Remarks

This event may be triggered when a drawing containing label templates is opened.


 OnLabelTemplateDeleted [Connectivity Automation Reference: CAR]

OnLabelTemplateDeleted Event

Triggered when a label template is deleted from a drawing.

See Also

Signature

object.OnLabelTemplateDeleted(Document, LabelTemplateName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document from which the label template was deleted.

LabelTemplateName

String; input to the handler
The name of the label template that was deleted.


 OnLabelTemplateModified [Connectivity Automation Reference: CAR]

OnLabelTemplateModified Event

Triggered when label template changes are saved in a drawing.

See Also

Signature

object.OnLabelTemplateModified(Document, LabelTemplateName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document containing the label template that was modified.

LabelTemplateName

String; input to the handler
The name of the label template that was modified.

Remarks

In some instances when a label template is modified, dbConnect triggers the following sequence of events:

  1. OnLabelTemplateCreate <temporary name starting from ASE>
  2. OnLabelTemplateDelete <label template name being modified>
  3. OnLabelTemplateCreate <label template name being modified>
  4. OnLabelTemplateDeleted <temporary name from 1>


 OnLinkTemplateCreated [Connectivity Automation Reference: CAR]

OnLinkTemplateCreated Event

Triggered when a new link template is saved in a drawing.

See Also

Signature

object.OnLinkTemplateCreated(Document, LinkTemplateName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document in which the link template was created.

LinkTemplateName

String; input to the handler
The name of the link template that was created.

Remarks

This event may be triggered when a drawing containing link templates is opened.


 OnLinkTemplateDeleted [Connectivity Automation Reference: CAR]

OnLinkTemplateDeleted Event

Triggered when a link template is deleted from a drawing.

See Also

Signature

object.OnLinkTemplateDeleted(Document, LinkTemplateName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document from which the link template was deleted.

LinkTemplateName

String; input to the handler
The name of the link template that was deleted.


 OnLinkTemplateModified [Connectivity Automation Reference: CAR]

OnLinkTemplateModified Event

Triggered when link template changes are saved in a drawing.

See Also

Signature

object.OnLinkTemplateModified(Document, LinkTemplateName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document containing the link template that was modified.

LinkTemplateName

String; input to the handler
The name of the link template that was modified.

Remarks

In some instances when a link template is modified, dbConnect triggers the following sequence of events:

  1. OnLinkTemplateCreate <temporary name starting from ASE>
  2. OnLinkTemplateDelete <link template name being modified>
  3. OnLinkTemplateCreate <link template name being modified>
  4. OnLinkTemplateDeleted <temporary name from 1>


 OnQueryCreated [Connectivity Automation Reference: CAR]

OnQueryCreated Event

Triggered when a new query is saved in a drawing.

See Also

Signature

object.OnQueryCreated(Document, QueryName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document in which the query was created.

QueryName

String; input to the handler
The name of the query that was created.


 OnQueryDeleted [Connectivity Automation Reference: CAR]

OnQueryDeleted Event

Triggered when a query is deleted from a drawing.

See Also

Signature

object.OnQueryDeleted(Document, QueryName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document from which the query was deleted.

QueryName

String; input to the handler
The name of the query that was deleted.


 OnQueryModified [Connectivity Automation Reference: CAR]

OnQueryModified Event

Triggered when query changes are saved in a drawing.

See Also

Signature

object.OnQueryModified(Document, QueryName)

Object

DbConnect object
An object expression that evaluates to a DbConnect container object.

Document

String; input to the handler
The name of the document containing the query that was modified.

QueryName

String; input to the handler
The name of the query that was modified.


Query Tips

The following tips can help you get more useful results from your questions.

  • Filter your search by selecting only those documentation components that are likely to have the type of information you are looking for. Select a book or a set of books from the List of Documentation Components to Search.
  • Check your question for typographical errors. Important words may be ignored if they can't be recognized.
  • Write your query in the form of a question (How do I turn off dialog boxes?), or a phrase (turn off dialogs), or a keyword (dialogs). Each yields slightly different results.
  • Enter fewer words. Fewer words often produce better results.
    Example: maximum viewports returns a different list of topics than How do I increase the maximum displayable viewports?
  • Order your words differently. The order of words can affect your results.
    Example: maximum viewports is interpreted differently than viewports maximum.
  • Use different but similar words or terms in your question.
    Example: draw circles displays slightly different topics than create circles.
    Example: dialog boxes returns different results than dialogs.
  • Don't use punctuation characters. Use the Search tab if you need to search for terms that include any punctuation characters.
    Example: Entering file names such as acad.pat returns unreliable results.
  • Don't enter words that contain numbers.
    Example: Entering terms that include 3D returns unreliable results. You get better results if you spell out the term three dimensional.
  • Don't enter words that might be very commonly found in Help topics.
    Example: Entering drawing or line probably skews the results. Remove such words from your query or use more specific words.


See Also

Methods and Properties:

No related topics.


None .. go back!


zz [Blank Topic]

Blank Topic

This topic intentionally left blank.