Nápověda AutoCADu

Nápověda AutoCADu 2006 pro vývojáře

Vítejte v nápovědě AutoCADu 2006 pro vývojáře

Nápověda AutoCADu 2006 pro vývojáře nabízí kompletní informace týkající se přizpůsobení a rozšíření AutoCADu. Klepnutím na odkazy vpravo nebo pomocí karty Obsah můžete procházet tématy nápovědy.

Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

Moje nápověda
Zdroje na webu


Nápověda AutoCADu 2006

Příručka uživatelských přizpůsobení

Příručka uživatelských přizpůsobení nabízí zkušeným uživatelům informace o tom, jak si přizpůsobit AutoCAD. Příručku uživatelských přizpůsobení můžete procházet pomocí karty Obsah na levé straně okna nápovědy.

  • Základní přizpůsobení
  • Uživatelské typy čar
  • Uživatelské šrafovací vzory
  • Přizpůsobení uživatelského rozhraní
  • DIESEL
  • Snímky a příkazové skripty
  • Úvod do programových rozhraních
  • Tvary a písma tvarů
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


AutoLISP Reference

AutoLISP Reference nabízí kompletní popis AutoLISPu, interpretačního programovacího jazyka s mnoha funkcemi, který můžete použít k volání příkazů, systémových proměnných a dialogů AutoCADu. Následující témata jsou obsažena v příručce AutoLISP Reference:

  • AutoLISP Functions: Operators, A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z.
  • Externally Defined Commands
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


AutoLISP Developer's Guide

AutoLISP Developer's Guide nabízí informace o používání interaktivního vývojového prostředí Visual LISPu k vytváření a testování programů AutoLISPu. Příručka rovněž popisuje možnosti použití doplňků pomocí Visual LISPu pro tvorbu ActiveX® Automation. Následující témata jsou obsaženy v příručce AutoLISP Developer's Guide:

  • Introduction
  • Using the Visual LISP Environment
  • Using the AutoLISP Language
  • Working with Programmable Dialog Boxes
  • Appendixes
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


AutoLISP Výukový manuál

AutoLISP Výukový manuál nabízí jednotlivé lekce, které vás naučí pomocí jazyka Visual LISP™ vytvářet aplikace AutoLISP®. Následující témata jsou obsažena v příručce AutoLISP Výukový manuál:

  • Úvod
  • Návrh a začátek tvorby programu
  • Použití nástrojů pro odladění chyb
  • Kreslení hranice cesty
  • Tvorba projektu a přidání rozhraní
  • Kreslení dlaždic
  • Práce s reaktory
  • Dokončení operace
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


DXF Reference

DXF Reference nabízí kompletní popis formátu souboru DXF™. Následující témata jsou obsažena v příručce DXF Reference:

  • DXF Format
  • HEADER Section
  • CLASSES Section
  • TABLES Section
  • BLOCKS Section
  • ENTITIES Section
  • OBJECTS Section
  • THUMBNAILIMAGE Section
  • Drawing Interexchange File Formats
  • Advanced DXF Issues
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


ActiveX and VBA Developer's Guide

ActiveX and VBA Developer's Guide vysvětluje, jak pomocí ActiveX a VBA vytvářet aplikace k přizpůsobení programu AutoCAD. Příručka rovněž obsahuje vzorové kódy a postupy krok po kroku. Následující témata jsou obsaženy v příručce ActiveX and VBA Developer's Guide:

  • Introduction
  • Getting Started with VBA
  • ActiveX Automation Basics
  • Control the AutoCAD Environment
  • Create and Edit AutoCAD Entities
  • Dimensions and Tolerances
  • Customize Toolbars and Menus
  • Use Events
  • Work in Three-Dimensional Space
  • Define Layouts and Plot
  • Advanced Drawing and Organizational Techniques
  • Develop Applications with VBA
  • Interact with Other Applications and Windows APIs
  • Design the Garden Path--An ActiveX/VBA Tutorial
  • Visual LISP and ActiveX/VBA Comparison
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


ActiveX and VBA Reference

Příručka ActiveX and VBA Reference nabízí popis modelu objektů ActiveX a jejich asociované komponenty rozhraní. Následující témata jsou obsažena v příručce ActiveX and VBA Reference:

  • Object Model
  • Events
  • Methods
  • Properties
  • Objects
  • Code Examples
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


Sheet Set Objects Reference

Dokumentace Sheet Set Objects Reference nabízí referenční informace o objektech pro Správce sad listů. Následující témata jsou obsažena v dokumentaci Sheet Set Objects Reference:

  • Overview of Sheet Set Manager Objects
  • Objects
  • Methods
  • Properties
  • Enums
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


Connectivity Automation Reference

Connectivity Automation Reference nabízí popis modelu objektů Connectivity Automation a jejich asociované komponenty rozhraní. Následující témata jsou obsažena v Connectivity Automation Reference:

  • Connectivity Automation Objects
  • Object Model
  • Objects
  • Methods
  • Properties
  • Events
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


ObjectARX

ObjectARX®, programovací prostředí AutoCAD® Runtime Extension, obsahuje knihovny C++, které jsou stavebními bloky a lze je použít k vývoji aplikací AutoCADu, rozšíření tříd a protokolů AutoCADu a tvorbě nových příkazů fungujících stejně jako vestavěné příkazy AutoCADu.

Pokud je tato položka nápovědy zobrazena jako ikona stránky ( [image]) na kartě Obsah, není dokumentace ObjectARX zatím k dispozici v systému nápovědy.

Dokumentaci pro AutoCAD 2006 ObjectARX lze stáhnout z oblasti Centrum pro vývojáře na webu společnosti Autodesk. Chcete-li začlenit dokumentaci ObjectARX do dokumentace AutoCADu, zkopírujte soubory nápovědy ObjectARX do složky AutoCAD 2006\HELP\.
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


Moje nápověda

S názvem Moje nápověda můžete vytvořit vlastní skupinu témat nápovědy. Až přidáte téma vlastní nápovědy do nápovědy AutoCADu, témata budou dostupná pomocí karty Obsah, karty Rejstřík (přidáte-li položky rejstříku) a karty Hledat v levém panelu okna nápovědy. Klepnutím na téma Moje nápověda na kartě Obsah zobrazíte témata nápovědy, která byla přidána do nápovědy AutoCADu.

Informace o nastavení vlastní nápovědy nabízí Nastavení vlastní nápovědy.
Obecné informace

Soubory nápovědy

Příručka uživatelských přizpůsobení

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Výukový manuál

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX


Informace o verzi


Připomínky?

Pomocí tohoto formuláře můžete své připomínky odeslat do oddílení dokumentace společnosti Autodesk, které tuto dokumentaci zpracovává.

Název a pozice tématu (neměňte):
Název (volitelné):
         E-mail (volitelné):
Připomínky:

Poznámka: Tento formulář neslouží pro technickou podporu samotného produktu. Odeslané informace budou použity ke zlepšení budoucích aktuálních dokumentací. Děkujeme!


AnswerWorks®


Tipy k dotazům

Následující tipy vám mohou pomoci získat lepší výsledky při dotazování.

  • Hledání zjednodušte výběrem pouze určitých komponentů dokumentace, které vám mohou s největší pravděpodobností nabídnout požadované informace. V seznamu prohledávaných komponentů dokumentace vyberte jednu nebo více knih.
  • Zkontroluje dotaz, aby neobsahoval pravopisné chyby. Nebudou-li důležitá slova rozeznána, mohou být ignorována.
  • Dotazy pište ve formě otázky (Jak vypnout dialogy?), fráze (vypnutí dialogů) nebo klíčových slov (dialogy). Každý způsob nabízí trochu odlišné výsledky.
  • Zadejte méně slov. Zadáním méně slov často získáte lepší výsledky.
    Příklad: maximum výřezů vrátí odlišný seznam témat než Jak zvýšit maximální počet zobrazených výřezů?.
  • Změňte pořadí slov. Pořadí zadaných slov může ovlivnit výsledek.
    Příklad: maximum výřezů je zpracováno jinak než výřezy maximum.
  • Použijte v dotazu synonyma slov.
    Příklad: kreslení kružnice zobrazí mírně odlišná témata než tvorba kružnic.
    Příklad: dialogová okna vrátí jiné výsledky než dialogy.
  • Nepoužívejte interpunkci. Potřebujete-li hledat pojmy obsahující interpunkční znaky, použijte kartu Hledat.
    Příklad: Zadání názvů souborů, například acad.pat, vrátí nespolehlivé výsledky.
  • Nezadávejte slova s číslicemi.
    Příklad: Zadání slov obsahujících 3D vrátí nespolehlivé výsledky. Lepších výsledků docílíte, rozepíšete-li takové slovo na trojrozměrný.
  • Nezadávejte běžně používaná slova v tématech nápovědy.
    Příklad: Zadáním výkres nebo úsečka nedocílíte žádoucích výsledků. Taková slova odstraňte z dotazu nebo používejte specifičtější slova.


Autorská práva a obchodní značky

Copyright © 2005 Autodesk, Inc.

Všechna práva vyhrazena

Tato publikace ani její části nesmí být reprodukovány v žádné podobě, žádným způsobem a pro žádný účel.

SPOLEČNOST AUTODESK, INC. NEPOSKYTUJE K TĚMTO MATERIÁLŮM ŽÁDNÉ PŘEDPOKLÁDANÉ ANI EXPLICITNĚ VYJÁDŘENÉ ZÁRUKY, VČETNĚ PŘEDPOKLÁDANÝCH OBCHODNÍCH ZÁRUK A ZÁRUKY VHODNOSTI PRO DANÝ ÚČEL. UZNÁVÁ A ZPŘÍSTUPŇUJE TYTO MATERIÁLY POUZE ZA ZDE POPSANÝCH PODMÍNEK.

SPOLEČNOST AUTODESK, INC. NENÍ V ŽÁDNÉM PŘÍPADĚ ZODPOVĚDNÁ ZA MIMOŘÁDNÉ, NEPŘÍMÉ, NÁHODNÉ NEBO NÁSLEDNÉ ŠKODY VZNIKLÉ KOUPÍ NEBO POUŽITÍM TĚCHTO MATERIÁLŮ. JEDINÁ A VÝHRADNÍ ODPOVĚDNOST SPOLEČNOSTI AUTODESK, INC., BEZ OHLEDU NA FORMU ČINNOSTI, NEPŘESAHUJE KUPNÍ CENU ZDE POPSANÝCH MATERIÁLŮ.

Společnost Autodesk, Inc. si vyhrazuje právo na revizi a vylepšení produktů, jak uzná za vhodné. Tato publikace popisuje stav produktu v době jejího vydání a nemusí odrážet stav produktu v budoucnosti.

Obchodní značky společnosti Autodesk

Následující značky jsou registrované obchodní značky společnosti Autodesk, Inc. v USA a dalších zemích: 3D Studio, 3D Studio MAX, 3D Studio VIZ, 3ds max, ActiveShapes, ActiveShapes (logo), Actrix, ADI, AEC-X, ATC, AUGI, AutoCAD, AutoCAD LT, Autodesk, Autodesk Envision, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, Autodesk WalkThrough, Autodesk World, AutoLISP, AutoSketch, backdraft, Biped, bringing information down to earth, Buzzsaw, CAD Overlay, Character Studio, Cinepak, Cinepak (logo), cleaner, Codec Central, combustion, Design Your World, Design Your World (logo), EditDV, Education by Design, gmax, Heidi, HOOPS, Hyperwire, i-drop, IntroDV, lustre, Mechanical Desktop, ObjectARX, Physique, Powered with Autodesk Technology (logo), ProjectPoint, RadioRay, Reactor, Revit, VISION*, Visual, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Toolbox, Visual Tugboat, Visual LISP, Volo, WHIP! a WHIP! (logo).

Následující značky jsou obchodní značky společnosti Autodesk, Inc. v USA a jiných zemích: AutoCAD Learning Assistance, AutoCAD LT Learning Assistance, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, AutoSnap, AutoTrack, Built with ObjectARX (logo), burn, Buzzsaw.com, CAiCE, Cinestream, Civil 3D, cleaner central, ClearScale, Colour Warper, Content Explorer, Dancing Baby (obrázek), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, Design Web Format, DWF, DWFit, DWG Linking, DXF, Extending the Design Team, GDX Driver, gmax (logo), gmax ready (logo),Heads-up Design, jobnet, mass, ObjectDBX, onscreen onair online, Plasma, PolarSnap, Productstream, Real-time Roto, Render Queue, Visual Bridge, Visual Syllabus, and Where Design Connects.

Obchodní značky společnosti Autodesk Canada Inc.

Následující značky jsou registrované obchodní značky společnosti Autodesk Canada Co. v USA, Kanadě a dalších zemích: discreet, fire, flame, flint, flint RT, frost, glass, inferno, MountStone, riot, river, smoke, sparks, stone, stream, vapour, wire.

Následující značky jsou obchodní značky společnosti Autodesk Canada Co. v USA, Kanadě a jiných zemích: backburner, Multi-Master Editing.

Obchodní značky třetích stran

Všechny ostatní značky, názvy výrobků a obchodní značky patří příslušným vlastníkům.

Autorská práva pro software třetích stran

ACIS Copyright © 1989-2001 Spatial Corp. Části Copyright © 2002 Autodesk, Inc.

AnswerWorks ® Copyright © 1997-2003 WexTech Systems, Inc. Části tohoto softwaru © Vantage-Knexys. Všechna práva vyhrazena.

Flash ® je registrovaná obchodní značka společnosti Macromedia, Inc. v USA a jiných zemích.

Copyright © 1997 Microsoft Corporation. Všechna práva vyhrazena.

Copyright © Stade de France - Macary, Zublena et Regembal, Costantini - Architectes, ADAGP - Paris - 2003

Mezinárodní systém kontroly pravopisu CorrectSpell™ © 1995 od společnosti Lernout & Hauspie Speech Products, N.V. Všechna práva vyhrazena.

InstallShield™ 3.0. Copyright © 1997 InstallShield Software Corporation. Všechna práva vyhrazena.

Macromedia Flash™ Player Copyright © 1995-2003 Macromedia, Inc. Všechna práva vyhrazena. Macromedia a Flash jsou obchodní značky společnosti Macromedia, Inc.

Barvy PANTONE ® Colors zobrazeny v softwaru nebo uživatelské dokumentaci nemusí odpovídat standardům PANTONE. Přesné barvy naleznete v aktuálních publikacích PANTONE Color Publications.

PANTONE ® a jiné obchodní značky Pantone, Inc. jsou majetkem společnosti Pantone, Inc. © Pantone, Inc., 2002

Pantone, Inc. je autorským vlastníkem dat nebo softwaru barev, jejichž licenci má společnost Autodesk, Inc. k distribuci pouze spolu s jistými produkty společnosti Autodesk. PANTONE Color Data nebo Software nebude za žádných podmínek kopírován na jiný disk nebo do paměti kromě případů spuštění jako součást tohoto softwarového produktu společnosti Autodesk.

Části Copyright © 1991-1996 Arthur D. Applegate. Všechna práva vyhrazena.

Části tohoto softwaru vychází z práce Independent JPEG Group.

RAL DESIGN © RAL, Sankt Augustin, 2002

RAL CLASSIC © RAL, Sankt Augustin, 2002

Barvy RAL Colors jsou reprezentovány se souhlasem institutu RAL Deutsches Institut für Gütesicherung und Kennzeichnung e.V. (RAL German Institute for Quality Assurance and Certification, re. Assoc.), D-53757 Sankt Augustin."

Písma od společnosti Bitstream ® knihovna písem copyright 1992.

Písma od společnosti Payne Loving Trust © 1996. Všechna práva vyhrazena.

POUŽITÍ VE STÁTNÍ SPRÁVĚ

Použití, kopírování nebo vyzrazení státní správou USA podléhá omezením, která jsou ustanovena v předpisu FAR 12.212 (Právo o posuzování komerčního počítačového softwaru) a DFAR 227.7202 (Právo v technických datech a počítačovém softwaru).


Nastavení vlastní nápovědy

Chcete-li nastavit vlastní nápovědu, je nutné vytvořit témata nápovědy v jazyce HTML a potom je kompilovat pomocí Microsoft HTML Help Workshop, aby se vytvořil kompilovaný soubor nápovědy myhelp.chm. Zkopírujte tento soubor do složky AutoCAD\Help.

Jak zobrazit názvy témat s odkazy v hlavním tématu vlastní nápovědy

  • Začleňte soubor obsahující seznam názvů příslušných témat do souboru CHM. Tento soubor nazvěte myhelp_toc.html.

Jak zobrazit názvy témat na kartě Obsah

  • Začleňte soubor HHC (obsah nápovědy) obsahující seznam názvů příslušných témat do souboru CHM.

Jak zobrazit položky rejstříku přidané do témat nápovědy

  • Začleňte soubor HHK (rejstřík nápovědy) do souboru CHM.

I když do souboru CHM nezačleníte soubor myhelp_toc.html nebo soubory HHC a HHK, obsah souboru CHM bude i přesto stále dostupný na kartě Hledat.

Při tvorbě vlastní nápovědy můžete nahlédnout do vzorových souborů, které nabízí Moje nápověda. Rozbalte vzorové soubory myhelp.zip.


zz [Blank Topic]

Prázdné téma

Toto téma je záměrně prázdné.