Soubor Readme AutoCADu 2006: Úvod

Soubor Readme AutoCADu 2006

Tento soubor Readme obsahuje důležité informace o verzi programu AutoCAD® 2006, které nemusí být nezbytně zdokumentovány v tištěné dokumentaci nebo v nápovědě.

  • Instalace, konfigurace a hardware
  • Aktualizace ovladače grafické karty
  • Kreslení a úpravy
  • Vykreslování a publikování
  • Text a jazyk
  • Informace pro vývojáře
  • Historie příkazů a systémových proměnných
  • Ochranné známky


Instalace, konfigurace a hardware

Instalace a konfigurace

Klíče registru zachované po odinstalaci

  • Pokud nebyl nikdy nainstalován prohlížeč Autodesk® DWFTM Viewer, zůstane po odinstalaci AutoCADu v registru pravděpodobně následující prázdný klíč:
    • HKLM\Software\Autodesk
  • Odinstalace prohlížeče DWF Viewer zachová následující klíče registru:
    • Software\Autodesk\DWF Common
    • Software\Autodesk\DWF Viewer

Instalace aplikace Adobe Reader

  • Pokusíte-li se o instalaci aplikace Adobe Reader v případě, že bude uživatelské jméno systému Windows obsahovat 8bitové nebo 2bajtové znaky (například znaky s přízvukem nebo asijské znaky) a použijete systém souborů FAT32, dojde k selhání instalace.

    Chcete-li vyřešit tento problém, vytvořte nové jméno uživatele systému Windows obsahující pouze znaky ASCII, přihlašte se a poklepejte na soubor EXE v adresáři Bin\ACADFeui\Support\Adobe na disku CD produktu.

    Pokud nelze nové jméno uživatele systému Windows vytvořit, požádejte o to správce systému.

Hlášení chyb

  • Chybová zpráva zobrazovaná při neočekávaném ukončení relace AutoCADu obsahuje doporučení, abyste chybové zprávy odeslali společnosti Autodesk. Chybové zprávy pomáhají společnosti Autodesk identifikovat mnoho potíží týkajících se produktu. Chybová zpráva je stená jako při neočekávaném ukončení aplikace v počítači s operačním systémem Microsoft® Windows® XP. Chybová zpráva zaznamená tu část produktu, která se při ukončení pracovní relace používá. V chybové zprávě stiskněte tlačítko Volitelné údaje, zadejte následující informace a potom stiskněte tlačítko Odeslat zprávu:
    • Informace o tom, co jste dělali v AutoCADu předtím, než došlo k neočekávanému ukončení běhu programu.
    • Vaše kontaktní údaje.

    Poskytnutím těchto informací pomůžete společnosti Autodesk chybu reprodukovat a opravit v nejkratší možné době. Pokud dojde k neočekávanému ukončení relace AutoCADu, ale chybová zpráva se nezobrazí, zkontrolujte, zda je systémová proměnná REPORTERROR nastavena na hodnotu 1.

Co je nového

  • Pokud se okno Co je nového po instalaci AutoCADu nezobrazí správně, restartujte systém.

Digitální podpisy

  • Implicitně je nyní narozdíl od předchozích verzí AutoCADu ikona digitálního podpisu v Průzkumníkovi Windows instalována ve vypnutém stavu.

    Zapnutí funkce digitálních podpisů
    1. Ve složce windows\system32 poklepejte na soubor AcSignOpt.exe.
    2. V dialogovém okně Možnosti ověření podpisu se ujistěte, že je zaškrtnuto následující políčko: Ověřovat digitální podpisy a zobrazovat speciální ikony. Klepněte na tlačítko OK.
    3. Změna se projeví po restartování systému Windows.

Hardware

Aktualizace ovladače grafické karty

  • V zájmu maximálního výkonu byste měli zkontrolovat a aktualizovat ovladač grafické karty. Další informace naleznete v tématu Aktualizace ovladače grafické karty.

Výkonnost 3D grafiky

  • Pokud máte grafickou kartu, která podporuje OpenGL, můžete dosáhnout zvýšení grafické výkonnosti a produktivity při práci s 3D modely tak, že zapnete hardwarovou akceleraci. Některé grafické karty a ovladače, které podporují OpenGL, však nemusí být po zapnutí volby Hardwarová akcelerace kompatibilní s AutoCADem. Tato nekompatibilita může mít za následek nepředvídatelné problémy s AutoCADem.

    Zapnutí hardwarové akcelerace
    1. V nabídce Nástroje vyberte položku Možnosti.
    2. V dialogovém okně Možnosti klepněte na kartě Systém v poli Aktuální 3D grafický displej na tlačítko Vlastnosti.
    3. V dialogovém okně Konfigurace 3D grafického systému vyberte v poli Akcelerace volbu Hardware a potom klepněte na tlačítko Použít & Zavřít.

Ovladač tiskárny Hewlett-Packard DesignJet

  • Společnost Autodesk již na disku CD produktu neposkytuje ovladač systému Windows tiskáren řady Hewlett-Packard DesignJet. V případě potřeby si můžete ovladač stáhnout na adrese http://www.designjet.hp.com.


Aktualizace ovladače grafické karty

V zájmu optimalizace AutoCADu doporučujeme zkontrolovat a aktualizovat ovladač grafické karty. Pomocí následujícího postupu zjistěte aktuální ovladač grafické karty.

Zjištění ovladače grafické karty

  1. Pravým tlačítkem myši klepněte na plochu systému Windows a v místní nabídce potom klepněte na příkaz Vlastnosti.
  2. V dialogovém okně Vlastnosti zobrazení klepněte na kartu Nastavení.
  3. Na kartě Nastavení klepněte na tlačítko Upřesnit a potom klepněte na kartu Adaptér.
  4. Poznamenejte si informace o systémovém ovladači grafické karty.

    Pokud potřebujete ovladač aktualizovat, navštivte webovou stránku prodejce grafické karty a stáhněte si nejnovější ovladač pro svůj operační systém. Aktualizovaný ovladač načtete následujícím způsobem.

Načtení aktualizovaného ovladače

  1. Pravým tlačítkem myši klepněte na plochu systému Windows a v místní nabídce potom klepněte na příkaz Vlastnosti.
  2. V dialogovém okně Vlastnosti zobrazení klepněte na kartu Nastavení.
  3. Na kartě Nastavení klepněte na tlačítko Upřesnit a potom klepněte na kartu Adaptér.
  4. Na kartě Adaptér klepněte na tlačítko Vlastnosti a poté klepněte na kartu Ovladač.
  5. Klepněte na tlačítko Aktualizovat ovladač.
  6. Při instalaci ovladače postupujte podle pokynů.


Kreslení a úpravy

Prostředí výkresu

Palety nástrojů

  • Palety nástrojů můžete používat pouze ve verzi produktu, ve které byly vytvořeny. Paletu nástrojů vytvořenou v AutoCADu 2006 například nelze použít v AutoCADu 2005.

Soubory uživatelských úprav se stejným názvem

  • Při načítání částečných nabídek AutoCAD nejdříve prohledá cestu k podpůrným souborům (definovanou na kartě Soubory v dialogovém okně Možnosti). Pokusíte-li se načíst soubor uživatelských úprav (CUI), který se v názvu shoduje s jiným souborem, načte program automaticky soubor umístěný v cestě k podpůrným souborům bez ohledu na vámi vybraný soubor. Chcete-li předejít záměně, zajistěte, aby byly názvy souborů jedinečné.

Pracovní prostory

  • Pokud v dialogovém okně Nastavení pracovního prostoru vyberete volbu Automaticky ukládat změny pracovního prostor, bude po ukončení produktu automaticky uložen aktuální pracovní prostor. Pracovní prostor však uložen nebude v případě, že AutoCAD ukončíte, aniž by obsahoval otevřený výkres. Chcete-li zajistit, aby byl pracovní prostor při ukončení uložen, uložte pracovní prostor před zavřením posledního výkresu pomocí příkazu ULOŽPRACPROST, nebo zajistěte, aby byl před ukončením AutoCAD otevřený alespoň jeden výkres.

Dynamický vstup

Dynamický vstup a okno příkazu

  • Účelem dynamického vstupu není nahrazení okna příkazu. Skrytím okna příkazu můžete rozšířit oblast výkresu, u některých operací je však bude nutné zobrazit. Stisknutím klávesy F2 můžete příkazové výzvy a chybové zprávy podle potřeb skrýt nebo zobrazit. Ukotvení okna příkazu můžete také zrušit a pomocí funkce pro automatické skrytí je otevřít nebo posunout nahoru.

Pokyny pro dynamický vstup

  • Hodnoty souřadnic můžete nyní místo do příkazové řádku zadávat do nápovědy. Hodnoty souřadnic X,Y zadávané pro většinu příkazů jsou implicitně interpretovány jako relativní polární souřadnice, nikoli absolutní souřadnice, jak tomu bylo v předchozích verzích produktu. K zadání relativních souřadnic není obvykle potřeba použít znak zavináč (@). Stačí zadat hodnoty relativního odsazení. Pro označení absolutních souřadnic použijte předponu představující křížek (#). Chcete-li například posunout objekt na počátek výkresu, zadejte do výzvy k zadání druhého bodu hodnotu #0,0.
  • Systémová proměnná DYNPICOORDS určuje, zda bude ukazatel vstupu pro souřadnice používat relativní nebo absolutní formát. Toto nastavení můžete dočasně změnit pomocí předpon:
    • Chcete-li při zobrazení relativních souřadnic v nápovědě zadat absolutní souřadnice, zadejte křížek (#).
    • Chcete-li při zobrazení absolutních souřadnic zadat relativní souřadnice, zadejte zavináč (@).
    • Chcete-li zadat absolutní souřadnice globálního souřadnicového systému (GSS), zadejte hvězdičku *.
  • Pokud je zapnutý rozměrový vstup (DYNMODE = 2 nebo 3) a zadáte čárku (,), lomenou závorku (<) nebo vyberete více uzlů, přepne program do vstupu ukazatele.
  • Zadáte-li hodnotu rozměru a stisknete klávesu TAB, zobrazí se v poli ikona zámku a kurzor bude omezený na vámi zadanou hodnotu.
  • Zadáte-li hodnoty do nápovědy dynamického vstupu v případě, že je kurzor mimo oblast výkresu a nápověda není zobrazena, může to mít neočekávané následky.
  • Dynamický vstup není podporován v perspektivních pohledech.

Rozměrový vstup a uzly

  • Chování produktu se změnilo v případech, kdy při zapnutím rozměrovém vstupu (DYNMODE = 2 nebo 3) protáhnete pomocí uzlů vrcholy. Chování se při zadání jedné přímé hodnoty vzdálenosti od předchozích verzí liší. V tomto případě totiž upravujete celkovou délku nebo hodnotu úhlu segmentu, nikoli pozici vrcholu. V zájmu dosaženích nejlepších výsledků vypněte rozměrový vstup nastavením proměnné DYNMODE na hodnotu 0 nebo 1, stisknutím klávesy F12 nebo klepnutím na tlačítko dynamického vstupu (DYN) na stavovém řádku.

Rozměrový vstup - úpravy uzlů a úhly

  • Protáhnete-li pomocí uzlů objekty nebo vytvoříte nové objekty, zobrazí ukazatel rozměrového vstupu pouze ostré úhly. To znamená, že budou všechny úhly svírat 180 stupňů a méně. Z tohoto důvodu bude úhel o velikosti 270 stupňů zobrazen jako 90stupňový, bez ohledu na směr úhlu nastavený v dialogovém okně Výkresové jednotky. Specifikace úhlů se při určení směru kladného úhlu řídí směrem pohybu kurzoru.

Procházení výběru objektů

  • Při procházení objektů pomocí klávesy TAB se chování liší v závislosti na nastavení dynamického vstupu:
    • Rozměrový vstup (DYNMODE=3): Vyberete-li více objektů, které sdílí společný uzel, a potom na uzel klepnete myší, bude klávesa TAB procházet všechny rozměry jednotlivých vybraných objektů.
    • Vstup ukazatele (DYNMODE=1): Pokud během provádění příkazu zadáte hodnotu, použijte pro zobrazení dalších vstupních polí místo klávesy TAB levou zalomenou závorku (<) nebo čárku (,).

Vkládání hodnot do nápovědy dynamické výzvy

  • Chcete-li do nápovědy dynamické výzvy vložit hodnoty ze schránky systému Windows pomocí příkazu SVLOŽ, zadejte do nápovědy písmeno potom před vložením pomocí klávesy BACKSPACE písmeno odstraňte. V opačném případě bude položka do výkresu vložena jako text.

Další otázky týkající se kreslení

Dočasné přednostní klávesy

  • Dobu odezvy klávesnice můžete pro dočasné přednostní klávesy upravit změnou nastavení v Ovládacích panelech systému Windows.

    Úprava doby odezvy dočasné přednostní klávesy
    1. V nabídce Start systému Windows klepněte na položku Nastavení > Ovládací panely.
    2. V Ovládacích panelech klepněte na panel Klávesnice.
    3. V dialogovém okně Klávesnice - vlastnosti upravte na kartě Rychlost dobu odezvy klávesnice přetažením jezdce Rychlost opakování. Potom klepněte tlačítko OK.

Asociativní kóty

  • Chcete-li, aby se vždy po otevření výkresu implicitně zapnulo asociativní kótování, přidejte do souboru acad2006doc.lsp, který se nachází v adresáři Support, tento řádek:

    (setvar "DIMASSOC" 2)

Po otevření výkresu, který byl modifikován v některé předchozí verzi nebo po otevření výkresu s externími referencemi, které byly modifikovány, použijte pro aktualizaci kót KÓTYREGEN. Chcete-li aktualizovat kóty automaticky, můžete do souboru acad2006doc.lsp v adresáři Support přidat tento řádek:

(command "KÓTYREGEN")

Plné šrafování

  • Výkresy obsahující plné šrafování mohou vytvářet větší soubory vykreslení než výkresy s ostatními typy šraf.

Hladiny a hodnoty tloušťky čar

  • Chcete-li vytvářet pojmenované filtry hladin pomocí kritérií tloušťky čar, zadejte do pole Tloušťka čáry v dialogovém okně Pojmenované filtry hladin hodnoty tloušťky čar tak, jak jsou uvedeny v Seznamu tloušťky čar (například zadejte 0.30 mm s mezerou mezi číslem a "mm"). Při nastavování filtru podle kritérií tloušťky čáry lze také použít zástupné znaky (zadejte například *3*). Chcete-li nastavit filtr pro více hodnot tloušťky čáry, je nutno hodnoty oddělit čárkami, bez mezer (zadejte například 0.30 mm,0.1*). Vlastní hodnoty tloušťky čáry jsou implementovány prostřednictvím stylů vykreslování a nelze je aplikovat na hladiny, objekty ani pojmenované filtry hladin.

Nepravoúhlé výřezy

  • Pokud přiřadíte nepravoúhlému výřezu nesouvislý typ čáry, může to vést k nerovnoměrnému oříznutí geometrie modelového prostoru uvnitř výřezu nebo nestabilitě programu AutoCAD.
  • Pokud použijete příkazy PIŠJPG, PIŠPNG, PIŠBMP a PIŠTIF v rámci rozvržení, které obsahuje nepravoúhlé výřezy a 3D nastavení SHADEMODE, a vyberete všechny objekty a výřezy, mohou být části jiných výřezů zakryté a objekty nemusejí být viditelné. Přesnější rastrový výstup získáte pomocí příkazu PUBLIKUJ.
  • Nenastavujte jako zmrazené hladiny, které obsahují nepravoúhlé výřezy; namísto toho hladiny s nepravoúhlými řezy vypněte nebo nastavte vlastnost Vykreslovat dané hladiny na Nevykreslovat. Pokud nastavíte jako zmraženou hladinu, která obsahuje nepravoúhlý výřez, nastaví se pravoúhlé ohraničení výřezu. Objekty ve výřezu, které by měly být oříznuty okrajem nepravoúhlého výřezu, skutečně vypadají jako oříznuté; pokud ale výkres zregenerujete nebo vykreslíte, objekty nebudou oříznuté, jak byste očekávali. Napravit tento problém, pokud nastane, lze tak, že hladinu rozmrazíte a výkres poté zregenerujete.

Značky AutoSnap

  • Použijete-li uchopování objektů, budou při přesunutí ukazovacího zařízení nad tyto objekty značky AutoSnapTM označovat místa uchopení. Tyto značky za normálních okolností zmizí, jakmile posunete ukazovací zařízení do jiné části výkresu, za určitých podmínek mohou ale na obrazovce zůstat. To se týká pouze uchopení objektů Průsečíků a Zdánlivých průsečíků, a dále pouze tehdy, je-li na kartě Kreslení v dialogu Volby vymazána volba Zobrazovat polární konstrukční čáry. Značky AutoSnap v této situaci ovlivňují pouze zobrazení výkresu; nejsou součástí vlastního výkresu. Chcete-li tyto značky odstranit, výkres zavřete a znovu otevřete.

Vnořené Xrefy

  • Vnořené externí odkazy (xref) můžete překládat pomocí relativních cest. Relativní cesta je založena na umístění původního hostitelského výkresu externí reference, nikoliv na aktuálně otevřeném výkresu. Pokud je vnořený xref hlášen jako "nenalezen," editujte cestu v původním hostitelském výkresu, nikoliv v aktuálně otevřeném hostitelském výkresu. Nastavení systémové proměnné VISRETAIN již neurčuje vyhodnocování relativních cest vnořených externích referencí.

Uspořádání projektu

Sady listů

  • Správce sady listů není plně funkční v následujících případech:
    • Je aktivní příkaz.
    • Není otevřen žádný výkres.
    • Sada listů je uzamčena jiným uživatelem.
    • Ikona zámku zobrazená před názvem sady listů ve Správci sady listů označuje, že je sada listů uzamčena. Zastavením kurzoru nad ikonou zámku zobrazíte informace o tom, kdo danou sadu listů uzamknul.
  • Jestliže vyberete list ve Správci sady listů, stav listu může být v poli Detaily chybně vypsán jako Zamčeno pro editaci pro Neznámý. Chcete-li stav listu aktualizovat, otevřete jej.
  • V sítích Novell Správce sady listů ikonu zámku po uzamčení sady listů jiným uživatelem nezobrazí. Volby místní nabídky ve Správci sady listů jsou zobrazeny, ale některé nemusí fungovat.
  • Pokud odstraníte list ze sady listů a potom importujete list zpět do sady listů, budou pole, která zobrazují informace o sadě listů v atributu bloku, zobrazena jako znaky libry. Chcete-li tato pole opravit, můžete pole znovu vytvořit nebo blok znovu vložit. Pokud pole znovu vytvoříte, protože list je již v sadě listů, měli byste použít pole vlastnosti sady listů a ne zástupné pole.
  • Pole sady listů (pole, která byla vybrána z kategorie sady listů) se chovají odlišně než jiné typy polí. Implicitně jsou ostatní typy polí aktualizovány automaticky při uložení výkresu nebo při použití příkazu REGEN. Naopak pole sady listů uchovávají poslední použité hodnoty a tyto hodnoty zobrazí, pokud nejsou informace odkazované polem sady listů dostupné. Chcete-li aktualizovat hodnotu v poli sady listů, použijte příkaz AKTUALIZUJTPOLE. Pokud není informace odkazovaná polem sady listů stále nedostupná, hodnota pole bude zobrazena jako ####.

Použití jednoho souboru DWT pro nastavení stránek a bloky v síti

  • Některé funkce listu nejsou k dispozici v případě, že dva síťoví uživatelé přistupují k sadě listů využívající pro odkazovací nebo označovací bloky, šablonu listu a změny nastavení stránky stejný soubor šablony výkresu (DWT). Chcete-li tomuto problému předejít, nepoužívejte k ukládání nastavení stránek a knihoven bloků stejný soubor DWT.


Vykreslování a publikování

Vykreslení a tisk výkresů

Orientace papíru a obrazu

  • V případě některých plotrů lze načíst stejnou velikost papíru dvěma různými způsoby: na šířku nebo na výšku. V případě plotrů s posuvným válcem je typicky stejná velikost papíru uvedena v nabídce Velikost papíru dvakrát, např. ANSI A (8.5 x 11 palců) a ANSI A (11 x 8.5 palců). U většiny stolních tiskáren lze papír vložit pouze jedním způsobem, obvykle na výšku.

    AutoCAD automaticky otáčí vykreslování tak, aby byl obrázek papíru na obrazovce zobrazen na výšku, a to i v případě, že je papír do plotru vložen na šířku. Skutečnou orientaci papíru můžete zobrazit pomocí plného náhledu.

    Oblast Orientace výkresu v dialogových oknech Nastavení stránky a Vykreslit obsahuje obrázek znázorňující orientaci papíru tak, jak je vložen do plotru. Písmeno A znázorňuje orientaci vykreslených objektů. Většina stolních tiskáren využívá orientaci papíru na výšku, přičemž vykreslení je pro zobrazení na šířku otočeno.

    Klepnutím na obrázek v dialogovém okně Vlastnosti tiskárny můžete zobrazení orientace pro tiskárny systému Windows změnit. Změna tohoto nastavení bude mít vliv pouze na velikost tisknutelné oblasti, nikoli na orientaci vykreslovaného obrázku nastavenou v dialogových oknech Nastavení stránky a Vykreslit. Při vykreslování výkresu v takové formě, v jaké jste jej vytvořili, nastavení pomocí tlačítek Na šířku/Na výšku v dialogu Uživatelské vlastnosti neměňte.

Publikování výkresů

Objekty s gradienty

  • Při publikování do souborů DWF se mohou objekty s gradienty jevit posunuté nebo úplně zmizet. K tomuto problému dochází v případě, že není rozlišení gradientů nastaveno na stejnou hodnotu jako rozlišení vektorů. Chcete-li tento problém vyřešit, upravte uživatelské vlastnosti ovladače DWF6 ePlot a nastavte rozlišení gradientů na stejnou hodnotu jako rozlišení vektorů. Pokud chcete upravit uživatelské vlastnosti, klepněte v dialogovém okně Vykreslit na tlačítko Vlastnosti > uzel Uživatelské vlastnosti > tlačítko Uživatelské vlastnosti.

Prostorový náhled souboru DWF

  • Pomocí příkazu PUBLIK3DDWF můžete zobrazit náhled technologie publikování 3D DWFTM. Po zpracování vybraných objektů můžete výstup souboru 3D DWF zobrazit pomocí prohlížeče Autodesk DWF Viewer.
  • Náhled pomocí technologie publikování 3D DWF má následující omezení:
    • Nejsou podporovány nekonečné čáry (přímky, polopřímky).
    • Nejsou podporovány roviny oříznutí a ořezávání externích odkazů.
    • Nejsou podporovány objekty OLE a vkládané obrázky.
    • Nejsou podporovány hypertextové odkazy.
    • Textová písma jsou převáděna na písmo Arial.
    • Není podporováno formátování textu.
    • Prohlížeč Autodesk DWF Viewer otevírá soubory pouze v režimu stínování.
    • Šrafy s gradientovými výplněmi zobrazují implicitní barvu hladiny.
    • V publikovaném souboru DWF se nezobrazují správně různé typy a tloušťky čar.
    • Režim jen s hranami a režim stínování s hranami zobrazí v prohlížeči Autodesk DWF Viewer objekty s trojúhelníkovými plochami. Používejte proto pouze režim stínování.


Text a jazyk

Text

Změna písma v souborech DXF

  • Pokud byl použit styl Big Font SHX, po uložení souboru DXFTM se informace o změně písma použijí automaticky na celý odstavcový objekt. Výsledkem bude, že pokud změníte aktuální styl textu na jiné písmo, tato změna se nepoužije na odstavcový text, dokud znovu nepoužijete styl na celý objekt odstavcového textu.

Jazyk

Podpora více jazyků

  • Zkopírujete-li a vložíte znaky vytvořené pomocí jiného než systémového jazyka, nebudou se znaky pravděpodobně zobrazovat správně. Zobrazení můžete opravit pomocí Lokálního editoru textu.

    Oprava a zobrazení původního jazyka
    1. Poklepání otevřete text v Lokálním editoru textu.
    2. Pravým tlačítkem myši klepněte do editoru. Klepněte na položku Znaková sada a zvolte původní jazyk.
  • Chcete-li zobrazovat a upravovat výkresy obsahující znaky, které nejsou součástí jazyků pro daný operační systém, zajistěte, aby byla v daném operačním systému počítače nainstalována doplňková podpora jazyků. Jazyk můžete zadat v dialogovém okně Místní a jazykové nastavení, které naleznete v Ovládacích panelech systému Windows. (Text využívající písmo SHX bude pravděpodobně možné zobrazit bez zadání zvláštní jazykové podpory.)
  • Textové styly asijských jazyků využívající písmo SHX a velké písmo mohou podporovat pouze znaky ze stejné kódové stránky. Textové styly využívající japonské velké písmo proto například nebudou podporovat německé ani korejské znaky. (Anglické znaky, které jsou součástí všech kódových stránek, jsou podporovány.) Podpora více jazyků pro jiné než asijské jazyky je k dispozici u textových stylů využívajících písma SHX, která mají zakázána velká písma. (Požadované znaky musí definovat písmo SHX.)
  • Chcete-li usnadnit používání vícejazyčného odstavcového textu v operačních systémech s podporou různých jazyků, použijte v Lokálním editoru textu nastavení písma TrueType.
  • Podpora více jazyků není v některých starších verzích AutoCADu k dispozici. Uložíte-li například soubor ve formátu AutoCADu® 2000, dojde k poškození odstavcového textu ve více jazycích. Výskyt těchto potíží je pravděpodobnější v případě, že výkres otevřete a uložíte v operačním systému s nastavením systémového jazyka lišícím se od systému, ve kterém byl výkres naposledy uložen.

Názvy složek a souborů

  • AutoCAD nerozlišuje názvy souborů s dvoubajtovými znaky, ve kterých se liší pouze velká a malá písmena. To může způsobit potíže při importu a být příčinou možného přepsání souborů.

    Chcete-li zajistit kompatibilitu při otevírání souborů a vkládání externích odkazů do ostatních výkresů, použijte pro názvy složek a souborů znaky ASCII.

Otázky týkající se dvoubajtových znaků

Názvy panelů nástrojů

  • Název nového panelu nástrojů, který se skládá pouze z jednobajtových číslic, nelze vytvořit. V názvech panelů nástrojů můžete používat pouze anglické abecední znaky nebo dvoubajtový text.

Názvy symbolů

  • Pokud v hladině nebo bloku zapíšete název symbolu pomocí římských znaků, bude u dvoubajtových i jednobajtových znaků první znak názvu symbolu převeden na velké písmeno a další znaky na malá písmena. Řetězec abc bude například převeden na Abc. U jednobajtových znaků se zobrazí upozornění, že řetězce abc a Abc představují identické názvy symbolů, u dvoubajtových alfanumerických znaků však bude identický název zapsán bez upozornění, přičemž symboly nebude pravděpodobně možné správně zobrazit.

    Stejným způsobem budou převedeny také názvy symbolů v importovaných výkresech vytvořených pomocí AutoCAD verze 13 (japonština). Chcete-li zajistit správnou funkci, přiřaďte každému symbolu jedinečný název.

Názvy hladin

  • Pokud ve formátu EPS vyexportujete výkresy s názvy hladin využívajícími dvoubajtové znaky, může dojít při otevření souboru EPS v aplikaci Adobe Illustrator k chybě. Pokud je nezbytné soubor v aplikaci Adobe Illustrator číst, nepoužívejte názvy hladin, které obsahují dvoubajtové znaky.
  • Použijete-li k pojmenování hladin znak 0xx??60, nebude pravděpodobně možné pomocí příkazu -HLADINA zapnout ani vypnout zobrazení hladiny z příkazového řádku. Místo toho můžete použít Správce vlastností hladiny (příkaz HLADINA).

Vyhledávací cesty k texturám

  • V dialogovém okně Možnosti (karta Soubory) nelze v uzlu Vyhledávací cesta k texturám zadat dvoubajtovou složku (japonština) s názvem 0xx5C. Soubory v této složce však můžete zadat pomocí absolutní cesty.

Názvy zdrojů dat

  • Kódy znaků (například 0xx??41 a 0xx??61) používané v názvech zdrojů dat nemusí být zpracovány správně. K tomuto problému dochází v případě, že pomocí volitelných názvů (japonština) zadaných v databázové konfiguraci vytvoříte více zdrojů dat. Některé názvy zdrojů dat tak pravděpodobně nebudu uvedeny v seznamu. Pokud k tomuto problému dojde, můžete změnit název chybějícího zdroje dat na jiný název.

Zobrazení textu

Svislý text asijských jazyků

  • Písma SHX - Text se svislým zobrazením můžete pomocí písem SHX a velkých písem vytvořit stejným způsobem jako v předchozích verzích. Nejlepších výsledků dosáhnete pomocí příkazu jednořádkového textu TEXT, nikoli příkazu MTEXT. V dialogovém okně Styl textu můžete vybrat svislý styl.

    Písma TrueType - Opět je možné vybírat písma začínající znakem @, nyní je však text automaticky otáčen o 270 stupňů. (V předchozích verzích bylo nutné text otáčet ručně.) Svislý text nyní podporuje svislý pohyb kurzoru.

Zobrazení písma

  • Pokud implicitní písmo nepodporuje znaky zadané pomocí Lokálního editoru textu (příkaz MTEXT), je obvykle toto písmo nahrazováno alternativním písmem.
  • Kódy CIF nebo MIF zadané pomocí Lokálního editoru textu (příkaz MTEXT) nebo příkazu DTEXT jsou nyní automaticky převáděny tak, aby zobrazovaly skutečné znaky.

Asijská velká písma dodávaná s produktem

Následující velká písma jsou dodávána společně s produktem:

  • @extfont2.shx - Japonské písmo využívané společně s písmy SHX k získání svislého zápisu (v zájmu správné funkce ve svislém textu jsou některé znaky otáčeny).
  • bigfont.shx - Písmo japonštiny.
  • chineset.shx - Písmo tradiční čínštiny.
  • extfont.shx - Písmo japonštiny.
  • extfont2.shx - Písmo japonštiny.
  • gbcbig.shx - Písmo zjednodušené čínštiny.
  • whgdtxt.shx - Písmo korejštiny.
  • whgtxt.shx - Písmo korejštiny.
  • whtgtxt.shx - Písmo korejštiny.
  • whtmtxt.shx - Písmo korejštiny.


Informace pro vývojáře

Změny s možným vlivem na skripty

Změny následujících příkazů nebo systémových proměnných mohou mít vliv na již existující skripty:

  • ADCNAVIGATE - Použijete-li k otevření okna DesignCenter příkaz ADCNAVIGATE, nebude již nutné stisknutím klávesy ENTER nebo ESC zobrazovat výzvu k zadání názvu cesty. Tato změna může mít vliv na již existující skripty.
  • PRODLUŽ - Pokud u příkazu PRODLUŽ po zobrazení výzvy k výběru objektů, které chcete prodloužit, objekt nevyberete, zobrazí se výzva k zadání protějšího rohu okna křížení. Tato změna může mít vliv na již existující skripty volající příkaz PRODLUŽ a zadávající bod, který nevybere žádné objekty. Starší skripty můžete opravit vynecháním bodů, které nevybírají objekty.
  • -VLOŽ - Pokud v dialogovém okně Definice bloku použijete novou volbu Použít stejné měřítko, nebude se již po vložení bloku pomocí příkazu -VLOŽ zobrazovat výzva k zadání samostatných faktorů měřítek souřadnic X, Y, Z. Tato změna může mít vliv na již existující skripty, které využívají tento příkaz.
  • ČTIMENU - Implicitně příkaz ČTIMENU v AutoCADu 2006 načte pouze soubory CUI. Chcete-li v AutoCADu 2006 provést příkaz ČTIMENU souboru MNU nebo MNS, je nutné explicitně uvést název souboru, jak je znázorněné v následujícím příkladu:

    (příkaz "menuload" "mojeNabídka.mnu")

    Místo změny kódu však důrazně doporučujeme před spuštěním aplikací, které soubory nabídek používají, otevřít starší soubory nabídek AutoCADu 2006. AutoCAD soubory automaticky převede na soubory CUI, přičemž soubory CUI budou načteny pomocí stávajícího kódu, který využívá název souboru bez přípony.

    Starší kód, který určuje příponu MNU, MNS nebo MNC, byste měli změnit tak, aby odkazoval na soubor CUI, přičemž aplikace AutoCADu 2006 by měly místo souborů MNU, MNS či MNC obsahovat soubory CUI.

  • OŘEŽ - Pokud u příkazu OŘEŽ po zobrazení výzvy k výběru objektů, které chcete o řezat, objekt nevyberete, zobrazí se výzva k zadání protějšího rohu okna křížení. Tato změna může mít vliv na již existující skripty volající příkaz OŘEŽ a zadávající bod, který nevybere žádné objekty. Starší skripty můžete opravit vynecháním bodů, které nevybírají objekty.

Visual LISP

Viditelnost procesu AutoCADu

  • Skripty AutoLISPu® spuštěné při startu by měly zkontrolovat, zda je proces AutoCADu viditelný nebo neviditelný. Pokud je proces neviditelný, skript by se neměl spustit, protože proces může provádět vykreslování na pozadí nebo publikování. Chcete-li zkontrolovat, zda je proces AutoCADu viditelný nebo neviditelný, můžete použít vlastnost Viditelný objektu Aplikace v objektovém modelu AutoCADu.

Konce řádků

  • Pokud použijete přepínač \r v rámci IDE jazyka Visual LISP®, nedojde k přesunu na další řádek. Místo toho se text zobrazí hned za posledním vytisknutým textem. Řešením je použít místo znaku \r položku (CHR 13).

Upozornění

  • V některých případech budou při změně jedné systémové proměnné upozornění vlr-sysVarWillChange a vlr-sysVarChanged vyvolána vícekrát.

Uzly

  • AutoCAD již nepodporuje uzly na nevybraných objektech. Výsledkem bude ignorování argumentu gripset funkce sssetfirst jazyka AutoLISP vrácení hodnoty nil pro první vrácenou sadu výběru funkcí ssgetfirst.

Barvy Truecolor

  • Používáte-li úplnou instalaci AutoCADu, naleznete pomůcky pro práci s barvami Truecolor v souboru color-util.lsp složky \Sample\VisualLISP. Tyto pomůcky lze použít pro operace související s barvami Truecolor, například k získávání komponent čísla barev Truecolor, převod indexu barvy nebo názvu barvy na hodnotu barvy Truecolor, vrácení seznamu s kódy skupiny DXF a práci se seznamem entit.

    Následující funkce jazyka AutoLISP umožňují přístup k uživatelskému rozhraní Truecolor:

    (acad_truecolordlg color [allowbylayer] [currentlayercolor]).
    Jedná se o výzvu pro zadání barvy prostřednictvím dialogového okna. Parametr barvy je tečkový pár popisující výchozí barvu; první prvek tečkového páru musí označovat jednu z barev souvisejících se skupinovými kódy DXF (62, 420 nebo 430). Je-li přítomen parametr allowbylayer a nemá hodnotu nil, zobrazí se tlačítka DleHlad a DleBlok. Je-li operace úspěšná, vrátí funkce seznam jednoho nebo více tečkových párů popisujících vybranou barvu. Poslední tečkový pár v seznamu určuje vybranou barvu. Funkce vrátí hodnotu nil, pokud uživatel zruší zobrazení dialogového okna.

    (acad_truecolorcli color [allowbylayer] [alternatePrompt]).
    Jedná se o výzvu pro zadání barev prostřednictvím příkazového řádku. První dva parametry jsou identické s acad_truecolordlg a třetí představuje volitelný řetězec výzvy příkazového řádku. Pokud tento řetězec vynecháte, použije se implicitní hodnota "Nová barva".

Funkce entmod a entmake

  • V AutoCADu 2004 a novějších verzích se funkce entmod a entmake při operacích s barvami chovají odlišně. Ve skupinovém kódu DXF 62 se uchovávají indexy barev AutoCADu (ACI), v kódu 420 hodnoty Truecolor. Pokud vznikne konflikt mezi hodnotou Truecolor a ACI, použije AutoCAD hodnotu 420, hodnota v kódu 420 by se tedy měla před pokusem o použití hodnoty v kódu 62 odstranit. Chcete-li se o této problematice dozvědět více, proveďte plnou instalaci AutoCADu a projděte si soubor color-util.lsp, který se nachází v adresáři \Sample\VisualLISP.

Uzavření přidružených aplikací

  • Pokud rutina jazyka AutoLISP již nepracuje s objektem mimo prostředí AutoCADu, například s objektem aplikace Microsoft Excel, můžete voláním funkce (vlax-release-object) zajistit řádné uzavření přidružené aplikace. Objekty uvolněné prostřednictvím funkce (vlax-release-object …) se nemusí uvolnit ihned. K uvolnění nemusí dojít, dokud nenastane příští automatické čištění bezvýznamných dat. Chcete-li, aby čištění bezvýznamných dat nastalo v určité části vašeho kódu, můžete funkci (gc) volat přímo. Zavolání funkce (gc) může ovšem vést ke snížení výkonnosti, doporučujeme tedy, abyste funkci (gc) neumisťovali do částí kódu, kde existuje pravděpodobnost, že bude tato funkce volána mnohokrát po sobě, např. uvnitř smyček.

    Pokud po volání funkce (gc) nedojde k uzavření objektu přidruženého k aplikaci, nebyla funkce (vlax-release-object) zavolána pro všechny objekty mimo prostředí AutoCADu.

Načítání chyb

  • Pokud příkaz ČTI při načítání souboru VLX odděleného jmenného prostoru zjistí chybu, byly pravděpodobně do jmenného prostoru aktuálního dokumentu před detekcí chyby exportovány některé funkce. Chcete-li zajistit, aby byly do aktuálního dokumentu exportovány všechny funkce ve svých aktuálních verzích, je nutno chybu opravit a soubor VLX znovu sestavit a načíst.
  • Pokud se pomocí příkazu CUILOAD načte do MDI částečná nabídka, načte se soubor MNL pro danou nabídku jednou pro každý otevřený dokument, přičemž veškerá uživatelská interakce bude probíhat v aktuálním dokumentu. Chcete-li se vyhnout nadbytečných vypsaných hlášení nebo uživatelských výzev, doporučujeme při inicializaci AutoCADu společně s více výkresy do kódu LISP MNL nezařazovat žádnou uživatelskou interakci. Místo toho použijte pro načtení případných souborů AutoLISP sloužících pro následné výběry položek nabídky kód MNL. Pro provedení kódu AutoLISP, který se má zpracovat při otevření výkresu, použijte soubory acad.lsp nebo acaddoc.lsp.
  • Pokud jako oddělovací znaménko použijete samostatná dopředná lomítka, dojde při předání argumentu ve formě názvu souboru metodě ActiveX UnloadDVB pomocí funkce vla-unloadDVB k selhání. Doporučujeme, abyste při volání funkcí vla-loadDVB, vla-RunMacro a vla-unloadDVB zadávali argumenty ve formě názvů souborů pomocí oddělovačů z dvojitých zpětných lomítek.

Zobrazení dialogového okna Prostředí MDE

  • Pomocí dialogu Prostředí MDE lze měnit implicitní funkčnost inicializace prostředí jazyka AutoLISP. Toto dialogové okno se zobrazí za následujících podmínek:
    • Hodnota Nezobrazovat klíče registru AcadLspAsDocDlg je nastavena na hodnotu 0.
    • Nejsou spuštěny žádné skripty ani aplikace jazyka AutoLISP či ActiveX.
    • Systémová proměnná ACADLSPASDOC je nastavena na hodnotu 0.
    • Ve vyhledávací cestě AutoCADu je umístěn soubor acad.lsp.
    • Ve vyhledávací cestě AutoCADu není umístěn soubor acaddoc.lsp.
    • Systémová proměnná SDI je nastavena na hodnotu 0.
    Jsou-li tyto podmínky splněné, zobrazí se dialogové okno Prostředí MDE v každé relaci poprvé při otevření druhého dokumentu.

Poškozené tiskové sekvence

  • Při tisku seznamu, který obsahuje více než 4 000 znaků, dojde ke kruhovému přetečení uvnitř zásobníku s pevně stanovenou velikostí, což vede při jeho prohlížení online k poškození výstupu. Náhradním řešením je upravit kód aplikací jazyka AutoLISP tak, aby najednou vytiskl méně než 4 000 znaků textu. To znamená rozdělit tiskový výstup do několika příkazů print.

ActiveX a VBA

Viditelnost procesu AutoCADu

  • Skripty VBA spuštěné při spuštění by měly zkontrolovat, zda je proces AutoCADu viditelný nebo neviditelný. Pokud je proces neviditelný, skript by se neměl spustit, protože proces může provádět vykreslování na pozadí nebo publikování. Chcete-li zkontrolovat, zda je proces AutoCADu viditelný nebo neviditelný, můžete použít vlastnost Viditelný objektu Aplikace v objektovém modelu AutoCADu.

Objekty AcadOle

  • Chcete-li pomocí jazyka VBA vložit do AutoCADu informace z jiné aplikace, použijte objekty AcadOle. Další informace o objektech AcadOle jsou dostupné v prohlížeči objektů jazyka VBA.


Historie příkazů a systémových proměnných

Zdroje informací o AutoCADu

Další informace o tomto produktu a jeho nových funkcích naleznete v následujících zdrojích:

  • karta Co je uvnitř v Prohlížeči médií (instalace),
  • příkaz Co je nového (nabídka Nápověda),
  • systém nápovědy (nabídka Nápověda),
  • nápověda pro vývojáře (nabídka Nápověda > Další zdroje informací),
  • Autodesk User Group International (AUGI) (nabídka Nápověda > Další zdroje informací),
  • web společnosti Autodesk na adrese http://www.autodesk.com.

Příkazy

Nové příkazy

  • PUBLIK3DDWF - Vytvoří prostorové soubory DWF prostorových modelů.
  • AKCEBLOKU - Přidá do dynamické definice bloku akci.
  • MNOŽAKCEBLOKU - V dynamické definici bloku určuje sadu výběru objektů přidružených k akci.
  • NÁSTROJAKCEBLOKU - Přidá do dynamické definice bloku akci.
  • SDRUŽBLOK - V dynamické definici bloku přidruží k akci parametr.
  • POŘATRBLOKU - Určuje pořadí atributů bloku.
  • PALBLOK - Otevře v Editoru bloků okno Palety pro vytváření bloků.
  • ZAVŘIPALBLOK - Zavře v Editoru bloků okno Palety pro vytváření bloků.
  • ZAVŘIEDBLOK - Zavře Editor bloků.
  • POŘCYKLPROCHBLOK - Pro odkaz dynamického bloku změní pořadí procházení uzlů.
  • EDBLOK - Otevře dialogové okno Upravit definici bloku a potom Editor bloků.
  • -EDBLOK - Otevře dialogové okno Upravit definici bloku a potom Editor bloků (příkazový řádek).
  • MNOŽUZLBLOK - Vytváří, odstraňuje nebo resetuje uzly přidružené k parametru.
  • VYHLTABBLOK - Zobrazí nebo vytvoří vyhledávací tabulku pro dynamickou definici bloku.
  • PARAMBLOK - Přidá do dynamické definice bloku parametr s uzly.
  • ULOŽBLOK - Uloží aktuální definici bloku.
  • ULOŽBLOKJAKO - Uloží kopii aktuální definice bloku pod novým názvem.
  • SKRYJBLOK - V aktuálním nebo všech stavech viditelnosti dynamické definice bloku skryje objekty.
  • -SKRYJBLOK - V aktuálním nebo všech stavech viditelnosti dynamické definice bloku skryje objekty (příkazový řádek).
  • ZOBRAZBLOK - V aktuálním nebo všech stavech viditelnosti dynamické definice bloku zobrazí objekty.
  • -ZOBRAZBLOK - V aktuálním nebo všech stavech viditelnosti dynamické definice bloku zobrazí objekty (příkazový řádek).
  • STAVVIDBLOKU - V dynamickém bloku vytvoří, nastaví nebo odstraní stav viditelnosti.
  • -STAVVIDBLOKU - V dynamickém bloku vytvoří, nastaví nebo odstraní stav viditelnosti (příkazový řádek).
  • PŘÍKAZŘÁD - Zobrazí příkazový řádek.
  • SKRÝTPŘÍKAZŘÁD - Skryje příkazový řádek.
  • CUI - Spravuje přizpůsobené prvky uživatelského rozhraní, například pracovní prostředí, panely nástrojů, nabídky, místní nabídky a klávesové zkratky.
  • EXPORTCUI - Exportuje přizpůsobené nastavení ze souboru acad.cui do podnikového nebo částečného souboru CUI.
  • IMPORTCUI - Importuje přizpůsobené nastavení z podnikového nebo částečného souboru CUI do souboru acad.cui.
  • NAČTICUI - Načte soubor CUI.
  • UVOLNICUI - Uvolní soubor CUI.
  • KÓTAOBLOUK - Vytvoří kótu s délkou oblouku.
  • ZALOMKÓTA - Vytvoří kóty se zalomeným poloměrem.
  • RESTAURUJVÝKRES - Zobrazí seznam souborů s výkresy, které lze po selhání programu nebo systému restaurovat.
  • SKRYJRESTVÝKRES - Zavře Správce restaurování výkresu.
  • GRADIENT - Vyplní uzavřenou oblast nebo vybrané objekty gradientovou výplní.
  • -ŠRAFY - Vyplní uzavřenou oblast nebo vybrané objekty šrafovacím vzorem, celobarevnou výplní nebo gradientovou výplní (příkazový řádek).
  • SPOJ - Spojí objekty tak, aby tvořily jeden nepřerušovaný objekt.
  • ZAVŘÍTRYCHLÝKAL - Zavře Rychlý kalkulátor.
  • RYCHLÝKAL - Otevře Rychlý kalkulátor.
  • OBNOVBLOK - Obnoví jeden nebo více dynamických odkazů na bloky na implicitní hodnoty definice bloku.
  • UPRSEZMĚŘ - Určuje seznam měřítek dostupných pro výřezy rozvržení, nastavení stránek a vykreslování.
  • -UPRSEZMĚŘ - Určuje seznam měřítek dostupných pro výřezy rozvržení, nastavení stránek a vykreslování (příkazový řádek).
  • VTOPTIONS - Zobrazí změnu zobrazení ve formě jemného přechodu.
  • PRACPROST - Vytvoří, změní a uloží pracovní prostory a zaktualizuje pracovní prostor.
  • ULOŽPRACPROST - Uloží pracovní prostor.
  • NASTPRACPROST - Nastaví možnosti pracovního prostoru.

Změněné příkazy

  • ADCNAVIGACE - Načte zadaný soubor výkresu, složku nebo síťovou cestu DesignCenter.
  • ATRDEF - Vytváří definici atributu.
  • -ATRDEF - Vytváří definici atributu (příkazový řádek).
  • BLOK - Vytváří z vybraných objektů definici bloku.
  • -BLOK - Vytváří z vybraných objektů definici bloku (příkazový řádek).
  • HRANICE - Vytvoří z uzavřené oblasti oblast nebo křivku.
  • KAL - Vyhodnocuje matematické a geometrické výrazy.
  • ZKOS - Zkosí hrany objektů.
  • KOPIE - Zkopíruje objekty o konkrétní vzdálenost v konkrétním směru.
  • UPRAV - Upraví palety nástrojů.
  • EATREXT - Exportuje informace o atributu bloku do tabulky nebo externího souboru.
  • -EATREXT - Exportuje informace o atributu bloku do tabulky nebo externího souboru (příkazový řádek).
  • PRODLUŽ - Prodlouží objekt k jinému objektu.
  • TPOLE - Vytvoří víceřádkový textový objekt s polem, který se může aktualizovat automaticky podle změn hodnot pole.
  • ZAOBLI - Zakulacuje a zaobluje hrany u objektů.
  • NAJDI - Najde, přesune, vybere nebo přiblíží určený text.
  • ŠRAFY - Vyplní uzavřenou oblast nebo vybrané objekty šrafovacím vzorem nebo celobarevnou výplní.
  • VLOŽ - Umístí do aktuálního výkresu jiný výkres nebo blok.
  • -VLOŽ - Umístí do aktuálního výkresu jiný výkres nebo blok (příkazový řádek).
  • ZRCADLI - Vytváří zrcadlové kopie objektů.
  • MČSTYL - Definuje styl více rovnoběžných čar.
  • MTEXT - Vytváří odstavce textu ve formě jednoho objektu víceřádkového textu (mtext).
  • POSUN - Přesune objekty o konkrétní vzdálenost v konkrétním směru.
  • EKVID - Vytváří soustředné kružince, rovnoběžné úsečky a křivky.
  • MOŽNOSTI - Upraví nastavení produktu.
  • PUBLIKUJ - Publikuje výkresy do souborů DWF.
  • OBD - Kreslí pravoúhlou křivku.
  • OTOČ - Otáčí objekty kolem základního bodu.
  • MĚŘÍTKO - Proporcionálně zvětší nebo zmenší vybrané objekty ve směru X, Y a Z.
  • PROTÁHNI - Posune nebo roztáhne objekty.
  • NPALETY - Zobrazí okno Palety nástrojů.
  • OŘEŽ - Ořeže objekty podle řezných hran definovaných jinými objekty.
  • XPŘIPOJ - Připojí externí reference do aktuálního výkresu.

Odebrané nebo zastaralé příkazy

  • MENU - Načte soubor uživatelských úprav. (Bude odebrán z další verze a nahrazen příkazem NAČTICUI.)
  • ČTIMENU - Načte soubory částečných nabídek. (Bude odebrán z další verze a nahrazen příkazem NAČTICUI.)
  • ZRUŠMENU - Zruší načtení souborů uživatelských úprav. (Bude odebrán z další verze a nahrazen příkazem UVOLNICUI.)
  • ČTIRML - Vkládá do výkresu připomínky ze souboru RML. (Nahrazen příkazem PŘIPOMÍNKY.)
  • -ČTIRML - Vkládá do výkresu připomínky ze souboru RML (příkazový řádek).

Systémové proměnné

Nové systémové proměnné

  • BACTIONCOLOR - Nastaví barvu textu akcí v Editoru bloků.
  • BDEPENDENCYHIGHLIGHT - Určuje, zda budou či nebudou závislé objekty při výběru parametru, akce nebo uzlu v Editoru bloků zvýrazněny jako závislé.
  • BGRIPOBJCOLOR - Nastavuje barvu uzlů v Editoru bloků.
  • BGRIPOBJSIZE - Nastavuje velikost zobrazení vlastních uzlů v Editoru bloků vzhledem k displeji obrazovky.
  • BLOCKEDITLOCK - Zakáže otevření Editoru bloků a úpravy dynamických definic bloků.
  • BLOCKEDITOR - Označuje, zda je či není Editor bloků otevřený.
  • BPARAMETERCOLOR - Nastavuje barvu parametrů v Editoru bloků.
  • BPARAMETERFONT - Nastavuje písmo použité pro parametry a akce v Editoru bloků.
  • BPARAMETERSIZE - Nastavuje velikost textu a funkcí parametru v Editoru bloků vzhledem k displeji obrazovky.
  • BTMARKDISPLAY - Určuje, zda se budou či nebudou zobrazovat připomínky se zadanou hodnotou.
  • BVMODE - Určuje způsob zobrazení objektů skrytých v aktuálním stavu viditelnosti v Editoru bloků.
  • CALCINPUT - Určuje, zda se budou či nebudou zobrazovat připomínky se zadanou hodnotou.
  • CENTERMT - Určuje způsob prodloužení víceřádkového textu zarovnaného vodorovně na střed pomocí uzlů.
  • CLISTATE - Ukládá hodnotu označující, zda bude okno příkazu zobrazené nebo skryté.
  • CMDINPUTHISTORYMAX - Nastavuje maximální počet předchozích vstupních hodnot, které budou pro výzvu v příkazu uloženy.
  • CROSSINGAREACOLOR - Určuje barvu oblasti výběru při výběru křížením.
  • DRSTATE - Určuje, zda bude či nebude okno Restaurování výkresu aktivní.
  • DTEXTED - Určuje uživatelské rozhraní pro úpravy jednořádkového textu.
  • DYNDIGRIP - Určuje, které dynamické kóty budou při protažení pomocí uzlů zobrazeny.
  • DYNDIVIS - Určuje počet dynamických kót zobrazovaných při protažení pomocí uzlů.
  • DYNMODE - Zapne a vypne funkce dynamického vstupu.
  • DYNPICOORDS - Určuje, zda bude vstup ukazatele pro souřadnice používat relativní nebo absolutní formát.
  • DYNPIFORMAT - Určuje, zda bude vstup ukazatele pro souřadnice používat polární nebo kartézský formát.
  • DYNPIVIS - Určuje, kdy se zobrazí vstup ukazatele.
  • DYNPROMPT - Určuje zobrazování výzev v nápovědě dynamického vstupu.
  • DYNTOOLTIPS - Určuje, na kterou nápovědu bude mít nastavení zobrazení nápovědy vliv.
  • ENTERPRISEMENU - Ukládá název souboru CUI (pokud je definován) včetně cesty k souboru.
  • FULLPLOTPATH - Určuje, zda bude do zásobníku pro vykreslování odeslána úplná cesta k souboru výkresu.
  • GRIPDYNCOLOR - Určuje barvu uživatelských uzlů pro dynamické bloky.
  • HPINHERIT - Určuje způsob zkopírování počátku šrafy ze zdrojového objektu do cílových šrafovaných objektů pomocí příkazu KOPIEVLAST.
  • HPOBJWARNING - Nastavuje počet objektů hranice šrafování, které lze vybrat, aniž by se zobrazilo upozornění.
  • HPORIGIN - Pro nové šrafované objekty nastavuje počáteční body šrafy vzhledem k aktuálnímu uživatelskému souřadnému systému.
  • HPORIGINMODE - Určuje, jakým způsobem příkaz ŠRAFY zjišťuje implicitní počáteční bod šrafy.
  • HPSEPARATE - Určuje, zda při práci s několika uzavřenými hranicemi příkaz ŠRAFY vytvoří jeden šrafovaný objekt nebo samostatné šrafované objekty.
  • INPUTHISTORYMODE - Určuje obsah a umístění zobrazení historie uživatelského vstupu.
  • INTELLIGENTUPDATE - Určuje obnovovací frekvenci grafiky.
  • LAYERFILTERALERT - Odstraněním nadměrného počtu filtrů hladin zlepší výkon.
  • LOCKUI - Uzamkne pozici a velikost panelů nástrojů a oken, například palet DesignCenter a Vlastnosti.
  • OSNAPZ - Určuje, zda bude uchopování objektů za aktuálního zdvihu automaticky promítnuto na rovinu rovnoběžnou s rovinou XY aktuálního USS.
  • PREVIEWEFFECT - Určuje vizuální efekt použitý pro náhled výběru objektů.
  • PREVIEWFILTER - Vyloučí z náhledu výběru zadané typy objektů.
  • QCSTATE - Určuje, zda bude či nebude Rychlý kalkulátor aktivní.
  • RECOVERYMODE - Určuje, zda budou po systémovém selhání zaznamenány informace o restaurování výkresu.
  • SELECTIONAREA - Určuje zobrazení efektů v oblastech výběru.
  • SELECTIONAREAOPACITY - Určuje průhlednost oblasti výběru při výběru v okně nebo výběru křížením.
  • SELECTIONPREVIEW - Určuje zobrazení náhledu výběru.
  • SHOWLAYERUSAGE - Pomocí ikon ve Správci vlastností hladiny označuje, zda se hladiny používají.
  • SSMPOLLTIME - Určuje časový interval mezi automatickým obnovením stavových dat v sadě listů.
  • SSMSHEETSTATUS - Určuje způsob obnovení stavových dat v sadě listů.
  • TABLEINDICATOR - Určuje zobrazení čísel řádků a písmen sloupců při úpravách buňky tabulky v otevřeném Lokálním editoru textu.
  • TEMPOVERRIDES - Zapne nebo vypne dočasné přednostní klávesy.
  • TOOLTIPMERGE - Sloučí nápovědy pro kreslení do jedné nápovědy.
  • VTENABLE - Určuje, kdy budou použity jemné přechody zobrazení.
  • VTDURATION - Nastaví dobu trvání jemného přechodu zobrazení v milisekundách.
  • VTFPS - Nastaví minimální rychlost jemného přechodu zobrazení ve snímcích za sekundu.
  • WINDOWAREACOLOR - Určuje barvu průhledné oblasti výběru při výběru v okně.
  • WSCURRENT - Do příkazového řádku vrátí název aktuálního pracovního prostoru a nastaví pracovní prostor jako aktuální.

Změněné systémové proměnné

  • AFLAGS - Nastaví možnosti atributů.
  • INSUNITS - Určuje hodnotu výkresových jednotek pro automatickou změnu velikosti bloků, obrázků nebo externích odkazů vložených či připojených k výkresu.

  • MTEXTED - Určuje název aplikace, která bude použita při úpravě bloků odstavcového textu.
  • UNDOCTL - Označuje stav možností Auto, Řízení a Skupina příkazu ZPĚT.


Ochranné známky

Následující známky jsou registrované ochranné známky společnosti Autodesk, Inc. v USA a dalších zemích: 3D Studio, 3D Studio MAX, 3D Studio VIZ, 3ds max, ActiveShapes, ActiveShapes (logo), Actrix, ADI, AEC-X, ATC, AUGI, AutoCAD, AutoCAD LT, Autodesk, Autodesk Envision, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, Autodesk WalkThrough, Autodesk World, AutoLISP, AutoSketch, backdraft, Biped, bringing information down to earth, Buzzsaw, CAD Overlay, Character Studio, Cinepak, Cinepak (logo), cleaner, Codec Central, combustion, Design Your World, Design Your World (logo), EditDV, Education by Design, gmax, Heidi, HOOPS, Hyperwire, i-drop, IntroDV, lustre, Mechanical Desktop, ObjectARX, Physique, Powered with Autodesk Technology (logo), ProjectPoint, RadioRay, Reactor, Revit, VISION*, Visual, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Toolbox, Visual Tugboat, Visual LISP, Volo, WHIP!, and WHIP! (logo).

Následující známky jsou ochranné známky společnosti Autodesk, Inc., v USA a dalších zemích: AutoCAD Learning Assistance, AutoCAD LT Learning Assistance, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, AutoSnap, AutoTrack, Built with ObjectARX (logo), burn, Buzzsaw.com, CAiCE, Cinestream, Civil 3D, cleaner central, ClearScale, Colour Warper, Content Explorer, Dancing Baby (image), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, Design Web Format, DWF, DWFit, DWG Linking, DXF, Extending the Design Team, GDX Driver, gmax (logo), gmax ready (logo),Heads-up Design, jobnet, mass, ObjectDBX, onscreen onair online, Plasma, PolarSnap, Productstream, Real-time Roto, Render Queue, Visual Bridge, Visual Syllabus a Where Design Connects.