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Use Plotters and Printers

 
You can produce hard copy output of your drawings using

many different types of plotters and printers. You can send

output to files using a variety of formats.

1
In this chapter

■ Supported Plotters

■ Set Up Plotters and Printers

■ Use the Plotter Configuration
Editor

■ Modify General PC3 File
Information

■ Control PC3 File Device and
Document Settings

■ Resolve Conflicts with the
Windows Print Manager

■ Port Settings



Supported Plotters
HDI (Heidi® Device Interface) drivers are used to communicate with hard
copy devices. These drivers fall into three categories: file format drivers, HDI
nonsystem drivers, and HDI system printer drivers.

NOTE It is highly recommended that you update your drivers regularly to avoid
plotting problems.

Raster Formats

The following raster file formats are supported using the Raster HDI driver:

■ CALS MIL-R-28002A Type 1 (CCITT G4 2D Compression)

■ CALS Type 1 (CCITT G4 2D Compression)

■ Independent JPEG Group JFIF (JPEG Compression)

■ MS-Windows BMP (Uncompressed DIB)

■ Portable Network Graphics PNG (LZH Compression)

■ TIFF Version 6 (CCITT G4 2D Compression)

■ TIFF Version 6 (Uncompressed)

■ TrueVision TGA Version 2 (Uncompressed)

■ ZSoft PC Paintbrush PCX (ZSOFT PACKBITS Compression)

PostScript Formats

The following PostScript output is supported using the Adobe PostScript HDI
driver.

■ Level 1

■ Level 1Plus (Level 1 with color image support)

■ Level 2

DXB Formats

The AutoCAD DXB file format is supported using the AutoCAD DXB file driver.
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Hewlett-Packard Plotters

Hewlett-Packard pen plotters are supported using the HP-GL and HP-GL/2
HDI drivers. The following plotters are supported using the HP-GL and HP-GL/2
HDI driver

NOTE While it is possible to use the HP-GL and HP-GL/2 HDI drivers to plot to
the HP DesignJet plotters, the recommended driver to use with these plotters is
the HP Windows System printer driver that is optimized for CAD use.

■ 7475A

■ 7550A

■ 7580B

■ 7585B

■ 7586B

■ 7600 Series Model 240 D/A1

■ 7600 Series Model 240 E/A0

■ 7600 Series Model 250 E/A0

■ 7600 Series Model 255 E/A0

■ 7600 Series Model 355 E/A0

■ HP DesignJet ColorPro CAD

■ HP DesignJet 3500CP

■ HP DesignJet 3000CP

■ HP DesignJet 2500CP

■ HP DesignJet 2000CP

■ HP DesignJet 1055CM

■ HP DesignJet 1050C

■ HP DesignJet 755CM

■ HP DesignJet 750C Plus

■ HP DesignJet 750C

■ HP DesignJet 700

■ HP DesignJet 650C
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■ HP DesignJet 600

■ HP DesignJet 488CA

■ HP DesignJet 455CA

■ HP DesignJet 450C

■ HP DesignJet 430

■ HP DesignJet 350C

■ HP DesignJet 330

■ HP DesignJet 250C

■ HP DesignJet 230

■ HP DesignJet 220

■ HP DesignJet 200

■ DraftMaster 1 (7595A)

■ DraftMaster 2 (7596A)

■ DraftMaster MX 7599

■ DraftMaster Mx Plus 7599B

■ DraftMaster RX 7596B

■ DraftMaster RX Plus 7596C

■ DraftMaster SX Plus Sheet Feed 7595C

■ DraftPro (7570A)

■ DraftPro Plus C3170A

■ DraftPro Plus C3171A

■ DraftPro-DXL (7575A)

■ DraftPro-EXL (7576A)

■ LaserJet 4

■ LaserJet 4M

■ LaserJet 4MV

■ LaserJet 4Si

■ LaserJet 4SiMx
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■ LaserJet 4V

■ LaserJet 5

■ LaserJet 5M

■ LaserJet 5Si

■ LaserJet 5Si Mopier

■ LaserJet 5SiMX

■ LaserJet III

■ LaserJet IIID

■ LaserJet IIISi

■ Generic SHPGL

■ Generic LHPGL

Xerox Plotters

The following Xerox plotters are supported by the device driver provided by
Xerox.

■ 6030 Wide Format

■ 6050 Wide Format

■ Wide Format Print System 510 Series

■ Wide Format Print System 721p

■ Wide Format Print System 8825 (1 Roll)

■ Wide Format Print System 8825 (2 Roll)

■ Wide Format Print System 8830

■ Wide Format Print System 8850

■ Wide Format Print System 8855

Oce Plotters

The following Oce plotters are supported by the device driver provided by
Oce.

■ 5120 A1 (LZ_1.x) / 5120 (LZ_4.x)

■ 5120 A0 (LZ_1.x) / 5120 (LZ_4.x)
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■ 5150 CC_2.x

■ 5200 (MI_1.x)

■ 5200 MI_4.x

■ 5250 CG_1.x

■ 9055-S/95xx-S (FR/FP1.x)

■ 9300 LVI_1.x

■ 9400(with Scanner) (LV_3.x)

■ 9400 LV_3.x/4.x

■ 9400-11 EPC-MI_1.x

■ 9600

■ 9700 (R1.0)

■ 9800 (R3 & EPC R)

■ TCS400 Colour HDI

■ TDS300 HDI

■ TDS400 HDI

■ TDS600 HDI

■ TDS800 HDI

■ TDS860 HDI

CalComp Plotters

The following CalComp plotters are supported by the device driver provided
by CalComp.

■ 52224 DrawingMaster Plus

■ 52236 DrawingMaster Plus

■ 52424 DrawingMaster Plus

■ 52436 DrawingMaster Plug

■ 54424 Solus LED Plotter

■ 54436 Solus LED Plotter
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Plotters that Are No Longer Supported

Autodesk will no longer test or fix problems with the following devices. They
are still available, but are not supported in this release.

Hewlett-Packard Plotters (No Longer Supported)

■ 7600 Series model 240 D/A1

■ 7600 Series model 240 D/A0

■ 7600 Series model 250

■ 7600 Series model 255

■ 7600 Series model 355

CalComp Plotters (No Longer Supported)

■ 1023 Artisan Pen Plotter

■ 1025 Artisan Pen Plotter

■ 1026 Artisan Pen Plotter

■ 2024 PaceSetter Pen Plotter

■ 2036 PaceSetter Pen Plotter

■ 3024 DesignMate Pen Plotter

■ 3036 DesignMate Pen Plotter

■ 4036 PaceSetter Pen Plotter

■ 5324 TechJet Color

■ 5324GT TechJet Color

■ 53336 DrawingMaster DM600

■ 5336 TechJet Color

■ 5336GT TechJet Color

■ 5336i TechJet Color 175i

■ 53436 Drawing Master DM800

■ 5424 TechJet 720

■ 5436 TechJet 720

■ 5524 TechJet Color
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■ 5536 TechJet Color

■ 5624 TechJet Color 720c

■ 5636 TechJet Color 720c

■ 57424 Monochrome Electrostatic

■ 57436 Monochrome Electrostatic

■ 57444 Monochrome Electrostatic

■ 58424 Color Electrostatic

■ 58436 Color Electrostatic

■ 58444 Color Electrostatic

■ 67436 Monochrome Electrostatic

■ 68436 Color Electrostatic

■ 68444 Color Electrostatic

Set Up Plotters and Printers
Each plotter configuration contains information such as the device driver and
model, the output port to which the device is connected, and various
device-specific settings.

AutoCAD lists printers or plotters configured for use with Windows in the
Plot and Page Setup dialog boxes. You do not need to configure these devices
with the system printer driver unless the AutoCAD defaults differ from the
Windows values.

NOTE Nonsystem devices are referred to as plotters and Windows system devices
are referred to as printers.

If a plotter is supported by AutoCAD, but not by Windows, you can use one
of the HDI nonsystem printer drivers. You can also use a nonsystem driver to
create PostScript, raster, or Design Web format (DWF) files.

You must configure local or network nonsystem plotters and Windows system
printers with nondefault settings. You do not need to configure system printers
if you change only the paper size.

AutoCAD stores information about the media and plotting device in configured
plot (PC3) files. Plot configurations are portable and can be shared in an office
or on a project as long as they are for the same driver, model, and driver
version. Shared plot configurations for Windows system printers may also
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need to be for the same version of Windows. If you calibrate a plotter, the
calibration information is stored in a plot model parameter (PMP) file that
you can attach to any PC3 files you create for the calibrated plotter.

You can configure AutoCAD for many devices, and store multiple
configurations for a single device. Each plotter configuration contains
information such as the device driver and model, the output port to which
the device is connected, and various device-specific settings. You can create
several PC3 files with different output options for the same plotter. After you
create a PC3 file, it’s available in the list of plotter configuration names in the
Plot dialog box.

To create these PC3 files, use the Add-a-Plotter wizard in the Autodesk Plotter
Manager. The Plotter Manager is a Windows Explorer window. The
Add-a-Plotter wizard is modeled after the Windows Add Printer wizard. Using
the Add-a-Plotter wizard, you can specify whether you want to configure a
nonsystem, local, or network plotter, or a system printer. You can create any
number of plotter device configurations that use either the Windows system
printer drivers or Autodesk nonsystem plotter drivers. Your configurations are
stored in your user profile.

There are a number of ways to modify the default settings for a Windows
system printer without creating a PC3 file. For example, you can modify the
properties systemwide from the Control Panel. You can also choose Properties
in the Plot dialog box and plot without saving the properties.

NOTE If you upgrade a driver, try using your existing PC3 file. If it does not work,
then you need to create a new PC3 file. In many cases, it may be possible to copy
and paste some of the settings from the old PC3 file to a new one created with
the new driver.

See also:

“Use the Plotter Configuration Editor” on page 12
“Calibrate Plotters and Work with Custom Paper Sizes” on page 19

To open the Autodesk Plotter Manager

You can also use any of the following methods to open the Autodesk Plotter
Manager:

■ From the File menu, choose Plotter Manager.

■ On the command line, enter plottermanager.

■ From the Tools menu, choose Options. On the Plot and Publish tab, choose
Add or Configure Plotters.
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To create a PC3 file for a Windows system printer

1 Open the Autodesk Plotter Manager.

2 In the Autodesk Plotter Manager, double-click the Add-a-Plotter Wizard
shortcut icon.

3 In the Add-a-Plotter wizard, read the Introduction, and then choose Next
to advance to the Add Plotter - Begin page.

4 On the Add Plotter - Begin page, choose System Printer. Choose Next.

5 On the Add Plotter - System Printer page, select the system printer that
you want to configure.

The list includes all printers known to the operating system. If you want
to connect to a printer that is not in the list, you must first add the
printer using the Windows Add Printer wizard in the Control Panel.

(Optional)The Import PCP or PC2 screen enables you to use configuration
information from a PCP or PC2 file created with an earlier version of
AutoCAD.

6 On the Add Plotter - Plotter Name page, enter a name to identify the
currently configured plotter. Choose Next.

7 When you reach the Add Plotter - Finish page, you can choose Finish to
exit the Add-a-Plotter wizard.

A PC3 file for the newly configured plotter appears in the Plotters window
and the plotter is available for plotting in the list of devices.

At this time, you can change the default settings for the plotter by
choosing Edit Plotter Configuration on the Add Plotter - Finish page.
You can also perform a plot calibration test on your newly configured
plotter by choosing Calibrate Plotter on the Add Plotter - Finish page.

To configure a local, nonsystem plotter

1 Open the Autodesk Plotter Manager.

2 In the Autodesk Plotter Manager, double-click the Add-a-Plotter Wizard
shortcut.

3 In the Add-a-Plotter wizard, read the Introduction, and then choose Next
to advance to the Add Plotter - Begin page.

4 On the Add Plotter - Begin page, choose My Computer. Choose Next.

5 On the Add Plotter - Plotter Model page, select a manufacturer and model.
Choose Next.

If you are configuring a PostScript device, select Adobe from the
Manufacturers list.
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If your plotter is not in the list of available plotters, and you have a driver
disk for your plotter, choose Have Disk to locate the HIF file on that
driver disk, and install the driver supplied with your plotter.

(Optional) The Import PCP or PC2 screen enables you to use
configuration information from a PCP or PC2 file created with an earlier
version of AutoCAD.

6 On the Add Plotter - Ports page, select the port to use when plotting.
Choose Next. The ports available for the specified device are displayed.

7 On the Add Plotter - Plotter Name page, enter a name to identify the
currently configured plotter. Choose Next.

8 When you reach the Add Plotter - Finish page, you can choose Finish to
exit the Add-a-Plotter wizard.

A PC3 file for the newly configured plotter appears in the Plotters
window, and the plotter is available for plotting in the list of devices.

At this time, you can change the default settings for the plotter by
choosing Edit Plotter Configuration on the Add Plotter - Finish page.
You can also perform a plot calibration test on your newly configured
plotter by choosing Calibrate Plotter on the Add Plotter - Finish page.

To configure a network, nonsystem plotter

1 Open the Autodesk Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 In the Add-a-Plotter wizard, read the Introduction, and then choose Next
to advance to the Add Plotter - Begin page.

4 On the Add Plotter - Begin page, choose Network Plotter Server. Choose
Next.

5 On the Add Plotter - Network Plotter page, enter the share name of the
network plotter server that you want to use.

The server must already exist on the network. For more information, see
your system administrator.

You must use the universal naming convention (UNC). The correct
format of a UNC path is \\server name\share name. You can select an
existing share name on your network by choosing Browse.

6 On the Add Plotter - Plotter Model page, select a manufacturer and model.
Choose Next.

If you are configuring a PostScript device, select Adobe from the
Manufacturers list.
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If your plotter isn’t in the list of available plotters and you have a driver
disk for your plotter, choose Have Disk to locate the HIF file on that
driver disk, and install the driver supplied with your plotter.

(Optional) The Import PCP or PC2 screen enables you to use
configuration information from a PCP or PC2 file created with an earlier
version of AutoCAD.

7 On the Add Plotter - Plotter Name page, enter a name to identify the
currently configured plotter. Choose Next.

8 When you reach the Add Plotter - Finish page, you can choose Finish to
exit the Add-a-Plotter wizard.

A PC3 file for the newly configured plotter appears in the Plotters window
and the plotter is available for plotting in the list of devices.

At this time, you can change the default settings for the plotter by
choosing Edit Plotter Configuration on the Add Plotter - Finish page.
You can also perform a plot calibration test on your newly configured
plotter by choosing Calibrate Plotter on the Add Plotter - Finish page.

Use the Plotter Configuration Editor
After you create a configured plotter (PC3) file using the Add-a-Plotter wizard,
you can edit the file using the Plotter Configuration Editor.

The Plotter Configuration Editor provides options for modifying a plotter’s
port connections and output settings including media, graphics, physical pen
configuration, custom properties, initialization strings, calibration, and
user-defined paper sizes. You can drag and drop these options from one PC3
file to another.

NOTE When dragging and dropping one leaf, the whole branch will come over
with the leaf. If you drag from a Windows system driver, in most cases, the Custom
branch will also be copied. For nonsystem drivers, the Custom leaf is copied only
if it is explicitly selected.

The Plotter Configuration Editor contains three tabs. The General tab contains
basic information about the configured plotter. The Ports tab contains
information about the communication between the plotting device and your
computer. The Device and Document Settings tab contains plotting options.
Depending on your configured plotting device, additional options are available
on the Device and Document Settings tab. For example, when you configure
a nonsystem pen plotter you have the option to modify the physical pen
characteristics.

You can edit the plotter configuration files for both nonsystem and system
plotters. You can also modify the default settings for a Windows system printer
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without creating a PC3 file. For example, you can modify the properties
systemwide in the Windows Control Panel. You can also choose Properties in
the Plot dialog box and plot without saving the properties.

To start the Plotter Configuration Editor

Use one of the following methods:

■ Double-click a PC3 file from Windows Explorer or right-click the file and
choose Open. (By default, PC3 files are stored in the user profile folder.)

■ Choose Edit Plotter Configuration on the Add Plotter - Finish page in the
Add-a-Plotter wizard.

■ On the File menu, click Plot. In the Plot dialog box, under Printer/Plotter
select a device, and then click Properties.

■ On the File menu, click Page Setup. In Page Setup Manager, select a page
setup, and then click Modify. In the Page Setup dialog box, under
Printer/Plotter select a device and then click Properties.

To save a PC3 file under a new file name

1 From the File menu, choose Plotter Manager.

2 In the Autodesk Plotter Manager, double-click to open the PC3 file you
want to use.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Choose Save As.

5 In the Save As dialog box, enter a new file name for the PC3 file.

6 Choose Save.

Modify General PC3 File Information
The General tab of the Plotter Configuration Editor contains basic information
about the PC3 file. You can add or modify the information in the Description
area.

The rest of the tab is read-only. The information on the General tab includes

■ Configured plotter file name

■ Description or other information you want to include about the plotter
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■ Plotter driver type (system or nonsystem), name, model, and location

■ HDI driver file version number (AutoCAD specialized driver files)

■ UNC name of the network server (if the plotter is connected to a network
server), the input/output port (if the plotter is connected locally), or the
name of the system printer (if the configured plotter is the system printer)

■ PMP file name and location (if a plotter calibration file [PMP] is attached
to the PC3 file)

To add or modify the PC3 file description

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose settings you want
to change.

3 In the Plotter Configuration Editor, choose the General tab.

4 Insert the cursor in the Description area.

5 Add a description or modify the existing description for the PC3 file.

Control PC3 File Device and Document
Settings

In the Plotter Configuration Editor, on the Device and Document Settings
tab, you can change many of the settings in the configured plot (PC3) file.

NOTE Only the settings available for the configured device are displayed in the
tree view. In addition, you might not be able to edit some settings if the device
handles the setting through the Custom Properties option or doesn’t support the
capability.

Adjust Media Settings (For Nonsystem Plotters
Only)

Depending on the features supported by your configured plotter, you can
modify the paper source, type, and size of your paper.

You can specify whether you want to print on both sides or just one side. If
your printer supports cutting, collating, and stapling, you can specify your
choice under the Media Destination option. For Windows system printers,
you must configure the Media settings using the Custom Properties option.
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To adjust media settings

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose media settings
you want to change.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click Media to view the media settings.

5 Do one of the following:

■ Select Source and Size. Under Media Source and Size, select a paper
source from the Source list. If appropriate, select a roll width from the
Width list or a tray from the Tray Type list. Under Size, select the
paper size you want to use. Select Automatic to tell the printer to
select the appropriate paper source.

■ Select Media Type. Under Media Type, select one of the available
media types.

■ Select Duplex Printing. Under Print on Both Sides (Duplex
Printing), select Short Side or Long Side. This setting may not be
available for your plotter.

■ Select Media Destination. Under Media Destination, specify one
of the available options, for example, cutting. This setting may not
be available for your plotter.

6 When finished, choose OK.

Specify Physical Pen Configuration (For Pen Plotters
Only)

In the Plotter Configuration Editor, the Physical Pen Configuration setting
controls the pens in the pen plotter.

You can specify pen swapping on a single pen plotter, adjust the polygon area
for pen width, and set pen optimization if the configured plotter supports
these features. The lower pane of the Device and Document Settings tab
displays a table that describes the color, width, and speed of each pen in the
plotter.

NOTE Physical pen information cannot be detected automatically. You must
provide this information for your pen plotter under the Physical Pen Characteristics
option.
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You must specify the pen settings even if you don't plan to use plot style
tables. If you choose not to create a plot style table, AutoCAD automatically
assigns pens, using the pen color and width information you provide. AutoCAD
uses the pen whose color is closest to the color assigned to the object. If more
than one pen matches, then the pen with the closest width is used. If the best
pen is narrower than the object's width, several strokes are used to draw the
object. If you use a plot style table, you can assign a physical pen number to
each plot style.

See also:

“Switch the Type of Plot Style Table” in the User’s Guide

To configure pens

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose pen settings you
want to change.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click Physical Pen Configuration to view the pen configuration
settings.

5 Select Pen Configuration. Under Pen Configuration, do one of the
following:

■ If you use a single-pen plotter and want to use different pens when
you plot, select Prompt for Pen Swapping.

■ For greater accuracy when plotting filled areas and wide polylines,
choose Area Fill Correction. AutoCAD moves the pen inward by half
a pen width.

■ Under Pen Optimization Level, select one of the available methods.
Each method in the list includes the optimization methods preceding
it in the list (except for No Optimization).

6 Select Physical Pen Characteristics. For each pen in your plotter, specify
the color, speed, and width. This step is required.

NOTE Use the Plot Style Table Editor to assign specific colors and pen
widths to your objects that correspond to the plotted colors and widths for
your plotting device.

7 When finished, choose OK.
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Specify Settings for Graphical Output

Depending on the capabilities of your configured plotter, you can modify the
plotter’s color depth, resolution, or dithering and specify whether the output
is color or monochrome for vector drawings.

When printing raster images on a plotter with limited memory, you can specify
some image-quality trade-offs to improve performance. If you use a nonsystem
plotter that supports varying amounts of installed RAM, you can provide
AutoCAD with that information to improve performance.

To specify graphics settings

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose pen settings you
want to change.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click Graphics to view the graphical output settings.

5 Do one of the following:

■ Select Installed Memory and enter the amount of memory available
in the plotter.

■ Select Vector Graphics and select color depth, resolution, and
dithering.

■ Select Raster Graphics and specify a balance between output quality
and performance.

■ Select TrueType Text and select the way you want to print TrueType
text.

■ Select Merge control and specify whether crossing lines should
overwrite the lines beneath them or merge.

6 When finished, choose OK.

Adjust Custom Properties

In the Plotter Configuration Editor, you can modify the device-specific
properties for the configured plotter by selecting Custom Properties from the
tree view on the Device and Document Settings tab.
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The settings for each plotter vary. If the plotter manufacturer has not included
a Custom Properties dialog box for the device driver, the Custom Properties
option is unavailable. For other drivers, the Customs Properties option is the
only tree view option available. For Windows system printers, most of the
device-specific settings are made in this dialog box.

For device-specific information, choose Help in the Custom Properties dialog
box for the driver you have configured.

To specify custom properties

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose custom properties
you want to change.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 In the tree view, select Custom Properties. Under Access Custom Dialog,
choose the Custom Properties button.

5 Set the properties for the printer or plotter. The properties vary depending
on the plotter and manufacturer.

6 Choose OK to exit each dialog box.

Use Initialization Strings

You can use ASCII text initialization strings to prepare the plotter for printing.

If you’re plotting to an unsupported, nonsystem plotter in Emulation mode,
you can use ASCII text initialization strings to prepare the plotter for printing,
set device-specific options, and restore the plotter to its original state. Only
advanced users should use initialization strings.

To set initialization strings

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose initialization
string settings you want to change.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 In the tree view, select Initialization Strings to view the initialization
string settings.
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5 Enter a Pre-Initialization string, Post-Initialization string, and Termination
string as required.

6 Choose OK.

Calibrate Plotters and Work with Custom Paper
Sizes

You should perform a plotter calibration only if your drawings must be exactly
to scale and your plotter or printer produces inaccurate plots.

You can adjust plotter calibration to correct scaling discrepancies, and you
can add custom paper sizes for nonsystem plotters.

Calibration Files

Plotter calibration is an optional process. If your plotter meets the
manufacturer's specifications for accuracy of scale, a 10-inch line in a drawing
plotted at a scale of 1:1 should be exactly 10 inches long on paper. If you need
to correct scaling discrepancies, you can adjust the plotter calibration. If your
plotter provides a calibration utility, use that utility instead of the AutoCAD
calibration utility so the calibration is available for all applications using the
plotter.

To calibrate a plotter, you must specify the dimensions of a test rectangle,
print the test rectangle, measure actual dimensions, and enter the actual
measurements in the Calibrate Plotter wizard. AutoCAD calculates the necessary
calibration for the plotter.

When you complete the Calibrate Plotter wizard, AutoCAD creates a plot
model parameter (PMP) file to store the results of the calibration for each plot
device. AutoCAD automatically attaches the resulting PMP file to the plotter
configuration (PC3) file that you used to perform the calibration test.

Calibrating a plotter creates a plotter model parameter (PMP) file that contains
calibration information. If the PMP file is not already attached to the plotter
configuration file (PC3) you are editing, you must create that association so
you can use the PMP file. If the plotter was calibrated from within the
Add-a-Plotter wizard, the PMP file is already attached. You can use the
Calibration and User Defined Paper Sizes option to add PMP files to and detach
PMP files from the PC3 file. If you have more than one PC3 file for a device,
you can attach the same PMP file to them using the Plotter Configuration
Editor. Because PMP files are plotter specific, it's appropriate to attach only
one PMP file to a PC3 file.
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NOTE You should perform a plotter calibration only if your drawings must be
exactly to scale and your plotter or printer produces inaccurate plots. Plotter
calibration causes AutoCAD to rescale all plots sent to your plotter to correct errors
in its hardware scaling. It is recommended that you use any calibration setting
provided by your plotter instead of the AutoCAD setting.

Custom Paper Sizes

For a nonsystem plotter, you can choose the Add option to create a custom
paper size or change the printable area of a standard or nonstandard paper
size. Using the Custom Paper Size wizard, you can create a new paper size or
select from a list of available paper sizes (from a PMP file). For a Windows
system printer, use the Custom Properties option to adjust paper settings.

You can modify standard paper sizes to adjust the printable area to match a
printer's capabilities. In the Plotter Configuration Editor, you cannot create
custom paper sizes for Windows system printers, but you can correct errors
in the printable area of standard paper sizes.

To calibrate a plotter

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter wizard icon.

3 Start the Add-a-Plotter wizard and configure the device you want to add.

4 When you reach the Add Plotter - Finish page, choose Calibrate Plotter.

You can also calibrate a plotter by running the Plotter Configuration
Editor on an existing PC3 file for the device you want to calibrate.

5 In the Paper Size list, select a paper size for the test plot. Choose Next.

6 On the Calibrate Plotter - Rectangle Size page, in the Units list, select
the measurement units.

7 In the Length and Width boxes, enter the dimensions of the test
rectangle. Choose Next. AutoCAD plots the test rectangle.

8 Retrieve the plot and measure the test rectangle. On the Calibrate Plotter
- Measured Plot page, in the Measured Length and Measured Width
boxes, enter the actual dimensions of the plotted test rectangle. Choose
Next.

AutoCAD compares the actual plotted measurements to the size you
specified in the preceding screen and computes the correction needed
to accurately calibrate the plotter.

9 On the Calibrate Plotter - File name page, enter a file name. Choose
Next.
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The resulting PMP file is stored in the AutoCAD Drv folder.

10 On the Calibrate Plotter - Finish page, choose Check Calibration.

AutoCAD plots the text rectangle again. Measure the sides again to verify
that the calibration is correct.

11 Choose Finish to return to the Add-a-Plotter wizard or Plotter
Configuration Editor.

To attach a PMP file to a PC3 file

After you create a PMP file, that file is attached to the PC3 file from which
you started the Calibrate Plotter wizard. You can attach an existing PMP file
to a different PC3 file using the Plotter Configuration Editor.

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration to which you want to attach a
PMP file.

3 On the Device and Document Settings tab, from User-Defined Paper
Sizes & Calibration, select PMP File Name <file name>.

If this PC3 file doesn’t have an attached PMP file, the PMP File Name
setting doesn’t show an attached file. Choose Attach.

4 Locate the PMP file you want to attach to this PC3 file and choose Open.

5 Choose OK to close the Plotter Configuration Editor.

The PMP File Name setting is updated.

To detach a PMP file from a PC3 file

After you create a PMP file, that file is attached to the PC3 file from which
you started the Calibrate Plotter wizard. You can detach a PMP from a PC3
file using the Plotter Configuration Editor.

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration from which you want to detach
a PMP file.

3 On the Device and Document Settings tab, select User-defined Paper
Sizes & Calibration and then select the PMP File Name <file name>.

4 Choose Detach. (If this PC3 file doesn’t have an attached PMP file, the
Detach option is unavailable.)

5 Choose OK to close the Plotter Configuration Editor.
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To save a PMP file to a new file name

After you create a PMP file, that file is attached to the PC3 file from which
you started the Calibrate Plotter wizard. You can save the PMP file with a new
file name using the Plotter Configuration Editor.

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration from which you want to save a
PMP file.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size options.

5 Under PMP File, choose Save PMP.

6 In the Save As dialog box, enter a new file name for the PMP file that’s
attached to the PC3 file you’re editing.

7 Choose Save.

The new file name is displayed in angle brackets beside the PMP File
Name option in the tree view.

8 Choose OK to close the Plotter Configuration Editor.

To add a new custom paper size from scratch (nonsystem HDI drivers only)

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration you want to modify.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size options. Then select Custom Paper Sizes.

5 Under Custom Paper Sizes, choose Add.

6 In the Custom Paper Size Wizard, on the Begin page, select Start from
Scratch. Choose Next.

7 On the Media Bounds page, in the Units list, select either Inches or
Millimeters for paper size.

When you plot a nondimensional raster image, such as BMP or TIFF, the
size of the plot is specified in pixels, not inches or millimeters.

8 From the Width and Length lists, select the paper width and length.
Choose Next.
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Each plotter has a maximum printable area determined by where it grips
the paper and how far the pen shuttle reaches. Verify that the plotter is
capable of plotting the new dimensions.

9 On the Printable Area page, in the Top, Bottom, Left, and Right boxes,
specify the printable area. Choose Next.

10 On the Paper Size Name page, enter a name for the paper size. Choose
Next.

11 On the File Name page, enter a name for the PMP file.

12 On the Finish page, specify whether the paper source is Sheet-Fed or
Roll-Fed. Choose Print Test Page to verify the custom size.

AutoCAD prints a cross that defines the paper size and a rectangle that
defines the printable area. If all four sides of the rectangle are not printed,
increase the printable area.

13 Choose Finish to exit the Custom Paper Size wizard.

To add a new custom paper size from scratch (system printers only)

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration you want to modify.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Select Custom Properties.

5 Choose Custom Properties in the Access Custom Dialog area.

The device driver-specific user interface opens.

6 Follow the manufacturer’s instructions to add a custom paper size.

You may need to choose the Help button for more information.

To add a new custom paper size starting from an existing paper size

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration you want to modify.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size options. Then select Custom Paper Sizes.

5 Under Custom Paper Sizes, choose Add.
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6 In the Custom Paper Size wizard, on the Begin page, select Use Existing.

7 From the list of existing standard paper sizes, select a paper size on which
to base the custom paper size you are creating.

8 On the Media Bounds page, select either Inches or Millimeters for paper
size and specify the paper width and length. Choose Next.

Each plotter has a maximum printable area determined by where it grips
the paper and how far the pen shuttle reaches. Verify that the plotter is
capable of plotting the new dimensions.

9 On the Printable Area page, in the Top, Bottom, Left, and Right boxes,
specify the printable area. Choose Next.

10 On the Paper Size Name page, enter a name for the paper size. Choose
Next.

11 On the File Name page, enter a name for the PMP file.

12 On the Finish page, specify whether the paper source is Sheet-Fed or
Roll-Fed. Choose Print Test Page to verify the custom size.

AutoCAD prints a cross that defines the paper size and a rectangle that
defines the printable area. If all four sides of the rectangle are not printed,
increase the printable area.

13 Choose Finish to exit the Custom Paper Size wizard.

To edit a custom paper size

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration you want to modify.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

5 Select Custom Paper Sizes.

6 Under Custom Paper Sizes, select a paper size from the list. Choose Edit.

7 In the Custom Paper Size wizard, make changes to the paper size,
printable area, custom paper size name, and source.

8 Choose Finish to exit the Custom Paper Size wizard.

9 Choose OK.
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To delete a custom paper size

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration you want to modify.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

5 Select Custom Paper Sizes.

6 Under Custom Paper Sizes, select a paper size from the list.

7 Choose Delete.

8 Choose OK.

To modify a standard paper size

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration you want to modify.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

5 Select Modify Standard Paper Sizes.

6 Under Modify Standard Paper Sizes, select the paper size you want to
adjust. Then choose Modify.

7 In the Custom Paper Size wizard, adjust the printable area as necessary.
Then choose Finish to exit the Custom Paper Size wizard.

To filter paper sizes

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration you want to modify.

3 In the Plotter Configuration Editor, choose the Device and Document
Settings tab.

4 Double-click User-Defined Paper Sizes & Calibration to display the
calibration and paper size settings.

5 Select Filter Paper Sizes.
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6 In the Size list in the Filter Paper Sizes area, check the paper sizes you
want to appear in the Paper Size lists in the Plot and Page Setup dialog
boxes.

Resolve Conflicts with the Windows Print
Manager

You need to use the appropriate driver for a locally connected plotter.

If you configure an HDI hardcopy driver for a locally connected plotter and
configure a Windows system printer for the same locally connected plotter,
the HDI driver is unable to connect directly to the local port because the
Windows system printer driver has control over it. The driver output is rerouted
to the Windows print spooler.

If the plotter is connected to a serial port, make sure that the Windows Control
Panel settings for that serial port are correct. The settings should match the
settings of the plotter and should be appropriate for the cabling you have
used. You can verify that these settings are correct by printing to the conflicting
Windows system printer.

Plotting from an HDI driver through the spooler is similar to plotting to a file
because there is only one-way communication with the plotter. Performance
varies depending on the device.

Port Settings
The Ports tab in the Plotter Configuration Editor contains information about
the plotter’s port configuration.

Adjust Port Settings

There are three possible places to configure your computer's port settings,
depending on how your plotter is connected.

The Ports tab in the Plotter Configuration Editor contains information about
the plotter’s port configuration. If you configure a local, nonsystem plotter,
you must specify the port to which the device is connected. You can choose
a serial (local), parallel (local), or network port. For parallel ports, the default
is LPT1. For serial ports, the default is COM1. Change the port name if your
device is connected to a different port.
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If you use a serial port, the settings within AutoCAD must match the plotter
settings. Choose Configure Ports to make the AutoCAD settings match your
plotter settings. The available protocols for your plotter are displayed.

NOTE If you are using a device that emulates the configured device and has
additional port options, select Show All Ports.

You can also change settings for communication between the PC3 file and
your computer or network system. You can plot through a port, plot to a file,
or use the AutoSpool feature to plot in the background while you continue
working. If you plot through a parallel port, you can specify the timeout value.
If you plot through a serial port, you can change the baud rate, protocol, flow
control, and input and output timeout values.

There are three possible places to configure your computer's port settings,
depending on how your plotter is connected.

Locally Connected Spooling

Your plotter is locally connected if it’s plugged in to a port on the computer
that’s running AutoCAD. AutoCAD spools the plot (sends it through the
Windows system spooler) if you also have configured a Windows system
printer to print to the same plotter using the same local port. You are notified
if your plot is being spooled due to a port conflict of this type, although you
can use a setting on the Plot and Publish tab in the Options dialog box to turn
off this warning.

Plotting through the system spooler is quicker. However, this method puts
the conflicting Windows system printer in control of the input/output port
configuration. The AutoCAD–configured port settings are ignored in this case.
To view or adjust the port settings, go to the Windows Print Manager in the
Control Panel and activate the printer that is configured for your plotter. You
can adjust port settings in the Windows system printer’s Properties dialog
box. You can print a test page from the Properties dialog box to verify that
the plotter and computer are communicating correctly.

Locally Connected, But Not Spooling

If your plotter is locally connected and there is no conflicting system printer,
AutoCAD can directly control the input/output port settings.

Across a Network

If you’re running AutoCAD on one computer and plotting to a device
connected to another computer on the network, the remote computer is in
control of the port settings, and the AutoCAD configured port settings are
ignored. A Windows system printer must be configured on the remote
computer. (This is how the plotter was shared on the network and made

Port Settings | 27



available to you.) The remote system printer controls the port settings; you
can view and change these settings in each system printer file’s Properties
dialog box, on the remote computer.

See also:

“Use AutoSpool” on page 28

To adjust port settings

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose port settings you
want to change.

3 In the Plotter Configuration Editor, choose the Ports tab.

4 Select one of the following options:

■ Plot to the Following Port. Sends the drawing to the printer
through the specified port.

■ Plot to File.  Sends the drawing to the file name specified on the
File tab in the Options dialog box.

■ AutoSpool.  Uses the AutoSpool utility specified on the File tab in
the Options dialog box to plot the drawing.

5 For a device that emulates the configured device and has additional port
options, select Show All Ports.

6 To connect a nonsystem plotter to another instance of the device, choose
Browse Network. In the Browse for Printer dialog box, select the device
and choose OK.

7 Choose OK.

Use AutoSpool

With AutoSpool you can plot to an automatically generated file name in the
folder you designate in the Options dialog box.

Once the file has been created, the spooler application specified in the Options
dialog box is executed.

Although it is not necessary to use AutoSpool to print to Windows network
printers and plotters, AutoSpool is available for users of other networks and
for users who want to start another application at plot time using the
AutoSpool mechanism.
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When you add printers or plotters in the Add-a-Plotter wizard, select a network
port, which meets most printer and plotter network connectivity requirements.

With AutoSpool, you can send a plot file to an assigned device for printing
while you continue working. AutoSpool accommodates special plotting and
printing requirements such as log files or nonstandard networks. You can also
use most plotting routines developed for previous versions of AutoCAD.

When you run AutoSpool, AutoCAD writes the plot job to a random file name
in a folder you specify. Next, AutoCAD runs a print queue submission program
along with a user-specified parameter list. At a minimum, the parameter list
must include the random file name AutoCAD assigned to the plot job. The
parameter list is represented by the %s variable. Other parameters can be used,
for example, to improve resolution at the destination device or generate log
files.

To set up AutoSpool, you must provide the executable file AutoCAD invokes
and specify that executable name and parameter list in the Options dialog
box. The executable file is usually a batch program that you create, but it can
also be a third-party program. If you use a third-party program, the setup is
essentially the same. To determine the parameter variables required for the
third-party program, refer to the documentation for that program.

You can use several methods for configuring plot spooling:

■ A Windows system printer driver and the Print Manager to enable spooling

■ An HDI driver and a Windows system printer driver configured for the
same I/O port to force the HDI driver’s output to the system spooler

■ AutoSpool

If you configure AutoCAD for plot spooling using AutoSpool, you must
configure your printer, specify the AutoSpool executable file, and specify the
print file location.

Create a Batch File for AutoSpool

The following sample plot.bat file shows some of the functions that can be
included in a batch file. This batch file determines the destination hard copy
device, submits the print job via the operating system Copy command, and
then deletes the temporary plot file created by AutoCAD.

This batch file requires two parameters to be passed from AutoCAD, %s and
%c, which are referenced internally in the batch program as %1 and %2,
respectively. The imaginary devices in this example are attached to the local
workstation and two different network printer servers. See the following table
for an explanation of the device names and connections. Note that the order
in which parameters are passed to the AutoSpool executable file determines
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how the variable is referenced in the program or batch file. For example, the
first variable becomes %1 and so forth.

Device names and connections

AutoCAD
configuration name

Network share nameServerDescription

my_laserLocal laser printer

hp755cm\\milana\hp755cmmilanaNetwork-attached
plotter

net_laser\\kilo\laserkiloNetwork-attached laser
printer

Rem PLOT.BAT
@echo off
Rem determine the destination
if %2 == my_laser goto PlotA
if %2 == hp755cm goto PlotB
if %2 == net_laser goto PlotC
Rem trap for undefined devices
echo *******************Warning**********************
echo %2 is not defined to the Plot Script, PLOT.BAT
echo The plot job has been canceled.
echo ************************************************
pause
goto END
Rem send the job
:PlotA
copy %1 /b LPT1
goto END
:PlotB
copy %1 /b \\milana\hp755cm
goto END
:PlotC
copy %1 /b \\kilo\laser
goto END
Rem clean up and exit
:END
erase %1
exit

NOTE Device names are case-sensitive. Make sure that the name configured for
the device in AutoCAD exactly matches the name in your batch program.

To use AutoSpool

1 Start the Add-a-Plotter wizard.

2 On the Ports page, select AutoSpool.
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3 From the Tools menu, choose Options. Then choose the Files tab.

4 Double-click Print file, Spooler, and Prolog Section Names to display the
options in this section.

5 Double-click Print Spool Executable.

6 Double-click the arrow. In the Select a File dialog box, locate the program
you want to execute when the plot file has been created. Add any
command line arguments you want to use. For example, enter
myspool.bat %s.

When AutoCAD plots to a file, it substitutes a unique plot file name for “%s”
in the Print Spool Executable name and sends the generated command to
DOS.

Print spool executable command line options

FunctionOption

Specifies the AutoCAD drawing name, including the full path
and -extension

%d or %D

Specifies the equal sign (=)%e or %E

Returns the height of the plot area in the selected plotting units%h or %H

Becomes the first letter of the plot units%i or %I

Designates the login name; the login name is stored in the
LOGINNAME system variable

%l or %L

Returns the AutoCAD plotter model; AutoCAD lists the model
name during configuration

%m or %M

Becomes the plotter name; AutoCAD uses the plotter name to
identify the manufacturer and type of plotter

%n or %N

Designates the plotter number; AutoCAD assigns a number to
a configured plotter and lists the plotters in this order

%p or %P

Specifies the plot spool file name, including the path and
extension

%s or %S

Specifies the user name entered during installation%u or %U

Returns the width of the plotter area in the selected units%w or %W

Specifies the percent sign (%)%%

Specifies the description for the device%c or %C
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Print spool executable command line options

FunctionOption

(This is the description entered on the General tab of the Plotter
Configuration Editor. This description should not contain spaces
if you want to use it with AutoSpool.)

To specify the location for AutoSpool print files

1 From the Tools menu, choose Options. Choose the Files tab.

2 Double-click Print Support File Path.

3 Double-click the Print Spooler File Location.

4 Double-click the arrow.

5 In the Select a File dialog box, enter the path to the directory where you
want AutoSpool to send its print files.

Set the Timeout Value for Devices

Some plotters support a timeout value, which specifies how much time elapses
while the plotter empties its buffer before more data is sent to the plotter.

After the plotter empties its buffer, it accepts more data from AutoCAD. Enter
the amount of time you want to elapse before AutoCAD prompts you to abort
the plot. If your drawings are complex or your pen speed is very slow, set the
timeout value higher than the default (30 seconds). If you begin to receive
numerous timeout messages, your timeout setting is probably too low. For
plotters that support a timeout value, you can also set the timeout value by
choosing Configure Port on the Ports page during the initial configuration in
the Add-a-Plotter wizard.

To set the timeout value for a local, nonsystem plotter

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose timeout value
you want to change.

3 In the Plotter Configuration Editor, choose the Ports tab.

4 On the Ports tab, select the port that you want to use.

5 Choose Configure Port and do one of the following:

■ For a parallel port, in the Transmission Retry box, enter the timeout
value in milliseconds.
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■ For a serial port, in the Input Timeout and Output Timeout boxes,
enter the timeout values in milliseconds.

6 Choose OK.

To set the timeout value for network or Windows system printers

1 From the Start menu, choose Settings. Then choose Printers.

2 Right-click the printer you want, and then choose Properties.

3 In the Properties dialog box, choose the Ports tab.

4 On the Ports tab, select the LPT port that the printer uses, and then
choose Configure Port.

5 In the Transmission Retry box, enter the number of seconds.

6 Choose OK to exit each dialog box.

Configure Serial Ports

You can adjust baud rate, protocol, flow control, and hardware handshaking
for serial ports on devices that support these settings.

You should use the fastest available baud rate and the protocol recommended
by your device manufacturer. See the documentation that accompanies your
device.

NOTE The settings on your plotter must match the settings in AutoCAD or you
will not be able to plot.

Flow Control and Handshaking

Your computer can produce a plot file faster than most plotters can process
it. Plotters have a limited amount of memory and as this memory fills up, the
plotter must be able to tell your computer to stop sending data temporarily.
Then, when plotter memory is freed up as the plot is processed, the plotter
must be able to tell the computer to resume sending the plot file. This
communication is called flow control or handshaking.

There are two methods of handshaking: hardware and software. Hardware
handshaking uses additional wires in the cable between the plotter and
computer. These wires are dedicated to handshaking signals or on/off voltages.
Software handshaking uses a single wire to send streams of commands that
include start/stop handshaking signals. The most common type of software
handshaking is XON/XOFF. You must provide different cables for hardware
and software handshaking.
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To adjust serial port settings

1 From the File menu, choose Plotter Manager.

2 Double-click the plotter configuration (PC3) file whose serial port settings
you want to change.

3 In the Plotter Configuration Editor, choose the Ports tab and select the
serial port that you want to use.

4 Choose Configure Port.

5 In the Settings for COM Port dialog box, select a baud rate and protocol
for your device.

The protocol settings available for the current device are displayed. You
cannot set an invalid protocol.

6 Select a Flow Control method.

The default flow control setting is XON/XOFF (software handshaking)
for compatibility with previous versions of AutoCAD. If you select
Hardware handshaking, you can specify additional settings by choosing
Advanced.

In the Advanced Settings for COM Port dialog box, the following settings
correspond to different pins on the serial port:

■ CTS. Enables Clear to Send handshaking. This monitors pin 5 of a
25-pin serial port or pin 8 of a 9-pin serial port. CTS is an input bit,
monitored for an output from the plotter or printer.

■ DSR. Enables Data Set Ready handshaking. This monitors pin 6 of a
25-pin serial port, or pin 6 of a 9-pin serial port. DSR is an input bit,
monitored for an output from the printer or plotter.

■ RLSD. Enables Received Line Signal Detector handshaking. This is
sometimes called Data Carrier Detect or DCD. It’s an input pin that
can be monitored for an output from the plotter. It’s on pin 8 of a
25-pin serial port and on pin 1 of a 9-pin serial port.

■ RTS. Controls the Request to Send output bit. This sends a signal to
the printer or plotter on pin 4 of a 25-pin serial port or on pin 7 of a
9-pin serial port.

Disabled. Disables the RTS line when the device is opened.

Enabled. Enables the RTS line when the device is opened.

Handshake. Enables RTS handshaking. The driver raises the RTS line
when the “type-ahead” (input) buffer is less than one-half full and
lowers the RTS line when the buffer is more than three-quarters full.
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Toggle. Specifies that the RTS line will be high if bytes are available
for transmission. After all buffered bytes have been sent, the RTS line
will be low.

■ DTR. Controls the Data Terminal Ready output pin. This sends a
signal to the printer or plotter on pin 20 of a 25-pin serial port or on
pin 4 of a 9-pin serial port.

Disabled. Disables the DTR line when the device is opened.

Enabled. Enables the DTR line when the device is opened.

Handshake. Enables DTR handshaking.

7 Choose OK to close the Advanced Settings for COM Port dialog box.
Choose OK to close the Settings for COM Port dialog box.
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Configure Hewlett-Packard DesignJets
Hewlett-Packard DesignJet plotters are supported by a Windows system printer
driver developed by Hewlett-Packard. Visit
http://hp.com/go/designjet
to check for the latest HP DesignJet drivers.

Plotters from other manufacturers that emulate HP DesignJets are supported
through the HP-GL/2 HDI driver.

AutoCAD® supports the Hewlett-Packard DesignJet plotter models through a
serial or a parallel port. Using the parallel port is recommended. If you use a
serial port, set the DesignJet at 9600 baud, with 8 data bits, 1 stop bit, no
parity, and hardware handshaking XON/XOFF.

All DesignJet roll-feed models can produce long-axis plots. Both the 600 and
650C have an optional expanded mode for page formats and margins. You
set the Expanded mode on the plotter’s front panel.

NOTE If you experience plotting problems, such as resolution degradation for
lines and shaded solids, when plotting to an Hewlett-Packard DesignJet plotter,
contact Hewlett-Packard for support.

Configure Hewlett-Packard HP-GL Plotters
Hewlett-Packard HP-GL plotters are supported through an RS-232C serial I/O
port.

Set the Hewlett-Packard plotters at 9600 baud with 7 data bits, 1 stop bit, and
even parity.

For detailed cabling, switch setting, and other information related to using
the HP-GL driver, see HP-GL Custom Properties Dialog Box.

For more information about using this driver, open the PC3 file for this device
and choose Help in the Custom Properties dialog box in the Plotter
Configuration Editor.

Hard Clip Limits

The 7580, 7585, 7586, DraftPro DXL/EXL, DraftMaster I, 7586B, and 7596A
plotters return hard clip limits to AutoCAD. These limits require two-way
communication between AutoCAD and the plotter. The plotter sends AutoCAD
the installed paper’s exact plot area so that AutoCAD can position the plot
on the paper based on the actual sheet size. If you turn off the AutoCAD
request for hard clip limits, AutoCAD positions the plot based on the
configured paper size. In most cases, if you turn off hard clip limits, you must
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adjust the configured paper size to reflect the actual printable area of the
device. Otherwise, your plot may be clipped. You can adjust the location of
the plot on the paper by changing the plot origin.

If your plot is sent through the Windows print spooler, the AutoCAD request
for hard clip limits is turned off because of a conflict with a Windows system
printer or because you’re plotting to a network port. If you see a warning
message, you may have to adjust your configured paper size and plot origin.

AutoCAD sends the plot to the currently configured port in the same manner
that it sends the plot to a file. After the plot is sent, you can plot directly to
plotter buffers or over networks.

HP-GL Long-Axis Plots

For roll-fed media, HP-GL devices limit the frame height. Frame height varies
with roll width. You must perform a long-axis plot to plot more than the
frame height.

AutoCAD determines whether a long-axis plot is necessary when you configure
to use a long-axis paper size and when you create a long-axis plot paper size
using the Add Paper Size wizard in the Plotter Configuration Editor.

The driver sends all vectors to the plotter buffer or hard disk. The pen plotters
automatically advance the page to plot each frame.

Follow the instructions in the Hewlett-Packard user’s guide. For long-axis,
multiframe plotting, you need a black 0.3 mm fiber-tip pen (for plotter paper)
or a 0.35 mm drafting pen (for vellum or polyester film) in pen stall 8. Only
these pens enable the plotter to detect the registration marks used for
frame-to-frame alignment.

When you create a long-axis plot with the 7586B roll-feed plotter, the Out of
Limit light comes on occasionally. Generally this is a result of the interaction
between AutoCAD and the plotter when plotting very large drawings.

To configure an HP-GL plotter driver

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, choose My Computer if the plotter is connected to
your computer. Select Network Plotter Server if the plotter is available
through a network. Choose Next.

4 On the Network Plotter page, enter the UNC name of the networked
plotter. Choose Next. This page is not displayed if you selected My
Computer in step 3.

Configure Hewlett-Packard HP-GL Plotters | 39



5 On the Plotter Model page, under Manufacturers, select Hewlett-Packard.
Under Model, select the type of Hewlett-Packard plotter that you are
using or emulating. Choose Next.

6 On the Import PCP or PC2 page, select a PCP or PC2 file to import
(optional). Choose Next.

7 On the Ports page, select the port that the printer is attached to. This
page is not displayed if you selected Network Plotter Server in step 3.
Choose Next.

8 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.

9 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.

To stop the long-axis plot after all vectors have been sent

■ Press Cancel on the plotter Control Panel to clear the plotter memory.

To stop the long-axis plot while vectors are being sent to the plotter

■ Press  ESC . Read your Hewlett-Packard manual for information about
canceling the plot and clearing its memory buffer.

You must reset your plotter after canceling a plot, otherwise portions of the
plot may overlay the next plot.

Configure Hewlett-Packard HP-GL/2 Devices
The HP-GL/2 nonsystem driver supports a variety of HP-GL/2 pen plotters
and ink jet plotters.

This is a generic HP-GL/2 driver; it is not optimized for a particular
manufacturer’s devices. This driver is intended to support obsolete pen plotters
and newer devices made by manufacturers other than HP.

The DesignJet, DraftPro Plus, and the DraftMaster with roll feed can perform
long-axis plots.

For more information about using this driver, open the PC3 file for this device
and choose Help in the Custom Properties dialog box in the Plotter
Configuration Editor.
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To configure an HP-GL/2 plotter driver

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, select My Computer if the plotter is connected to
your computer. Select Network Plotter Server if the plotter is available
through a network. Choose Next.

4 On the Network Plotter page, enter the UNC name of the networked
plotter. Choose Next. This page is not displayed if you selected My
Computer in step 3.

5 On the Plotter Model page under Manufacturers, select Hewlett-Packard.
Under Model, select the type of Hewlett-Packard plotter that you are
using or emulating. Choose Next.

6 On the Import PCP or PC2 page, select a PCP or PC2 file to import
(optional). Choose Next.

7 On the Ports page, select the port that the printer is attached to. This
page is not displayed if you selected Network Plotter Server in step 3.
Choose Next.

8 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.

9 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.

To perform a long plot

1 Plot in the normal manner. For best results, plot to extents, don’t rotate
the plot. Use an explicit one-to-one scale (not Scale to Fit).

2 To stop your plotter after AutoCAD has finished sending all the vectors,
clear the plotter memory using the plotter Control Panel.

3 To stop a long-axis plot while AutoCAD is sending vectors to the plotter,
press  ESC .

4 Clear the plotter memory as indicated for the following devices:

■ DraftMaster X series. Press the Cancel button.

■ HP 7600 240D/E. Press the plotter Reset button.

■ HP 7600 250/255/355. Press the Plot Management button. Select
Queuing Operations, and then select the plot and delete it from the
queue.
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■ HP DesignJet Series. Press the Cancel button.

■ HP DraftPro Plus. Press the Cancel button.

Configure Oce Plotters
Although the primary configuration choice for Oce plotters is through a parallel
port, Oce plotters can be supported through an RS-232C serial I/O port.

Set the Oce plotters at 9600 or 19,200 baud, with 8 data bits, 1 stop bit, and
no parity. Serial port cabling instructions are available from your dealer or
manufacturer.

For more information about using this driver, open the PC3 file for this device
and choose Help in the Custom Properties dialog box in the Plotter
Configuration Editor.

To configure an Oc plotter driver

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, select My Computer if the plotter is connected to
your computer. Select Network Plotter Server if the plotter is available
through a network. Choose Next.

4 On the Network Plotter page, enter the UNC name of the networked
plotter. Choose Next. This page is not displayed if you selected My
Computer in step 3.

5 On the Plotter Model page under Manufacturers, select Oce. Under Model,
select the type of Oce plotter that you are using. Choose Next.

6 On the Import PCP or PC2 page, select a PCP or PC2 file to import
(optional). Choose Next.

7 On the Ports page, select the port that the printer is attached to. This
page is not displayed if you selected Network Plotter Server in step 3.
Choose Next.

8 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.

9 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.
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Configure Xerox Devices
It is highly recommended that you use the Xerox HDI driver for AutoCAD.
Along with improved performance, this new driver provides the same settings
that now exist in the Windows system driver as well as the ability to get
information from the printer in a bi-directional environment, such as roll
status and what raster stamps are installed in the printer.

For more information on the latest Xerox devices and drivers, see the Xerox
website.

To configure an HDI Xerox plotter driver

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, select My Computer if the plotter is connected to
your computer. Select Network Plotter Server if the plotter is available
through a network. Choose Next.

4 On the Network Plotter page, enter the UNC name of the networked
plotter. Choose Next. This page is not displayed if you selected My
Computer in step 3.

5 On the Plotter Model page under Manufacturers, select Xerox Engineering
Systems. Under Model, select the type of Xerox plotter that you are using.
Choose Next.

6 On the Import PCP or PC2 page, select a PCP or PC2 file to import
(optional). Choose Next.

7 On the Ports page, select the port that the printer is attached to. This
page is not displayed if you selected Network Plotter Server in step 3.
Choose Next.

8 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.

9 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.

Configure CalComp Plotters
If you are using a CalComp plotter, you can use the Windows system printer.

If your plotter provides an HP-GL or HP-GL/2 emulation, you can use the
HP-GL or HP-GL/2 HDI drivers.
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For more information about using this driver, open the PC3 file for this device
and choose Help in the Custom Properties dialog box in the Plotter
Configuration Editor.

Configure Houston Instruments Plotters
If you are using a newer Houston Instruments plotter, use the generic HP-GL
or HP-GL/2 HDI drivers and configure your plotter in HP-GL or HP-GL/2
emulation mode.

Use the Autodesk HDI System Printer Driver
With the HDI system printer driver, you can use the plotter or printer you
have configured with Windows.

You can use any printing device supported by Windows (Windows system
printer).

You can use the HDI system printer driver to choose printer defaults for
AutoCAD that differ from the defaults for other Windows applications.

The Autodesk system printer driver supports raster output. However, the
amount of memory in the printing device limits the ability of the device
connected as the system printer to output raster and vector data sent by
AutoCAD.

If you have multiple Windows system printers, you can select the device used
to plot from AutoCAD. For example, you might use a LaserJet printer for word
processing documents and a BubbleJet for AutoCAD drawings.

For best results, use the Windows system printer and AutoCAD plotter drivers
as follows:

■ Use the Autodesk HDI driver appropriate to your plotter in preference to
the Windows system printer unless you have a Hewlett-Packard DesignJet
plotter. HP has supplied a system printer driver for DesignJets that is
optimized for AutoCAD use.

■ Use the Windows system printer for output devices without pens, such as
laser printers.

Setting up the Windows system printer for AutoCAD consists of two parts:

■ Configuring the system printer in Windows (see the Microsoft
documentation for your operating system)
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■ Configuring the system printer as the AutoCAD plotter using the
Add-a-Plotter Wizard shortcut icon

To create a plotter configuration for the system printer

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, select System Printer. Choose Next.

4 On the System Printer page, select the system printer for which you want
to create a plotter configuration file. Choose Next.

5 On the Import PCP or PC2 page, choose Import File and select a PCP or
PC2 file to import (optional). Choose Import. Then choose Next.

6 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.

7 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.
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AutoCAD® provides plotter drivers to create the following types of files:

■ Autodesk ePlot (DWF)

■ Adobe PostScript

■ DXB file format

■ Raster file formats

Configure ePlot to Create DWF Files

With ePlot, you can generate electronic drawing files that are optimized for
either plotting or viewing. The files you create are stored in Design Web Format
(DWF). DWF files can be opened, viewed, and plotted by anyone using
Autodesk DWF Viewer® or Autodesk DWF Composer®. With Autodesk DWF
Viewer or Autodesk DWF Composer, you can also view DWF files in Microsoft®

Internet Explorer 5.01 or later. DWF files support real-time panning and
zooming and the display of layers and named views.

Configure the Adobe PostScript Driver

If you configure a PostScript driver in the Add-a-Plotter wizard, you can output
your drawings in PostScript format. To configure the PostScript driver, in the
Add-a-Plotter wizard, select Adobe from the Manufacturer list, and select a
PostScript level from the Model list.

AutoCAD supports three levels of PostScript. Level 1 works with most devices
but does not support color images and produces larger plot files than the
newer PostScript levels. Level 1 Plus is for Level 1 devices that also support
color images. Level 2 is for newer printers and produces smaller files and faster
output on Level 2 devices.

AutoCAD supports PostScript printers and plotters using a Centronics-type
parallel I/O port, an RS-232C serial I/O port, or plotting across a network. If
you use a serial port, configure the printer to match the settings you select in
the Configure Port dialog box in the Add-a-Plotter wizard, Ports page.

Configure DXB File Formats

DXB (drawing interchange binary) file formats are supported using the
AutoCAD DXB nonsystem file driver.

The output is compatible with the DXBIN command and with the ADI DXB
driver delivered with earlier releases. The DXB driver shares the following
limitations of the ADI driver:

■ The driver produces 16 bit integer DXB files containing only vectors.

■ DXB output is monochrome; all vectors are color 7.
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■ Raster images and embedded OLE objects are not supported.

■ The driver ignores object and plot style lineweights.

Configure Raster File Formats

AutoCAD can view drawings that contain raster images such as TIFF or JPEG.

With the raster file format driver, AutoCAD can also export raster files in the
formats listed in the Add-a-Plotter wizard. To configure a raster format driver,
select Raster File Formats from the Manufacturer list.

See also:

“Plot Files to Other Formats” in the User’s Guide

To configure a plotter driver for DWF file output

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, select My Computer. Choose Next.

4 On the Plotter Model page, under Manufacturers, select Autodesk ePlot
(DWF). Under Model, select the type of DWF that you want to create.
Choose Next.

5 On the Import PCP or PC2 page, choose Import File and select a PCP or
PC2 file to import (optional). Choose Import. Then choose Next.

6 On the Ports page, select Plot to File. Choose Next.

7 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.

8 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.

To configure a plotter driver for PostScript file output

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, select My Computer. Choose Next.

4 On the Plotter Model page under Manufacturers, select Adobe. Under
Model, select the level of PostScript file that you want to create. Choose
Next.
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5 On the Import PCP or PC2 page, choose Import File and select a PCP or
PC2 file to import (optional). Choose Import. Then choose Next.

6 On the Ports page, select Plot to File. Choose Next.

7 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.

8 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.

To configure a plotter driver for DXB file output

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, select My Computer. Choose Next.

4 On the Plotter Model page, under Manufacturers, select AutoCAD DXB
File. Under Model, select DXB File. Choose Next.

5 On the Import PCP or PC2 page, choose Import File and select a PCP or
PC2 file to import (optional). Choose Import. Then choose Next.

6 On the Ports page, select Plot to File. Choose Next.

7 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.

8 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.

To configure a plotter driver for raster file output

1 From the File menu, choose Plotter Manager.

2 Double-click the Add-a-Plotter Wizard shortcut icon.

3 On the Begin page, select My Computer. Choose Next.

4 On the Plotter Model page under Manufacturers, select Raster File
Formats. Under Model, select the type of raster file that you want to
create. Choose Next.

5 On the Import PCP or PC2 page, choose Import File and select a PCP or
PC2 file to import (optional). Choose Import. Then choose Next.

6 On the Ports page, select Plot to File. Choose Next.

7 On the Plotter Name page, enter a name for the plotter configuration
file. Choose Next.
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8 On the Finish page, choose Finish.

A new plotter configuration file (PC3) is created.

To view the custom properties Help

1 From the File menu, choose Plotter Manager.

2 In the Autodesk Plotter Manager, double-click to open the PC3 file whose
custom properties help you want to view.

3 Choose the Device and Document Settings tab.

4 Select the Custom Properties node.

5 Choose Custom Properties.

6 In the Custom Properties dialog box for the configured device, choose
Help.

Help provides specific configuration information.
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Once you have configured your databases, you can access their data from
AutoCAD, even if you don’t have the database system that created the data
installed on your system. AutoCAD can access data from the following
applications:

■ Microsoft Access

■ dBase

■ Microsoft Excel

■ Oracle

■ Paradox

■ Microsoft Visual FoxPro®

■ SQL Server

NOTE With MDAC versions 2.1 and higher, you can’t edit dBase files unless you
have a Borland DataBase Engine (BDE) installed on your computer.

Once you have successfully configured a database to use with AutoCAD, a
configuration file with the extension .udl is created. This configuration file
contains the information AutoCAD needs to access the configured database.
By default, .udl files are stored in the Data Links folder of AutoCAD. You can
specify a different location for .udl files from the Options dialog box.

The following topics demonstrate how to set up a data source using ODBC,
and how to configure data sources so that you can use them with AutoCAD.
For detailed information about ODBC and OLE DB, refer to the following
online Microsoft resources:

■ OLE DB Help

■ ODBC Help

■ ODBC Microsoft Desktop Database Drivers

Bypass ODBC Using an OLE DB Direct Driver

Several database management systems supported by AutoCAD have direct
drivers available for OLE DB. If you use these direct drivers, you don’t need
to set up configuration files from within both ODBC and OLE DB; you only
need a single OLE DB configuration file.

Direct database drivers are available for the following database systems:

■ Microsoft Access
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■ Oracle

■ Microsoft SQL Server

Use ODBC to Create a Configuration File

ODBC is an intermediary program that makes data from one application
available to other applications.

Configure a Data Source with OLE DB

You can use OLE DB to establish a UDL configuration file that points to an
external database table.

To specify a new location for .UDL files

1 From the Tools menu, choose Options.

2 From the Files tab, select Data Source Location, and then choose Browse.

3 From the Browse for Folder dialog box, locate and select the folder you
want, and then choose OK.

4 Choose OK.

To set up a direct Microsoft Access configuration using OLE DB

1 From the dbConnect menu, choose Data Sources ➤ Configure.

2 In the Data Link Properties dialog box, the Provider tab, select Microsoft
Jet 3.51 OLE DB Provider. Choose Next.

3 Enter the name and path to the database you want to configure in Select
or Enter a Database Name.

4 Choose Test Connection to verify that your configuration is working
properly.

If the connection fails, verify that the settings are correct. For example,
spelling errors and case sensitivity may be the cause of a failed
connection.

5 In the Microsoft Data Link dialog box, choose OK.

6 Choose OK.

To set up a direct Oracle configuration using OLE DB

1 From the dbConnect menu, choose Data Sources ➤ Configure.

 | 55



2 In the Data Link Properties dialog box, the Provider tab, select Microsoft
OLE DB Provider for Oracle. Choose Next.

3 Enter the Oracle server name in Enter a Server Name.

4 Enter a valid user name and password.

5 Choose Test Connection to verify that the settings are correct. For
example, spelling errors and case sensitivity may be the cause of a failed
connection.

6 In the Microsoft Data Link dialog box, choose OK.

7 Choose OK.

To set up a direct SQL Server configuration using OLE DB

1 From the dbConnect menu, choose Data Sources ➤ Configure.

2 In the Data Link Properties dialog box, the Provider tab, select Microsoft
OLE DB Provider for SQL Server. Choose Next.

3 Enter the server name in Select or Enter a Server Name.

4 Enter a valid user name and password.

5 Select the database to configure in Select the Database on the Server.

6 Choose Test Connection to verify that the settings are correct. For
example, spelling errors and case sensitivity may be the cause of a failed
connection.

7 In the Microsoft Data Link dialog box, choose OK.

8 Choose OK.

To set up a Microsoft Access data source using ODBC

1 From the Start menu (Windows), choose Settings ➤ Control Panel.

2 Double-click the ODBC icon.

3 In the ODBC Data Source Administrator dialog box, do one of the
following:

■ Choose the User DSN tab to create a data source that is visible only
to you and can be used only on the computer you create it in.

■ Choose the System DSN tab to create a data source that is visible to
all users who have access rights to the computer.
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■ Choose the File DSN tab to create a data source that can be shared
with other users who have the same ODBC drivers installed on their
systems.

4 Choose Add.

5 Select the Microsoft Access Driver, and then choose Finish.

6 Enter a name for your data source in Data Source Name.

7 Choose Select, and then locate and select the database that you want to
configure. Choose OK.

8 In the ODBC Microsoft Access dialog box, choose OK.

9 In the ODBC Data Source Administrator dialog box, choose OK.

To set up a dBase data source using ODBC

1 From the Start menu (Windows), choose Settings ➤ Control Panel.

2 Double-click the ODBC icon.

3 In the ODBC Data Source Administrator dialog box, do one of the
following:

■ Choose the User DSN tab to create a data source that is visible only
to you and can be used only on the computer you create it in.

■ Choose the System DSN tab to create a data source that is visible to
all users who have access rights to the computer.

■ Choose the File DSN tab to create a data source that can be shared
with other users who have the same ODBC drivers installed on their
systems.

4 Choose Add.

5 Select the Microsoft dBase Driver, and then choose Finish.

6 Enter a name for your data source in Data Source Name, and select the
appropriate version of dBase from the Version list.

7 Make sure that Use Current Directory is cleared.

8 Choose Select Directory, and then locate and select the directory that
contains the database tables you want to configure. Choose OK.

9 In the ODBC dBase Setup dialog box, choose OK.

10 In the ODBC Data Source Administrator dialog box, choose OK.
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To set up a Microsoft Excel spreadsheet to use with AutoCAD

1 From Microsoft Excel, open the workbook or spreadsheet that you want
to access from AutoCAD.

2 Select a range of cells to function as a database table.

3 Enter a name for the range of cells in the Name Box, then press  ENTER
.

4 Repeat steps 2 and 3, if desired, to specify additional database tables.

5 From the File menu (Microsoft Excel), choose Save.

NOTE Microsoft Excel is not a true database management system. In order to
access Excel data from within AutoCAD, you must first specify at least one named
range of Excel cells to function as a database table. Each named range of cells that
you specify within a spreadsheet is treated as an individual table by AutoCAD.

To set up a Microsoft Excel data source using ODBC

1 From the Start menu (Windows), choose Settings ➤ Control Panel.

2 Double-click the ODBC icon.

3 In the ODBC Data Source Administrator dialog box, do one of the
following:

■ Choose the User DSN tab to create a data source that is visible only
to you and can be used only on the computer you create it in.

■ Choose the System DSN tab to create a data source that is visible to
all users who have access rights to the computer.

■ Choose the File DSN tab to create a data source that can be shared
with other users who have the same ODBC drivers installed on their
systems.

4 Choose Add.

5 Select the Microsoft Excel Driver, and then choose Finish.

6 Enter a name for your data source in Data Source Name, and select the
appropriate version of Excel from the Version list.

7 Make sure that Use Current Directory is cleared.

8 Choose Select Workbook, and then locate and select the workbook or
spreadsheet you want to configure. Choose OK.

9 In the ODBC Microsoft Excel dialog box, choose OK.
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10 In the ODBC Data Source Administrator dialog box, choose OK.

To set up an Oracle data source using ODBC

1 From the Start menu (Windows), choose Settings ➤ Control Panel.

2 Double-click the ODBC icon.

3 In the ODBC Data Source Administrator dialog box, do one of the
following:

■ Choose the User DSN tab to create a data source that is visible only
to you and can be used only on the computer you create it in.

■ Choose the System DSN tab to create a data source that is visible to
all users who have access rights to the computer.

■ Choose the File DSN tab to create a data source that can be shared
with other users who have the same ODBC drivers installed on their
systems.

4 Choose Add.

5 Select Microsoft ODBC for Oracle, and then choose Finish.

6 Enter a name for your data source in Data Source Name.

7 Enter your user name.

8 Enter the name of the Oracle Server in Server.

9 Choose OK.

10 In the ODBC Data Source Administrator dialog box, choose OK.

To set up a Paradox data source using ODBC

1 From the Start menu (Windows), choose Settings ➤ Control Panel.

2 Double-click the ODBC icon.

3 In the ODBC Data Source Administrator dialog box, do one of the
following:

■ Choose the User DSN tab to create a data source that is visible only
to you and can be used only on the computer you create it in.

■ Choose the System DSN tab to create a data source that is visible to
all users who have access rights to the computer.
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■ Choose the File DSN tab to create a data source that can be shared
with other users who have the same ODBC drivers installed on their
systems.

4 Choose Add.

5 Select the Paradox Driver, and then choose Finish.

6 Enter a name for your data source in Data Source Name, and select the
appropriate version of Paradox from the Version list.

7 Make sure that User Current Directory is cleared.

8 Choose Select Directory, and then locate and select the database you
want to configure. Choose OK.

9 In the ODBC Paradox Setup dialog box, choose OK.

10 In the ODBC Data Source Administrator dialog box, choose OK.

To set up a Microsoft Visual FoxPro data source using ODBC

1 From the Start menu (Windows), choose Settings ➤ Control Panel.

2 Double-click the ODBC icon.

3 In the ODBC Data Source Administrator dialog box, do one of the
following:

■ Choose the User DSN tab to create a data source that is visible only
to you and can be used only on the computer you create it in.

■ Choose the System DSN tab to create a data source that is visible to
all users who have access rights to the computer.

■ Choose the File DSN tab to create a data source that can be shared
with other users who have the same ODBC drivers installed on their
systems.

4 Choose Add.

5 Select the Microsoft Visual FoxPro Driver, and then choose Finish.

6 Enter a name for your data source in Data Source Name, and select a
type in Database Type.

7 Choose Browse, and then locate and select the database you want to
configure. Choose Open.

8 In the ODBC Visual FoxPro Setup dialog box, choose OK.

9 In the ODBC Data Source Administrator dialog box, choose OK.
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For additional information about setting up a Microsoft Visual FoxPro
data source, see the Microsoft Visual FoxPro ODBC Driver documentation.

To set up an SQL Server data source using ODBC

1 From the Start menu (Windows), choose Settings ➤ Control Panel.

2 Double-click the ODBC icon.

3 In the ODBC Data Source Administrator dialog box, do one of the
following:

■ Choose the User DSN tab to create a data source that is visible only
to you and can be used only on the computer you create it in.

■ Choose the System DSN tab to create a data source that is visible to
all users who have access rights to the computer.

■ Choose the File DSN tab to create a data source that can be shared
with other users who have the same ODBC drivers installed on their
systems.

4 Choose Add.

5 Select SQL Server, and then choose Finish.

6 Follow the instructions in the wizard to complete the data source setup.

Microsoft provides additional Help topics describing the interface
components of each page in the wizard. To view Help for a wizard page,
choose Help.

7 In the ODBC Data Source Administrator dialog box, choose OK.

You can use OLE DB to establish a UDL configuration file that points to an
external database table.

To configure a data source using OLE DB

1 Use Microsoft ODBC to set up a data source (see “Use ODBC to Create
a Configuration File” on page 55).

2 From the dbConnect menu, choose Data Sources ➤ Configure.

3 In the Data Link Properties dialog box, the Provider tab, select Microsoft
OLE DB Provider for ODBC Drivers. Choose Next.

4 Enter the name of the data source you want to configure in Use Data
Source Name.
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5 Choose Test Connection to verify that your configuration is working
properly.

If the connection fails, verify that the settings are correct. For example,
spelling errors and case sensitivity may be the cause of a failed
connection.

6 In the Microsoft Data Link dialog box, choose OK.

7 Choose OK.
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