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CAD



2 | Introduction

Draw to Scale

Drawing scale is something you consider when laying out your drawing. You establish scale 
differently in CAD than you do with manual drafting.

With manual drafting, you 
must determine the scale of a 
view before you start 
drawing. This scale compares 
the size of the actual object to 
the size of the model drawn 
on paper.

In AutoCAD, you first decide 
what units of measurement 
you will use, and then draw 
your model at 1:1 scale.

For example, when you draw a motor part, the 
length of one unit might equal one millimeter 
or one inch. When you draw a map, one unit 
might equal one kilometer or one mile.

This drawing of a mechanical carriage uses 
millimeters for the length of one unit. Views of 
the part were scaled later to create the layout 
for the printed drawing.

Draw the object at 1:1 scale in the units you 
choose.

When you lay out and plot your drawing, you 
can specify any scale.
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Lay Out Your Drawing

On paper, a layout is constrained by the sheet size you use. In CAD, you are not limited to one 
particular layout or sheet size.

When you draft manually, you 
first select a sheet, which usually 
includes a preprinted border and 
title block. Then you determine 
the location for views—plans, 
elevations, sections, and details. 
Finally, you start to draw.

With AutoCAD, you first draw 
your design, or model, in a 
working environment called model 
space. You can then create a layout 
for that model in an environment 
called paper space.

A layout represents a drawing sheet. It typically 
contains a border, title block, dimensions, general 
notes, and one or more views of the model 
displayed in layout viewports. Layout viewports are 
areas, similar to picture frames or windows, 
through which you can see your model. You scale 
the views in viewports by zooming in or out.

In this drawing of a cottage, layout viewports 
display the model in plan and elevation views.

You create your basic design, or 
model, in a drawing area called model 
space.

When you’re ready to print, you can arrange 
different views of your model in a layout.
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Organize Drawing Information

In both manual drafting and CAD, you need a way to organize your drawing content—a method for 
separating, sorting, and editing specific drawing data.

With manual drafting, you can separate 
information onto individual transparent 
overlays. For example, a building plan might 
contain separate overlays for its structural, 
electrical, and plumbing components.

In AutoCAD, layers are equivalent to 
transparent overlays. As with overlays, you can 
display, edit, and print layers separately or in 
combination.

You can name layers to help track content, and lock layers so 
they can't be altered. Assigning settings such as color, linetype, or 
lineweight to layers helps you comply with industry standards.

You can also use layers to organize drawing objects for plotting. 
Assigning a plot style to a layer makes all the objects drawn on 
that layer plot in a similar manner.

This drawing of a press uses layers to define different linetypes 
and colors.

Turn off layers to hide complex 
details as you work.

Display layers when you need 
to see all components.
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Establish Drafting Standards

Whether you work as a member of a team or on an individual project, developing standards is a 
requirement for efficient communication.

Manual drafting requires meticulous 
accuracy in drawing linetypes, 
lineweights, text, dimensions, and 
more. Standards must be established 
in the beginning and applied 
consistently.

With AutoCAD, you can ensure 
conformity to industry or company 
standards by creating styles that you 
can apply consistently.

You can create styles for text, dimensions, and 
linetypes. A text style, for example, establishes font and 
format characteristics such as height, width, and slant.

You can save styles, layers, layouts, title block and 
border information, and some command settings in 
drawing template files. Using drawing templates helps 
you quickly start new drawings that conform to 
standards.

This drawing of a roadway plan uses styles to maintain 
drafting standards for text, dimensioning, and 
linetypes.

Dimension, text, and linetype 
styles can be established in a 
template drawing and used for 
creating new drawings.
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Draw Efficiently

Draw with less effort and revise with more speed: these are the two main reasons you use CAD. 
AutoCAD has a complete set of drawing and editing tools to help eliminate repetitive, time-
consuming drafting tasks.

With manual drafting, you use drawing 
tools that include pencils, scales, 
compasses, parallel rules, templates, and 
erasers. Repetitive drawing and editing 
tasks must be done manually.

In AutoCAD, you can choose from a 
variety of drawing tools that create lines, 
circles, spline curves, and more.

You can easily move, copy, offset, rotate, 
and mirror objects. You can also copy objects between 
open drawings.

In this drawing of a trolley, copying and mirroring were 
used to create repeated and symmetrical features. 
Offsetting was used to draw parallel lines more 
efficiently.

You can save drafting time by drawing one 
half of an item and then mirroring it to create 
the other half.
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Draw Accurately

Engineering and architectural drawings require a high degree of accuracy. With CAD, you draft more 
accurately than with manual methods.

On paper, you must draw objects 
carefully to ensure correct size and 
alignment. Objects drawn to scale 
must be manually verified and 
dimensioned.

In AutoCAD, you can use several 
methods to obtain exact dimensions.

The simplest method is to locate 
points by snapping to an interval on 
a rectangular grid.

Another method is to specify exact coordinates. 
Coordinates specify a drawing location by indicating 
a point along an X and Y axis or a distance and angle 
from another point.

With object snaps, you can snap to locations on 
existing objects, such as an endpoint of an arc, the 
midpoint of a line, or the center point of a circle.

With polar tracking, you can snap to previously set 
angles and specify distances along those angles.

In this drawing of a pumping station, object snaps were 
used to ensure that lines connected perfectly. Polar 
tracking was used to draw lines at correct angles.The polar tracking feature 

displays visual guidelines at 
specific angles and can snap 
the cursor to an angle.

With object 
snaps, when you 
place your cursor 
here…

you can snap to the 
center point 
automatically.
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View Your Drawing

The power of CAD makes it easy for you to quickly view different parts of your design at different 
magnifications.

When you draft on paper, the 
size and resolution of your 
drawing is fixed.

In CAD, the size and resolution 
of your drawing can be changed 
as needed.

To do detailed work, you can 
increase display size by zooming 
in. You can zoom out to display 
more of the drawing. To move 
to another section of a drawing, you pan the 
drawing without changing magnification.

You can zoom and pan to create the best working 
conditions. This can be invaluable when working 
on large and detailed drawings, such as this 
health spa plan.

You can zoom out to see more of your 
design, or zoom in to see more detail.

You can pan to shift to another area of your 
design.
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Create Standard Symbols

Symbols have long been used in manual drafting as a way to represent real-world objects in a 
simplified way. The ability to create and reuse standard symbols is one of CAD’s greatest strengths.

With manual drafting, you 
might use a symbol template 
or printed stickers to draw 
repetitive landscape, 
architectural, mechanical, or 
electrical symbols. This 
method, however, limits the 
possible variations of a 
symbol.

In CAD, you can save time by 
inserting copies of existing 
symbols anywhere in your 
drawing, at any rotation or 
scale. 

When you need to create a custom symbol, 
you combine several objects into a single 
object called a block. You then can insert the 
block as many times as needed into any 
drawing using DesignCenter.

Standard landscaping symbols are used 
extensively in this drawing of a residential 
landscaping plan.DesignCenter helps you locate libraries (collections) 

of blocks that you can drag onto your drawing or onto 
a tool palette. You can browse and preview blocks 
from drawings stored on your computer, on a 
company network, or on a website.
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Create Dimensions and Text

Creating accurate dimensions and consistent, legible text is a time-consuming task for the manual 
drafter. CAD provides ways to streamline this task.

When you work on paper, if 
you resize any part of the 
drawing, you must erase and 
then redraw the dimensions. 
Changing text can often 
involve relettering the whole 
drawing.

In AutoCAD, you create 
associative dimensions and text 
on the layout in paper space.

Associative dimensions are 
tied to the underlying model. Changes to the 
model automatically update the dimension 
values.

Standard types of dimensions in AutoCAD 
include linear, radial, ordinate, angular, 
baseline, and more.

You can easily revise the content, font, size, 
spacing, and rotation of text in dimensions and 
notes.

In this detail drawing of a gutter, the text, 
leaders, and dimensions describe the required 
hardware.

If you make dimensions associative, you can update 
the dimension size and value automatically when you 
stretch or scale the dimensioned object.

You can create leader lines with associated text. If you 
move the text, the leader is adjusted automatically.
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Modify Your Drawing

Revisions are a part of any drawing project. Whether you work on paper or with CAD, you will need 
to modify your drawing in some way.

On paper you must erase and redraw to make revisions to your drawing manually.

AutoCAD eliminates tedious manual editing by providing a variety of editing tools. 
If you need to copy all or part of an object, you don’t have to redraw it. If you need 
to remove an object, you can erase it with a few clicks of the mouse. And if you 
make an error, you can quickly undo your actions.

Once you draw an object, you never need to redraw it. You can modify existing 
objects by mirroring, rotating, scaling, stretching, trimming, and more. You can 
also change object properties, such as linetype, lineweight, color, and layer, at any 
time.

These before-and-after drawings show some typical edits to a house elevation. The revision cloud 
feature is used to mark areas of change.

Once you draw something, you can easily copy it without 
having to re-create it.
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Why You Should Use this Guide

This Getting Started guide provides an introduction to the most commonly used features of AutoCAD. 
Use it to learn the basic features so you can begin working quickly.

AutoCAD has a rich set of features and there are often many ways of accomplishing a task. This guide 
focuses on the following:

■ What do you need to know to get started?
■ What is the recommended method for using the features presented?

After you become more familiar with AutoCAD, you will find your own ways of working efficiently 
based on the type of work that you do.

NOTE The tutorials in this guide assume that you are is using the default settings of AutoCAD for 
display and behavior. If the settings have been customized, you might want to ask for help.

Get Information About AutoCAD

Additional resources are available when you need more information. From the Help menu, you can 
access the following resources:

■ Help provides procedures, conceptual information, and command descriptions. You can also 
press F1 at the Command prompt, in a dialog box, or at a prompt within a command to display 
Help information.

■ Info Palette automatically displays procedures that are relevent to the active command.
■ New Features Workshop provides a series of overviews about new features.
■ Additional Online Resources provides several options for additional help from the Web.

NOTE The Quick Reference card at the end of this guide provides an easy-to-use graphical key to the 
product interface, toolbars, shortcut keys, system variables, command aliases, and basic operations such 
as selecting objects.

Access Related Topics in the Help System

Keyword references are displayed at the end of most Getting Started topics. For example, the 
following information indicates that you can find concepts, procedures, commands, and system 
variables related to LAYOUT by entering layout in the Index tab of the Help window.

Help system

LAYOUT

Try it: Locate a Help topic using a keyword

■ Start AutoCAD and press the F1 key. Then follow the steps in the illustration.
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Tutorial: Use the Help System

In this tutorial, you will use the Help system to find information about how to start a drawing with 
a template file and how to create a layout.

NOTE It is important to learn how to use the Help system effectively. The Help system can provide 
answers that keep you from needless frustration.

1 Start AutoCAD and press F1 to display the Help window.

2 In the left pane of the Help window, click the Contents tab if necessary to display the table of 
contents. Then click the plus sign (+) next to User’s Guide.

The User’s Guide expands to display a list of chapters.

2 Enter a 
keyword 

3 Double-
click to view 
a topic

4 Click to display a concept 
related to the selected topic

5 Click to list 
procedures related to 
the selected topic

6 Click to list 
commands related 
to the selected topic

1 Click the 
Index tab
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3 In the left pane, click directly on the title, Start, Organize, and Save a Drawing. The right pane of 
the Help window displays links to several topics, with descriptions for each one.

4 In the right pane, click Start a Drawing. Then click Use a Template File to Start a Drawing.

You have navigated to a destination topic in the Help system. Notice that the table of contents 
in the left pane displays the topic structure for easy navigation.

5 Click the Procedures tab. Then click the first procedure on the list. Click the Procedures tab to 
redisplay the list.

6 Click the Commands tab. The Commands tab lists all commands and system variables that are 
associated with this topic.

If you click a link on this tab, the Command Reference is opened in Help, and provides details 
about command and dialog box options.

7 Next, in the left pane, click the Search tab.

You will now locate topics that contain the word layout.
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8 Type the word layout and press ENTER or click List Topics.

A large number of topics that contain the word layout are displayed.

9 Click the column labeled Title to sort the list of topics alphabetically. Then, click the column 
labeled Location to sort the list of topics by book: Command Reference, Customization Guide, User’s 
Guide, and so on.

10 Scroll down to find the User’s Guide topic, Work on a Layout Tab-Concepts. Then click Display (or 
double-click the topic).

The topic is displayed. But how do you know where you are in the table of contents? How can 
you display an adjacent, related topic?

11 In the left pane, click the Contents tab.

The table of contents opens to the current topic. Use this method to find related topics easily.

Note If the table of contents does not automatically open to the current topic, click the Concepts 
tab in the right pane.
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12 In the left pane, right-click any topic and then click Close All.

This is a quick method for collapsing the table of contents when too many subtopics are 
displayed.

13 Close the Help window.

For more information, read Use the Help System Efficiently. In the Help system, on the Contents tab, 
click User’s Guide ➤ Find the Information You Need ➤ Use the Help System Efficiently.
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Use Quick Help on the Info Palette

Quick Help on the Info palette provides convenient access to procedures in the Help system. During 
most activities, Quick Help displays a list of procedures that are relevent to the current command. 
You can click on a procedure to display it in the palette.

Often, the guidance you get from Quick Help is just enough to get you started performing unfamiliar 
or rarely used tasks.

Usually, the Quick Help information is updated as you start new commands; however, if you need 
to freeze the information so it doesn’t change as you change commands, you can lock the Info 
palette.

Navigate the Info Palette Content

You can right-click in the Info palette to display a shortcut menu with navigation commands. Use 
these commands to move forward and backward through viewed topics or return to Home in the 
Info palette, as you would in a web browser. You can click the title banner at the top of the Info 
palette to display a list of all commands and system variables in the product.

right-click in the palette 
or on the title bar to 
display a shortcut menu

display reference 
information

choose a procedure

title bar
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Control the Info Palette Display Options

You can access the options and settings for the Info palette from the shortcut menu displayed when 
you right-click the title bar of the Info palette. These settings include

■ Auto-hide. The Info palette can automatically roll open or roll away when your cursor moves over 
the title bar of the Info palette.

■ Transparency. The Info palette can be made transparent so it does not obscure objects under it.

NOTE The title bar can appear on either the left side or right side of the palette, depending on where 
the palette is dragged.

Help system

HELP, ASSIST

Review and Recall

1 What is the purpose of the tabs in the right pane of the Help window?

2 In the left pane of the Help window, when would you use the Contents tab rather than the Index tab?

3 From what menu can you get information about new features in AutoCAD?

To get started

Action Menu Toolbar

Access the Help system Help ➤ Help Standard

Use New Features Workshop Help ➤ New Features 
Workshop

Find training resources Help ➤ Additional Online 
Resources ➤ Training

Use Quick Help on the Info palette Help ➤ Info Palette

Print a Quick Help procedure Right-click for shortcut menu

Lock a Quick Help procedure Right-click for shortcut menu





Draw toolbar 
Contains 
buttons that 
create new 
objects.

Properties toolbar 
Displays and 
controls color, 
linetype, line-
weight, and plot 
style properties.

Command window
Displays commands in progress, 
options, and command history.

Status bar 
Indicates 
coordinate 
values and 
the status of 
drawing 
aids.

DesignCenter (can 
be docked or floating). 
Use to locate and place 
drawing content into 
drawings and onto tool 
palettes.

Drawing area The area of the 
AutoCAD window where you 
create and edit drawings.

Model and layout tabs Provide two working environments.

Layers toolbar Displays and 
controls layer settings.

Styles toolbar Displays and 
controls text settings.

Tool Palettes window 
(can be docked or 
floating). Use to drag 
frequently used blocks 
and hatches into 
drawings.

Standard toolbar Contains 
buttons for standard operations.

Menu bar Provides menu 
access to all commands.
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Use the Mouse

Most people use a mouse as their pointing device. On a two-button mouse, the left button is usually 
the pick button, used to specify points or select objects in the drawing area. With the right button, 
you can display a shortcut menu that contains relevant commands and options. Different shortcut 
menus are displayed depending on where you move the cursor.

NOTE To see what options are available in any situation, try right-clicking to display a shortcut menu.

A wheel mouse is a two-button mouse with a small wheel between the buttons. This wheel can be 
rotated or pressed down to zoom and pan your drawing quickly. It is highly recommended that you 
use a wheel mouse.

Cancel a Command

If you accidentally click in the screen, display a shortcut menu, or start a command, you can always 
escape by pressing the ESC key on your keyboard.

Try it: Cancel a selection

■ Click in the drawing area and move the mouse. AutoCAD is in a selection mode. Press ESC to 
cancel.

Start a Command

You can start a command using a menu, a toolbar, a palette, or the command line. Because AutoCAD 
is very flexible, you can work in the way that feels most comfortable to you.

You can choose commands from several different kinds of menus in AutoCAD:

■ Pull-down menus are available from the menu bar at the top of the AutoCAD window. All the 
commands for the tutorials in this book are accessible from these menus.

specify points or select objects display a shortcut menu
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■ The Object Snap menu is displayed when you hold down SHIFT and click the right mouse button. 
Object snaps facilitate precision drawing by snapping the cursor onto a feature on an object such 
as the endpoint of a line or the center of a circle.

■ Shortcut menus are displayed when you click the right mouse button. Different menus are 
displayed when you right-click an object, right-click in the drawing area, right-click a toolbar, or 
right-click within a dialog box, palette, or window.

Start Commands from Menus

Toolbars contain buttons that start commands. When you move the pointing device over a button, 
a tooltip displays its name.

Dock, Resize, and Float Toolbars

A docked toolbar is attached to any edge of the drawing area.

■ You can float a docked toolbar by clicking its move handle and dragging it anywhere in the 
drawing area.

■ You can resize a floating toolbar by dragging any edge.
■ You can dock a floating toolbar by clicking its title bar and dragging it to an edge of the drawing 

area. Press the CTRL key to prevent docking.

Hide, Display, and Lock Toolbars

■ You can display or hide toolbars by right-clicking any toolbar and, on the shortcut menu, clicking 
the toolbar that you want to display or hide.

■ You can lock toolbars in place using the same shortcut menu and clicking one of the Lock options 
at the bottom of the menu.

Try it: Resize and position the Draw toolbar

In this tutorial, you can practice moving, resizing, and docking the Draw toolbar. 

NOTE When you are instructed to “drag,” click and hold down the left mouse button, move the 
cursor, and then release the mouse button.

1 To make space, close any open palettes in the drawing area by clicking the [x] in their title bars.

2 On the left side of the application window, drag the move handle on the Draw toolbar to the 
center of the drawing area.

3 Move the cursor to the bottom of the Draw toolbar, where it changes into an up-down cursor.

4 Drag the bottom of the Draw toolbar to change its shape.

5 Click the [x] in the upper-right corner of the Draw toolbar to close it.

You can easily redisplay the Draw toolbar or any other toolbar.

move handle
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6 Right-click any toolbar to display a shortcut menu that contains a list of toolbars. On the 
shortcut menu, click Draw to redisplay the Draw toolbar.

7 Drag the title bar of the Draw toolbar to the left edge of the application window. When the 
toolbar outline changes shape, release the left mouse button to dock the toolbar.

NOTE If you move a toolbar past the edge of your screen, it may be hard to find, but a sliver of the 
toolbar will be visible and you can drag it back. If you drag the toolbar behind the Microsoft Windows 
taskbar at the bottom of your screen, you need to set the Windows taskbar properties to “Auto-hide” to 
retrieve the toolbar.

Start Commands on the Command Line

You can initiate AutoCAD commands by typing them on the command line within the command 
window instead of using toolbars or menus. Additionally, some commands must be completed on the 
command line, regardless of how they are started.

Some commands have abbreviated names or command aliases. For example, you can enter c as an 
alias for CIRCLE. See the Quick Reference card at the back of this guide for more information.

After you type the command on the command line, press ENTER or SPACEBAR to execute the 
command. You can also repeat the previous command by pressing ENTER or SPACEBAR.

NOTE In this guide and in the Help system, when you are instructed to enter something, type the bold-
face value on the command line, and then press the ENTER key.

Specify a Command Option

When you start a command, AutoCAD often displays a set of options on the command line. For 
example, when you enter the CIRCLE command, the following prompt is displayed on the 
command line: 

Specify center point for circle or [3P/2P/Ttr (tan tan radius)]:

The default option, “Specify center point for circle,” is displayed before the square brackets. Alternate 
options are displayed between the square brackets.

■ To accept the default option, enter coordinate values, or use the pointing device to click a center 
point in the drawing area. 

■ To choose a different option, enter the capitalized letters in the option name. For example, type 
2P and press ENTER to choose the Two-Point option.

command window

command line
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Use the Dynamic Prompt

In addition to the prompt on the command line, a similar prompt is displayed next to the cursor 
called the dynamic prompt.

With the dynamic prompt, you can keep your eyes on your work and you don’t have to look down 
to the command line.

To display command options in the dynamic input prompt, press the DOWN ARROW key, and then 
click an option on the menu.

Try it: Use a menu to draw a line

1 On the menu bar, click the Draw menu and then click Line.

In future steps, this is abbreviated Click Draw menu ➤ Line.

2 At the Specify First Point prompt, click anywhere in the drawing area to locate a point.

The prompt changes: Specify Next Point or [Undo]. 

3 At the Specify Next Point or [Undo] prompt, click anywhere else in the drawing area to specify the 
endpoint of the line segment.

4 Create a second line segment by clicking again to locate another point.

The Specify Next Point or [Undo] prompt is repeated so you can continue to draw segments until 
you end the LINE command.

5 Press ENTER to end the LINE command.

The two line segments that you just created share an endpoint, but are separate objects.

6 Click Modify menu ➤ Erase, and click each line. Then press ENTER to execute the erase 
command.
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Try it: Use a button on a toolbar to draw a line

1 On the Draw toolbar, which is located on the left edge of the application window, click the Line 
button.

2 Draw two line segments.

3 On the Modify toolbar, which is located on the right edge of the application window, click the 
Erase button.

4 Click each line and then press ENTER to erase the lines.

Try it: Use the command line to draw a line

1 On the command line, type line or the letter L. Press ENTER.

2 Click anywhere in the drawing area to locate a point.

3 At the Specify Next Point or [Undo] prompt, click anywhere else in the drawing area to specify 
the endpoint of the line segment.

4 At the Specify Next Point or [Undo] prompt, click anywhere else in the drawing area to specify 
the endpoint of the line segment.

5 Type u and press ENTER to undo the last line segment and click another location for the 
endpoint.

6 Then type c (Close) and press ENTER to add a third line segment that connects to the initial point 
and ends the command.

Try it: Use the command line to draw a circle

1 On the command line, enter circle or the letter c (type c and press ENTER).

2 At the Specify Center Point for Circle prompt, click anywhere in the drawing area to locate a 
point.

3 At the Specify Radius of Circle prompt, enter 5 (type 5 and press ENTER).

4 On the command line, press ENTER to repeat the CIRCLE command.

5 Enter 2P to create a circle using two points (type 2P and press ENTER).

6 Click anywhere in the drawing to locate each point.

7 Repeat the CIRCLE command several more times, using each of the other options.

8 When you’re done, enter erase or e, and click each circle to select it. Then press ENTER to erase 
the selected circles.
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Use the dynamic prompt to draw a circle

1 At the dynamic prompt, enter circle or the letter c.

2 At the Specify Center Point for Circle prompt, press the DOWN ARROW key.

3 Click one of the CIRCLE options on the menu and complete the command.

Undo or Redo Commands

Occasionally you will need to cancel a command in progress or undo some of your work. Two 
Standard toolbar buttons reverse mistakes in your drawings.

■ Undo. You can backtrack previous actions. For example, click Undo to delete an object that you 
just created.

■ Redo. You can reinstate the actions that you backtracked with Undo. For example, click Redo to 
re-create the object that you just undid. 

You can use the Undo and Redo lists to reverse more than one action at a time. Click the Undo or 
Redo list arrow and then click to select the actions.

Help system

OPTIONS, U, UNDO, REDO

To get started

Action Menu Keyboard

End a command Right-click ➤ Enter ENTER or SPACEBAR

Repeat a command Right-click ➤ Repeat ENTER or SPACEBAR

Cancel a command Right-click ➤ Cancel ESC

Undo the previous command Edit ➤ Undo <action> U

Redo listUndo list
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Review and Recall

1 What can you do to display a list of all available toolbars?

2 What are three ways that you can start a command?

3 What other key can you use to end or repeat a command in addition to ENTER?

4 What should you do to cancel a command?





It will be easier to create or modify objects in 
this drawing by zooming in to magnify the 
view.

After you finish working on an area, you can 
zoom out to get a better overall view.

Once you have zoomed in, you can pan the 
view to center the objects you are working on.
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Zoom to Magnify a View

A view is a specific magnification, position, and orientation of your design. The most common way 
to change a view is zooming. Zooming increases or decreases the magnification of the image 
displayed in the drawing area.

AutoCAD provides several methods for zooming in your drawings.

Zoom by Moving the Cursor

You can use a pointing device to zoom in real time—that is, to zoom in or out by moving the cursor. 
With the Realtime option of the ZOOM command, you drag the cursor up to zoom in; drag it down 
to zoom out. If you use a wheel mouse, rotate the top of the wheel forward to zoom in and rotate it 
backward to zoom out.

Zoom to a Specified Area

With the Window option of the ZOOM command, you can quickly zoom in on a specific area by 
using the mouse to define a rectangular zoom window. The area you define is centered in the new 
view.

Zoom to Display the Entire Drawing

Use the Extents option of the ZOOM command to display the entire drawing. This is useful when 
you need to return to an overall view quickly. This option is also useful if your drawing area is blank 
as a result of zooming in too close on a blank area or panning too far off the drawing area.

zoomed out zoomed in
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Pan to Reposition a View

Panning is another common way to change a view. Panning moves the position of the image 
displayed in any two-dimensional direction.

Pan by Moving the Cursor

You can pan in real time—that is, use the pointing device to reposition the image in the drawing 
area. Within the PAN command, drag the cursor to pan the image to a new location. If you use a 
wheel mouse, hold the wheel down and move the mouse to pan.

Tutorial: Zoom and Pan

In this tutorial, you can practice zooming and panning operations using the commands on the View 
menu or directly with a wheel mouse.

1 Click File menu ➤ Open.

2 In the Open dialog box, find the /Sample folder in the AutoCAD product folder. Click on each 
drawing file and open one that looks interesting.

3 Click View menu ➤ Zoom ➤ Window.

4 Click somewhere near the center of the drawing. Move your cursor to form a rectangular area 
and click again.

5 Click View menu ➤ Pan ➤ Realtime.

6 Drag the cursor in any direction to reposition the view. Press ESC to end the operation.

7 Continue to practice zooming and panning with these options:

■ Zoom Realtime (drag the cursor up and down, press ESC to end.)
■ Zoom Previous
■ Zoom Window
■ Zoom Extents
■ Pan Realtime

before PAN after PAN
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Practice these options until you are comfortable with zooming and panning. These are the most 
common options for drawing in 2D.

Note If you zoom in and you notice that arcs and circles lose their smoothness, or if you can’t zoom 
in or out beyond a limit, you can regenerate the display. Click View menu ➤ Regen All. This 
command also removes stray pixels.

8 (Optional) If you have a wheel mouse, you can zoom and pan without entering a command. Try 
the following operations:

■ Move your cursor to an area in the drawing and rotate the wheel forward and backward to 
zoom in and out. Notice that your cursor location determines the stationary reference point 
of your zoom operation.

■ Press the wheel down and drag the view to pan it.
■ Double-click the wheel to zoom to the extents of the drawing.

9 Close the sample drawing without saving it.

Help system

PAN, ZOOM, REGEN

Review and Recall

1 What ZOOM option should you use to fit your entire drawing into the drawing area?

2 What is a fast way to redisplay the previous view?

3 What command smooths the display of curves and removes stray pixels?

To get started

Action Menu Toolbar

Pan View ➤ Pan Standard 

Zoom View ➤ Zoom Standard 

Reset the display limit for zooming View ➤ Regen

Smooth arcs and circles View ➤ Regen
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Start a Drawing

AutoCAD offers several ways to start a new drawing. The recommended method is to start with a 
drawing template file.

A drawing template file contains predefined settings, standards, and definitions that will save you 
significant setup time. When you start a drawing with a drawing template, these settings are passed 
on to the new drawing. Drawing template files include settings and basic drawing elements that you 
will use often, such as

■ Unit type and precision
■ Tool settings and preferences
■ Layer organization
■ Title blocks, borders, and logos
■ Dimension styles
■ Text styles
■ Linetypes and lineweights
■ Plot styles

Your AutoCAD installation folder includes many drawing template files, including some that 
facilitate compliance with ANSI, DIN, ISO, and JIS standards. Nevertheless, it is very likely that you 
will customize one or more of these, or build your own drawing template files to meet your standards 
and requirements.

You can create a drawing template file by saving a drawing using the .dwt extension.

drawing template file saved 
with title block 
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Try it: Open a drawing template file

1 Click File menu ➤ New.

2 In the Select Template dialog box, click one of the following drawing template files and then 
click Open.

■ Tutorial-mArch.dwt. Sample architectural template (metric)
■ Tutorial-mMfg.dwt. Sample mechanical design template (metric)
■ Tutorial-iArch.dwt. Sample architectural template (imperial)
■ Tutorial-iMfg.dwt. Sample mechanical design template (imperial)

The metric template files are scaled to use millimeters as the drawing unit, and the imperial template 
files are scaled to use inches as the drawing unit.



52 | Chapter 4 Drawing Setup

Plan the Drawing Units and Scale

In AutoCAD, you don’t need to worry about setting a scale before you start drawing. Even though 
you eventually print or plot to paper at a specified scale, you create the model in AutoCAD at 1:1 
scale. However, before you start a drawing, you must first decide what drawing units you will use.

Choose the Drawing Units

In AutoCAD, distances are measured in drawing units. In a drawing, one drawing unit may equal 
one inch, one millimeter, one meter, or one mile. 

Before you begin drawing, you decide what one drawing unit will represent—there is no setting in 
AutoCAD that determines the length of a drawing unit.

Set the Format of Drawing Units

After you decide what drawing units to use, you can set the format of the drawing units. The format 
settings available for linear units are as follows:

■ Architectural. A length of 15.5 units displays as 1’-3 1/2”
■ Decimal. A length of 15.5 units displays as 15.5000
■ Engineering. A length of 15.5 units displays as 1’-3.5”
■ Fractional. A length of 15.5 units displays as 15 1/2
■ Scientific. A length of 15.5 units displays as 1.5000E+1

For example, if you are a mechanical engineer or architect who normally works in millimeters, you 
would set the format for linear units to decimal. If you are an architect who normally works in feet 
and inches, you would set the format to architectural.

Shaft
1 unit = 1 mm
(grid spacing = 2 mm)

Office plan
1 unit = 1 inch
(grid spacing = 12 inches)
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The drawing unit format controls only the display style of the drawing units on-screen, such as in 
the display of coordinates and values in the Properties palette, dialog boxes, and prompts. 

Try it: Check the drawing unit format and precision

1 Click Format menu ➤ Units. In the Drawing Units dialog box, notice the display style selected 
for linear and for angular units.

Note Think of this dialog box as the Drawing Units Format dialog box.

2 Notice the value displayed under Precision. This represents the decimal or fractional rounding 
of values displayed on-screen.

3 Close the dialog box.



54 | Chapter 4 Drawing Setup

Understand Models and Layouts

AutoCAD provides two parallel working environments represented by the Model and layout tabs. 
Working on the Model tab, you draw a full-size model of your subject. On the layout tabs, you can 
arrange multiple “snapshots” of the model.

■ The Model tab accesses a limitless drawing area. In model space, you first decide whether one 
unit represents one millimeter, one meter, one inch, or some other drawing unit. Next, you set 
the drawing unit format. Then you draw at 1:1 scale.

■ Layout tabs access drawing layouts. When you set up a layout, you specify the paper size you 
want to use. The layout represents a printed drawing sheet in which you can display one or more 
views of the model at various scales. This layout environment is called paper space. Here you create 
layout viewports that act as windows into model space. Each layout viewport can contain a 
different view of the model.

full-size model of a part 
created at 1:1 scale

layout with title block and rectangular 
layout viewports that contain scaled views

layout with viewports using different scales
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Try it: Switch between the Model and layout tabs

1 At the bottom-left of the display area, click the Model tab. This is where you create and modify 
the geometry for your model.

2 Click the layout tab to the right of the Model tab.

The layout has already been prepared, including a sample title block and a layout viewport, the 
blue rectangle.

3 On the layout tab, double-click anywhere within the rectangular viewport area. This is how you 
will later access model space to pan the model space view and to add dimensions.

Notice that the border of the layout viewport becomes thicker and the crosshairs cursor is active 
only within the layout viewport.

4 Double-click in a blank area outside the rectangular viewport. This returns you to paper space.

The border of the layout viewport is no longer as thick and the crosshairs cursor is active within 
the entire drawing area.
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Organize Drawings with Layers

Layers are the equivalent of the overlays used in manual drafting. They are an important 
organizational tool in AutoCAD. 

Each layer includes an assigned color, linetype, and lineweight. Before you create objects, you set 
the layer on which the objects are to be created. This is called the current layer. By default, AutoCAD 
assigns the current layer’s color, linetype, and lineweight automatically to the new objects you 
create.

Assign Layers

You can organize the drawing by assigning similar components to the same layer. For example, you 
can create a layer called Electrical and assign it the color green. Whenever you draw electrical 
objects, you switch to that layer. The objects you draw are created on the Electrical layer and are 
colored green.

Later, if you don’t want to view or plot electrical objects, you can turn off that layer.

NOTE It is very important to establish a company-wide layer standard. With a layer standard, drawing 
organization will be more logical, consistent, compatible, and maintainable over time. Layer standards 
are essential for team projects.

Try it: Display the list of layers in a drawing

1 Click Format menu ➤ Layer. 

2 In the Layer Properties Manager, notice the name and default properties assigned to each layer.

These layers are just a sample of the types of layers that you will need to use in a well-organized 
drawing. There are many layer standards already in use, including those specified in companies 
and those recommended by professional organizations.

3 Enlarge the right side of the dialog box to display all of the columns. Click the titles of the Status, 
Color, and Name columns to rearrange the order of the layers.

Review the descriptions of each layer in the column on the far right.

walls

furniture

all layers

electrical
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Control Layers

To make objects on a layer invisible, you can turn off the layer or freeze it in the Layer Properties 
Manager. You can also lock layers to reduce the possibility of modifying objects accidentally.

■ Turn off layers. Use this option rather than freezing if you frequently need to switch a layer’s 
visibility.

■ Freeze layers. Use this option if you don’t need a layer to be visible for a long time. Thawing a 
frozen layer causes an automatic regeneration of the drawing and is slower than turning a layer 
on.

■ Lock layers. Use this option to prevent objects on a layer from being modified. You can still use 
the objects on a locked layer for operations that don’t modify the objects. For example, you can 
snap to these objects to use them as guides for precision drawing.
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Tutorial: Tour a Drawing

In this tutorial, you tour a drawing of an arbor and picket fence design.

1 Click File menu ➤ Open.

2 In the Select File dialog box, find the /Help/Tutorials folder in the AutoCAD installation folder 
and open arbor.dwg.

3 Click the Model tab.

4 As you move the mouse over the objects in the drawing, notice that the objects are automatically 
highlighted.

5 Zoom and pan in model space to inspect the arbor design.

6 Perform a Zoom Extents to display the entire design.

7 Click the ANSI C Layout tab.

8 Zoom and pan in paper space to inspect the drawing layout.

9 Perform a Zoom Extents to display the entire layout.

10 Click Format menu ➤ Layer. In the Layer Properties Manager, review the list of layers that were 
created to organize this drawing.

Notice that the current layer has a green check next to it.

11 Click several lightbulb icons to turn off several layers.

12 Click the column labeled On to arrange the layers according to whether they are on or off. Then 
turn the layers back on.

13 Click the Color column to arrange the layers according to color.

14 Click the Name column and click OK.

15 Close the drawing without saving it.

To get started

Action Menu Toolbar

Start a new drawing File ➤ New Standard

Save a drawing template File ➤ Save As Standard

Set the display style of the units Format ➤ Units

Create a layout File ➤ Page Setup

Create and modify layers Format ➤ Layer Layers
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Help system

NEW, SAVEAS, STARTUP, UNITS, MODEL, LAYOUT, LAYER

Review and Recall

1 Why is it important to start a drawing from a drawing template file?

2 What is the difference between choosing drawing units and setting the drawing unit format?

3 What is the difference between the Model tab and a layout tab?

4 What are several benefits to creating a drawing with layers?
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Object Properties Overview

All objects created in AutoCAD have properties. Object properties are settings that control the 
appearance and geometric characteristics of an object. The general properties that are common to 
all objects are listed below. All other object properties are specific to the type of object.

Assign Object Properties

Typically, you assign object properties using one of the following strategies:

■ By layer. Properties are assigned to a layer. Objects that are drawn on that layer automatically use 
those properties.

■ Individual properties. Properties are assigned to objects individually, regardless of the layer that 
they are drawn on.

Color Linetype scale Hyperlink

Layer Plot style Lineweight

Linetype Thickness

View a description of the selected property.

Click the icon to expand or collapse a 
category of properties.

Click to change a property.

Right-click to set palette behavior options.
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Use the Properties Palette

The Properties palette is the primary tool for viewing, setting, and modifying the properties of 
objects. The Properties palette operates as follows:

■ If no objects are selected, the Properties palette displays the current default property settings, and 
you can set the default properties for all subsequently created objects.

■ When you click an object, the Properties palette displays the properties of that object, and you 
can change its properties.

■ If you click multiple objects, the Properties palette displays all the properties that they have in 
common, and you can change their common properties.

Try it: Display the Properties palette

1 Click File menu ➤ New.

2 In the Select Template dialog box, click one of the drawing template files and then click Open.

3 Click Modify menu ➤ Properties.

Leaving the palette open keeps it handy. You can turn on Auto-hide to make the Properties palette 
appear and disappear when your cursor moves over the Properties palette title bar.

Try it: Change the Auto-hide behavior of the Properties palette

1 Right-click the Properties palette title bar. Click Auto-hide on the shortcut menu.

2 Move the cursor on and off the Properties palette. Leave the Properties palette open.

Use the Properties and Layers Toolbars

You can use the controls in the Properties toolbar and the Layers toolbar to view, set, and modify 
the properties the same way as the Properties palette. By default, these toolbars are displayed above 
the drawing area.

The Properties toolbar provides convenient access to the most important object properties.

The Layers toolbar controls layer properties. Use the Layer Properties Manager button to make 
adjustments to drawing layers. The Layer control provides a quick method for changing several layer 
properties and for changing the current layer.

Color control Linetype control Lineweight
control

Plotstyle
control

Properties 
toolbar
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Tutorial: Change Object Properties

In this tutorial, you will use several controls to view and change the properties of layers and objects.

1 Click File menu ➤ Open.

2 In the Select File dialog box, find the /Help/Tutorials folder in the AutoCAD installation folder 
and open arbor.dwg.

3 Click the Model tab.

4 Move your cursor onto the title bar of the Properties palette. 

Examine the current default properties settings.

5 Click a dimension object in the drawing to select it.

Notice that several properties of this object are displayed in the Properties toolbar near the top 
of the application window. The layer of the object is Dimension. The color, linetype, and 
lineweight properties of the object are set to ByLayer. The color of the Dimension layer is red.

6 Move your cursor onto the title bar of the Properties palette to open it. 

Examine the additional properties of the dimension object in the Properties palette.

7 Click several more objects with different colors. Move your cursor onto the title bar of the 
Properties palette.

Notice that only the common properties of the objects are listed.

8 Move your cursor off the Properties palette and press ESC to cancel the selection.

Change the default color of a layer

1 Click Format menu ➤ Layer.

2 In the Layer Properties Manager, click the red box under the Color column of the Dimension 
layer.

3 In the select Color dialog box, click the green box and click OK. Click OK again to exit the Layer 
Properties Manager.

Notice that all the objects on the Dimension layer are now green. Because all of the dimensions 
are on a single layer, you can change the properties of all objects on that layer in one operation.

Change the color of an individual object

1 Click any green dimension object to select it.

2 On the Properties toolbar, click the Color control and click Magenta.

Layer 
control

Make the layer of the currently
selected object the current layer.

Layer Properties 
Manager

Make the previous layer
the current layer.Layers 

toolbar
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The color of the selected object changes to magenta, overriding the green color of the object’s 
layer. If you change the layer color, the dimension object’s color will remain magenta.

3 Press ESC to exit.

4 Click the same dimension object.

5 Click the Color control and click ByLayer. This restores the color property behavior of the 
dimension object.

Change the current layer

1 Click the Layer control on the Layers toolbar.

2 Click a different layer to make it the current layer.

All new objects will be created on this layer until you change the current layer to a different one.

3 Click Format menu ➤ Layer

4 In the Layer Properties Manager, click a layer to select it.

5 Click the green check mark button at the top of the Layer Properties Manager. Click OK to make 
the selected layer the current layer.

6 Click the Layer control on the Layers toolbar.

7 Click the lightbulb image for the Dimension layer to turn it off. Then click anywhere in the 
drawing area.

All objects on the Dimension layer are now hidden.

8 Use the Layer Properties Manager to turn the Dimension layer back on.

9 Close the drawing without saving it.

Use Linetypes

You can associate a single linetype with all of the AutoCAD objects drawn on the same layer or you 
can assign linetypes individually to objects. You can use any of the standard linetypes that AutoCAD 
provides, or you can create your own linetypes. 

Color control
Properties 
toolbar

Layer control

Layers
toolbar
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To use a linetype, you must first load it into your drawing using the Linetype Manager.

Try it: Load a linetype and make it current

1 Click File menu ➤ New and select a drawing template.

2 Click Format menu ➤ Linetype.

3 In the Linetype Manager, click Load.

4 In the Load or Reload Linetypes dialog box, scroll down the list of linetypes and click 
HIDDENX2. Click OK.

5 Click Show Details.

Several linetype scaling options are displayed. Notice the Use Paper Space Units for Scaling 
option. You check this option if you want linetypes automatically scaled in layout viewports.

6 Click the HIDDENX2 linetype and click Current. Click OK.

Notice that the Properties toolbar near the top of the application window displays the 
HIDDENX2 linetype as current rather than BYLAYER. All subsequently created objects will be 
displayed using this linetype. This setting overrides the linetype assigned to the current layer.

7 Click the Model tab.

CONTINUOUS

HIDDEN

CENTER
PHANTOM
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8 Click Draw menu ➤ Line and click several locations in the drawing area to draw line segments. 
Press ENTER to end the command.

9 Use the Linetype Manager or the Properties toolbar to return the current linetype to BYLAYER.

All subsequently created objects will be displayed using the linetype assigned to the current layer.

Scale Linetypes

When you scale views in layout viewports, you can create inconsistencies in the appearance of 
linetypes. In noncontinuous linetypes, the length of dashes and dots, and the space between them, 
may increase or decrease. You can set the scaling to correspond to the model or layout scale or to 
remain the same at any zoom scale.

Use the Details area of the Linetype Manager to control the linetype scale in layout viewports.

■ Global Scale Factor. Sets the global scale factor for all linetypes.
■ Current Object Scale. Sets the linetype scale for newly created objects.
■ Use Paper Space Units for Scaling. Scales the linetypes in paper space and model space identically.

To update a linetype scale, you need to regenerate the model space display within a layout viewport 
on the layout tab. The steps required are

1 Click a layout tab.

2 Double-click within a layout viewport to enter model space.

3 Click View menu ➤ Regen.

The linetypes within the layout viewport are scaled according to the viewport display scale setting.

Dashed linetype 
scaled to the model

Dashed linetype 
scaled to the layout
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Assign Lineweights

Using lineweights, you can create heavy and thin lines to show cuts in sections, depth in elevations, 
dimension lines and tick marks, and differences in details. Lineweights are independent of the 
current display scale. Objects with a heavier lineweight always appear at the specified line width 
regardless of display scale.

Try it: Choose a lineweight and make it current

1 Click the Model tab.

2 Click Format menu ➤ Lineweight.

3 In the Lineweight Settings dialog box, under Lineweights, click a heavier lineweight such as 0.50 
mm or 0.020”.

4 Click Display Lineweight and click OK.

Notice that the Properties toolbar near the top of the application window displays the new 
lineweight as current. From now on, objects that are created will be displayed using the heavier 
lineweight.

5 Click Draw menu ➤ Line and draw several line segments. Press ENTER.

6 Use the Lineweight Settings dialog box or the Properties toolbar to return the current linetype to 
BYLAYER.

From now on, objects that are created will be displayed using the lineweight assigned to the 
current layer.

7 Practice setting linetypes and lineweights.

NOTE You can assign a color, linetype, or lineweight to individual objects, regardless of the default 
layer setting. Whether you choose to assign these properties individually or by layer settings depends on 
your drawing organization and company standards.
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Draw Lines

The line is the most basic object in AutoCAD. A line can be one segment or a series of successive 
segments, but each segment is a separate line object. If you need to draw a series of line segments as 
a single object, such as in a contour map, use a polyline.

Create Parallel Lines

An offset line is an exact replica of a line that is drawn at a specified distance from the original line. 
You can use the OFFSET command to create parallel lines as well as concentric circles and parallel 
curves.

Offsetting objects is one of the most efficient construction methods used in AutoCAD.

Try it: Offset a line to create parallel lines

1 Draw a line.

2 Click Modify menu ➤ Offset.

3 At the offset distance prompt, enter 10.

4 Click the line to offset.

5 Click on one side of the line.

6 Press ENTER to end the command.

Draw Polylines and Polygons

A polyline is a connected sequence of line or arc segments created as a single object. Use polylines for 
creating objects such as

■ Traces on printed circuit boards
■ Borders
■ Contour lines, roads, and rivers in maps
■ Segments with fixed or tapered widths

Polygons are closed polylines with equal-length sides and angles. The Polygon command is the 
simplest method for creating equilateral triangles, squares, pentagons, hexagons, and so on.

offset arcs
offset lines
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Draw Polylines

To draw each polyline segment, you specify a start point and an endpoint. To draw additional 
segments, continue to specify points in your drawing.

Try it: Create a polyline

1 Click Draw menu ➤ Polyline.

2 At each prompt, click a point. After several points, do one of the following:

■ Press ENTER to end the command.
■ Enter c to create a closed loop.

3 Click the polyline. Notice that the segments all belong to a single object.

You can include arc segments in polylines.

Try it: Create a polyline with arc segments

1 Click Draw menu ➤ Polyline.

2 Draw a polyline segment (1 and 2).

3 At the next prompt, enter a to switch to Arc mode and continue with an arc segment (3).

4 Enter L to return to Line mode, and then draw another line segment.

5 End the command.

Try it: Create a rectangle

1 Click Draw menu ➤ Rectangle.

2 Click a location on the screen.

3 Move the cursor diagonally and click another location.

The resulting object is a closed polyline in the shape of a rectangle.

Endpoint of arc Final segment

3

2

1
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Try it: Create a polygon

1 Click Draw menu ➤ Polygon.

2 Enter the number of sides, for example, 6.

3 Click a location for the center of the polygon.

4 Specify either the Inscribed or the Circumscribed option. This determines how the distance that 
you enter in the next prompt is measured.

5 To specify a “radius” of the polygon, do one of the following:

■ Move the cursor and click a location.
■ Enter a distance.

The resulting object is also a closed polyline.

You can draw polylines of various widths by using the Width and Halfwidth options after you 
specify a starting point for a polyline. You can also make polyline segments taper. 

Once you create a polyline, you can

■ Separate the polyline into independent segments with the EXPLODE command.
■ Join a polyine to another polyline, line or arc with the JOIN command.

inscribed radius circumscribed radius

Mixed widthUniform width Tapered segment
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Draw Circles and Arcs

You can create a variety of basic curved objects with AutoCAD, including circles and arcs. 

Draw Circles

To create circles, use one of the following methods:

■ Specify the center and radius (default method).
■ Specify the center and diameter.
■ Define the circumference of the circle with two or three points.
■ Create the circle tangent to two existing objects. 
■ Create the circle tangent to two objects and specify a radius.

Draw Arcs

To create arcs, you can specify various combinations of center, endpoint, start point, radius, angle, 
chord length, and direction values. The following examples illustrate three ways to specify two 
points and an included angle.

radius

11

3

2

center

2

radius

tangent objects

Center, radius Two points 
defining diameter

Three points defining 
circumference

Tangent, tangent, 
radius

Start, center, angle

12

Center, start, angle

1

2

Start, end, angle

1

2

included angle
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NOTE The FILLET command creates an arc tangent to two existing objects. This is often the preferred 
method for creating arcs and will be covered later.

Help system

PROPERTIES, COLOR, LAYER, LINETYPE, LTSCALE, CELTSCALE, PSLTSCALE, LINEWEIGHT, LINE, OFFSET, 
PLINE, POLYGON, RECTANG, PEDIT, JOIN, EXPLODE, CIRCLE, ARC

Review and Recall

1 What is the result of setting the color of an object to ByLayer?

2 What is the fastest way to change the current layer to a different one?

3 What would you do to access a complete list of the properties of an object?

4 What command is recommended for creating parallel lines and curves?

5 What type of object is composed of a series of connected segments?

To get started

Action Menu Toolbar

Set properties Tools ➤ Properties
Modify ➤ Properties

Standard

Load, scale, and 
manage linetypes

Format ➤ Linetype Properties

Change lineweight 
settings

Format ➤ Lineweight Properties

Draw lines Draw ➤ Line Draw 

Draw parallel lines Modify ➤ Offset Modify 

Draw polylines Draw ➤ Polyline Draw

Draw polygons Draw ➤ Polygon Draw

Separate polyline 
segments

Modify ➤ Explode Modify

Join polylines Modify ➤ Join Modify

Draw circles Draw ➤ Circle Draw 

Draw arcs Draw ➤ Arc Draw 
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locate points precisely

Turn on polar tracking to draw 
along specified angles

Turn on Ortho to draw 
horizontal and vertical 
lines

Turn on Grid and Snap to 
draw within a predefined 
framework

Use object snaps 
to locate precise 
points on objects



Precision Drawing

Set Grid and Snap Values  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .76
Set Grid and Snap Spacing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
Set Grid Limits . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

Draw with Coordinates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .78
Use Cartesian and Polar Coordinates. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78
Draw with Absolute Cartesian Coordinates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78
Draw with Relative Cartesian Coordinates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Snap to Precise Points on Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .80
Use Single Object Snaps. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80
Set Running Object Snaps . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Object Snap Descriptions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .82
Specify Angles and Distances  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .83

Use Polar Tracking. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
Specify Distances . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
Specify an Angle . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84
Tutorial: Draw with Precision . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84



76 | Chapter 6 Precision Drawing

Set Grid and Snap Values

The grid and snap features set up a framework that you can use as a guide while drawing.

■ Grid displays a rectangular pattern of dots that extends over the area specified by the drawing grid 
limits. The grid helps you align objects and visualize the distances between them. The grid does 
not appear in the plotted drawing.

■ Snap restricts the movement of the crosshairs to intervals that you have defined. When Snap is 
on, the cursor seems to adhere, or “snap,” to an invisible grid. Snap is useful for specifying precise 
points with the cursor.

Set Grid and Snap Spacing

The grid does not necessarily correspond to the current snap interval. You might set a wide grid 
spacing to be used as a reference but maintain a closer snap spacing for accuracy in specifying points. 
For example, you might set the grid spacing to 10 times the snap spacing in a metric drawing or 12 
times the snap spacing in an imperial drawing.

Try it: Constrain the cursor with Snap

1 Start a new drawing.

2 Click the Snap button on the status bar.

Notice that the button changes to indicate that Snap has been turned on.

3 Move the pointer around in the drawing area while Snap is turned on.

Notice that the cursor seems to adhere, or “snap,” to points at equal intervals in the drawing area.

Try it: Display a grid

1 Click the Grid button on the status bar.

Notice that the grid dots cover a limited area, the grid limits.

2 Turn Grid and Snap off.

If you zoom in or out, you might need to adjust grid spacing to be more appropriate for the new 
magnification.
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Try it: Change the Grid and Snap spacing

1 Right-click either the Grid or Snap button on the status bar.

2 Click Settings on the shortcut menu.

3 In the Drafting Settings dialog box, specify new spacings for Grid and Snap. Click OK.

4 Turn on Grid and Snap.

Set Grid Limits

Try it: Change the grid limits

1 Click Format menu ➤ Drawing Limits.

2 Click two points to represent the lower-left and the upper-right corners of a rectangular area.

3 Repeat using two different points.

Grid limits shown by 
range of grid dots
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Draw with Coordinates

Coordinates represent locations in your drawing. When a command prompts you for a point, you 
can use the cursor to specify a point in the drawing area or you can enter coordinate values.

Use Cartesian and Polar Coordinates

In two-dimensional space, you specify points on a plane that is similar to a flat sheet of grid paper. 
You can enter two-dimensional coordinates as either Cartesian (X,Y) or polar (distance<angle) 
coordinates. 

■ Cartesian coordinates are measured from two perpendicular lines, the X axis and the Y axis. The 
X value specifies horizontal distance, and the Y value specifies vertical distance. For example, the 
coordinates 5,3 represent a point 5 units along the X axis and 3 units along the Y axis. The origin 
(0,0) indicates where the two axes intersect.

■ Polar coordinates use a distance and an angle to locate a point. For example, the coordinates 
5<30 specifies a point that is a distance of 5 units from the origin and at a 30 degree angle from 
the X axis.

You can use absolute or relative values with each method. Absolute coordinate values are based on 
the origin. Relative coordinate values are based on the last point entered.

Draw with Absolute Cartesian Coordinates

Use absolute Cartesian coordinates when you know the precise X and Y values of the location of the 
point. For example, the line in the illustration begins at an X value of –2 and a Y value of 1 and ends 
at 3,4. The entries on the command line were as follows:

Command: line
Specify first point: #–2,1
Specify next point or [Undo]: #3,4

Y

X–X

-Y 0,0-2,1

3,4
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Entering the # identifies the coordinates as absolute coordinates.

Draw with Relative Cartesian Coordinates

Use relative Cartesian coordinates when you know the location of a point in relation to the previous 
point. For example, to locate a point relative to the absolute coordinates –2,1, start the next 
coordinates with the @ symbol.

Command: line
Specify first point: #–2,1
Specify next point or [Undo]: @5,3

Entering @5,3 locates the same point in this example as entering #3,4 in the previous example.

NOTE Absolute coordinates are entered differently if dynamic input (the DYN button on the status bar) 
is turned off. In that case, the # is not used to specify absolute coordinates.
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Snap to Precise Points on Objects

Using object snaps is the most important way to specify an exact location on an object without 
having to use coordinates. For example, you can use an object snap to draw a line to the exact center 
of a circle, to the endpoint of another line segment, or to the tangent on an arc. 

You can specify an object snap whenever AutoCAD prompts for a point. When you move your 
cursor over an object, AutoCAD identifies an active object snap point with AutoSnap markers and 
tooltips.

Use Single Object Snaps

When AutoCAD prompts you for a point, you can specify a single object snap by holding down 
SHIFT, right-clicking, and choosing an object snap from the Object Snap menu. 

Once you have specified an object snap, use the cursor to select a location on an object.

NOTE To cycle through all the object snap points available for a particular object, press TAB.

Press SHIFT and right-click to 
display the object snap menu

object snaps
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Set Running Object Snaps

To use the same object snap repeatedly, set it as a running object snap. It will stay active until you 
turn it off. For example, you might set Center as a running snap if you need to connect the centers 
of a series of circles with a line.

You can set multiple running object snaps, such as Endpoint and Center.

Try it: Change the running object snap settings

1 Right-click Osnap on the status bar.

2 On the shortcut menu, click Settings.

3 On the Drafting Settings dialog box, select the object snaps you want to use. Click OK.
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Object Snap Descriptions

The following table illustrates commonly used object snaps.

Object snap Snaps to

Endpoint Object endpoints

Midpoint Object midpoints

Intersection
Object intersections or, for single object snaps, 
locations where intersections would occur if 
objects were extended

Center

Center points of circles, arcs, or ellipses

Quadrant

Quadrants of arcs, circles, or ellipses

Perpendicular

Points on objects that form a perpendicular 
alignment with the last point specified

Tangent

Point on a circle or arc that, when connected to 
the last point, forms a line tangent to the object
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Specify Angles and Distances

You can quickly specify angles and distances using the polar tracking, direct-distance entry, and 
angle override features.

Use Polar Tracking

As you draw lines or move objects, you can use polar tracking to restrict the movement of the cursor 
to specified angle increments (the default value is 90 degrees). For example, you can create a series 
of perpendicular lines by turning on Polar before you start drawing. Because the lines are constrained 
to the horizontal and vertical axes, you can draw faster, knowing that the lines are perpendicular.

Try it: Use polar tracking

1 Click Polar on the status bar to turn it on.

2 Draw several lines at 90 degrees from each other.

Specify Distances

Use direct distance entry to specify an exact line length quickly—by moving the cursor to indicate a 
direction and then entering the distance from the first point. When polar tracking is on, using direct 
distance entry helps you draw perpendicular lines of a specified length efficiently. 

Polar tracking restricts cursor 
movement to specified angles

alignment path

tooltip display of distance and angle

Polar: 1.5<45

Polar tracking constrains the cursor 
to an angle, in this case 180 degrees...

then direct distance entry determines 
the exact length of the line, in this 
case, 1000
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Try it: Draw several lines of specified lengths

1 Click Draw menu ➤ Line.

2 Click a point and then move the cursor to the right (0 degrees).

3 Enter a value.

4 Move the cursor up (90 degrees) and enter another value.

5 Repeat several more times and then press ENTER.

Specify an Angle

If the angle that you want to use is not going to be used frequently, you can enter an angle override. 
For example, if you start drawing a line at the coordinates –2,1, and want that line to be at a 10 
degree angle with a length of 50, you would enter

Command: line
Specify first point: #–2,1
Specify next point or [Undo]: <10
(Move the cursor in the desired direction)
Specify next point or [Undo]: 50

Tutorial: Draw with Precision

In this tutorial, you will practice using some of the precision tools available in AutoCAD to create 
the following drawing, which can be the beginning of a design for

■ A health spa with exercise pool
■ A catch for a window lock
■ A housing for a motor assembly

NOTE It is important that you save this drawing as you work. It will be used in several future tutorials 
in this guide.
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1 Click File menu ➤ New.

2 Select the tutorial drawing template file that is closest to your intended application and units of 
measurement:

■ Tutorial-mArch.dwt. Sample architectural template (metric)
■ Tutorial-mMfg.dwt. Sample mechanical design template (metric)
■ Tutorial-iArch.dwt. Sample architectural template (imperial)
■ Tutorial-iMfg.dwt. Sample mechanical design template (imperial)

3 Click the Model tab.

4 Click File menu ➤ Save. Use MyDesign as the file name.

Use Grid and Snap to create an outline

1 On the status bar, turn on Grid and Snap. Dynamic Input (Dyn) should also be turned on.

2 Click Draw menu ➤ Line and click several locations to create a series of line segments to create 
the previously illustrated design. The exact dimensions don’t matter, but use reasonable 
distances for the design. Press ENTER to end the command.

3 Click Draw menu ➤ Circle ➤ Center, Radius.

4 Click a point to locate the center of the circle, and then click another point to specify its radius.

5 Turn Grid and Snap off.

Create a line using object snaps

1 Click Modify menu ➤ Erase.

The crosshairs cursor changes into a square pickbox cursor.

2 Click directly on one of the lines that you created and then press ENTER.

The line is erased, but how do you create another line to take its place with precision?

3 Click Draw menu ➤ Line.

4 Press SHIFT and right-click. From the object snap menu, click Endpoint.

5 Move the cursor over an endpoint of a line. When you see an AutoSnap marker, click.

6 Press SHIFT and right-click again. From the object snap menu, click Endpoint.

7 Move the cursor over the opposite endpoint and click. Press ENTER to end the command.

The endpoints of the new line are located exactly at the endpoints of the adjacent lines.
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8 Do the following:

■ Experiment with creating lines using the following object snaps: Midpoint, Center, 
Perpendicular, and Tangent.

■ Turn running object snaps on and create several more lines.
■ Create a line from the center of the circle at a 30 degree angle and 10 units long.

9 Erase any objects that are not part of the illustrated result.

10 Save the drawing. MyDesign should be the file name.

Help system

GRID, SNAP, DSETTINGS, LIMITS, UCS, DYNMODE, OSNAP, OPTIONS

Review and Recall

1 How do you turn off the grid dots in your drawing area?

2 The term origin refers to what coordinate values?

3 Pressing SHIFT while you right-click displays what shortcut menu?

4 What button can you turn on to ensure that the line you are drawing is exactly vertical?

5 What is meant by the term direct distance entry?

To get started

Action Menu Toolbar

Set Snap and Grid spacing Tools ➤ Drafting Settings, 
Snap and Grid tab

Use single object snaps SHIFT+right-click for the
object snap menu

Object Snap

Set running object snaps Tools ➤ Drafting Settings, 
Object Snap tab

Object Snap

Change AutoSnap settings Tools ➤ Options, Drafting 
tab

Change polar settings Tools ➤ Drafting Settings Polar Tracking





Use COPY to create duplicates 
at locations that you specify

Use MIRROR to create an exact replica 
of objects across a mirror line

Use DIST to measure the distance 
between two points

Use FILLET to connect 
two lines with an arc

Use OFFSET to create parallel 
lines and concentric circles

Use TRIM to remove the parts of 
objects that extend beyond cutting 
edges that you specify
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Select Objects to Edit

When you edit objects, you select one or more objects to specify a selection set of the objects. You 
can use two methods to specify which objects to modify:

■ Choose the command first. Choose an editing command and then select objects to modify.
■ Choose the objects first. Select objects and then start the editing command. In addition, when 

you use this method, grips are displayed on the objects that you can use to modify the objects 
directly. You can clear a selection by pressing ESC.

Object Selection Methods

The two most common methods to select objects are

■ Select individual objects. Click objects individually.
■ Specify a selection area. Click a rectangular area around the objects to be selected.

Specify a Selection Area

You can select objects by enclosing them in a rectangular selection area. You define a rectangular 
selection area in the drawing area by clicking opposite corners. The order in which you specify the 
corners makes a difference. 

■ Drag from left to right to create a window selection, which selects only objects entirely within the 
selection area. 

■ Drag from right to left to create a crossing selection, which selects objects within and crossing the 
selection area.

NOTE You can remove objects from the selection set by pressing SHIFT and then clicking them.

Objects selected using window selection 

1

2
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Erase, Extend, and Trim Objects

These methods delete objects or change their lengths:

■ Erase deletes the entire object.
■ Extend lengthens an object to a precise boundary.
■ Trim shortens an object to a precise boundary and removes the excess.

Erase Objects

You can use all the object selection methods with the ERASE command. The example shows how 
you use window selection to erase a section of piping. 

Try it: Practice using window and crossing selection

1 Start a new drawing.

2 Create some lines, arcs, and circles.

3 Click Modify menu ➤ Erase.

4 Select several objects using a crossing selection and press ENTER.

Notice which objects are selected and erased.

5 Select several more objects using a window selection and press ENTER.

Again, notice which objects are selected and erased.

6 Select the other objects that you created in step 1 individually and press ENTER to erase them.

1

2

ResultSelected objectsObjects selected with 
window selection 
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Extend Objects

You can extend objects so that they end precisely at a boundary defined by other objects. If you press 
ENTER instead of selecting boundary objects, all visible objects in the drawing become potential 
boundaries. The illustration shows lines extended precisely to the circle, which is the nearest 
boundary.

Try it: Extend an object

1 Create a short line. Then create circle that encompasses the line.

2 Click Modify menu ➤ Extend.

3 At the Select Objects prompt, click the circle.

Notice that you select the boundary objects first.

4 Press ENTER to end boundary selection.

This step is easy to forget. 

5 At the next Select Objects prompt, click one end of the line and then the other end of the line. 
Press ENTER to end the command.

Trim Objects

Trimming objects is very similar to extending them. To trim, you cut an object at an edge defined 
by one or more objects. By default, objects defined as cutting edges must intersect the object to be 
trimmed.

Select objects to extend nearest 
to the end to be extended

Press ENTER to accept 
all objects as boundaries

Result

Cutting edges selected 
with a crossing selection 

Object to trim selected Result

1

2

3
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Try it: Trim an object

1 Create two horizontal lines and two vertical lines as shown on the left side of the previous 
illustration.

You can use the Perpendicular object snap to make sure that the two horizontal lines intersect 
the vertical line.

2 Click Modify menu ➤ Trim.

3 At the Select Objects prompt, click points 1 and 2 as previously illustrated.

Notice that you select the boundary objects first.

4 Press ENTER to end boundary selection.

5 At the next Select Objects prompt, click the vertical line at point 3 as shown. Press ENTER to end 
the command.

NOTE With both EXTEND and TRIM, you must accept the selection set of boundary objects by pressing 
ENTER, and then select the objects to be trimmed. If you press ENTER without selecting any boundary 
objects, all objects become potential boundaries.
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Duplicate Objects

There are several ways to make copies of objects: 

■ Copy creates new objects at a specified location.
■ Offset creates new objects at a specified distance from selected objects or through a specified 

point.
■ Mirror creates a mirror image of objects around a specified mirror line.

Copy Objects

To copy an object, you select one or more objects to copy, specify a start point, called a base point, 
and then specify a second point to determine the distance and direction of the copy. The two points 
can be anywhere within the drawing. For example, in the following illustration, the circle is copied 
from one rectangle to a corresponding location on the second rectangle.

Try it: Copy an object

1 Create two rectangles and a circle as shown on the left side of the previous illustration.

2 Click Modify menu ➤ Copy.

3 At the Select Objects prompt, click the circle and press ENTER.

4 At the Specify Base Point prompt, press SHIFT and right-click to display the object snap menu. 
Click Endpoint.

5 Click the corner of the rectangle at point 2 as shown.

Result1 Select the circle

2 Specify a base point (endpoint object snap)

3 Specify second point (endpoint object snap)
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6 At the Specify Second Point prompt, press SHIFT and right-click to display the object snap menu. 
Click Endpoint.

7 Click the corner of the other rectangle at point 3 as shown.

8 Press ENTER to end the command.

The copied circle is at the same location relative to its enclosing rectangle as the original circle.

You can also copy objects specifying a base point followed by direct distance entry, typically with 
polar snap turned on.

The Copy command automatically repeats so you can easily create multiple copies.

Offset Objects

Offsetting creates a new object that seems to trace a selected object at a specified distance. Offsetting 
circles creates larger or smaller circles depending on the offset side. For an easy way to create parallel 
lines or concentric circles, use offsetting.

Objects selected Base point specified and 
a distance entered

Result

enter a distance

Object selected (bush) Result

base point

next point

next point
next point

second point
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NOTE Offsetting several objects followed by trimming or extending them is a very efficient drawing 
technique.

Mirror Objects

You mirror objects around a mirror line, which you define with two points. You then choose to 
delete or retain the original objects.

Mirroring is useful for creating symmetrical objects. You can draw half the object and quickly mirror 
it rather than draw the whole object.

object offset

original object

1

2 3

mirror 
line

Objects selected Mirror line defined Result with original retained

4
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Move and Rotate Objects

An important drawing technique is to create one or more objects and then move or rotate them into 
place.

Move Objects

You move objects the same way that you copy them. You select the object to move, specify the base 
point (1), and then specify a second point to determine the distance and direction of the move (2). 
In the illustration, these steps move the window higher and away from the door. 

Rotate Objects

You rotate objects by specifying a base point and a rotation angle. You can specify the rotation angle 
by specifying a point or entering a value for the angle.

In the following example, you specify the base point (1) and a second point (2) that determines the 
angle of rotation (2) for the orientation of a house.

Instead of specifying the second point in the example, you could have entered -35 to specify the 
rotation in degrees. Repeating the rotation with the same base point and angle would result in the 
house being rotated a total of 70 degrees from its original orientation.

NOTE By default, a positive angle results in a counter-clockwise rotation. However, this setting can be 
changed using the UNITS command.

1 2

Select objects, specify base point and 
new location of the selected objects.

Objects selected Result

1

Base point and 
angle of rotation

2
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Fillet Corners

Filleting connects two objects with an arc of a specified radius that is tangent to the objects. 

Use the Radius option of the Fillet command to specify arc radius of the fillet. Changing the radius 
sets the default radius for subsequent fillets. By default, the filleted objects are trimmed as shown in 
the illustration.

One useful technique is to set the fillet radius to 0. This results in two objects intersecting in a sharp 
corner as illustrated. No arc is created.

NOTE You can hold down SHIFT while selecting the objects to override the current fillet radius with a 
value of 0.

You can also fillet circles, arcs, and polylines. Depending on the points you specify, more than one 
possible fillet can exist between circles and arcs. AutoCAD chooses the endpoint closest to your 
selection point.

Tutorial: Modify Objects with Precision

In the following tutorial, you will use precision drawing techniques to modify part of an assessor’s 
map.

The adjoining property owners of an empty city lot persuaded their city council to allow them to 
acquire the lot. The only requirement was that the property owners agree on an equitable division.

Objects selected Result

Radius set to 0, 
objects selected 

Result
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How would you divide the empty lot?

The proposal accepted by the property owners expanded lots 26 and 27 to make their total lot sizes 
equal. The fence between lots 38 and 39 was extended. Lot 38 was larger than the others, but this 
benefit was offset by its irregular shape.

empty lot
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Use the following procedure to change the boundaries of the lots.

1 Click File menu ➤ Open.

2 In the Select File dialog box, find the /Help/Tutorials folder in the AutoCAD product folder and 
open map.dwg.

3 To simplify the display, turn off the Text layer.

You first create a new property line on the left side of the triangular lot. The top end of the new 
property line will be displaced 15.73 feet; and the bottom end of the new property will be 
displaced by 39.94 feet. These distances were determined using trial-and-error to make lots 26 
and 27 about equal in area, but without making lot 38 too narrow or too large.

To accomplish this task, you create some “construction geometry” that makes the task easier.

4 Use the Circle command and object snaps to create a circle with a radius of 15.73 and a circle 
with a radius of 39.94 centered on the intersections as shown in the illustration.

5 Use intersection object snaps to create a new property line as shown in the illustration.
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6 Erase the old property line and the two construction circles.

Next, extend the old property line to the new one.

7 Click Modify menu ➤ Extend.

8 Click the new property line. This line is the boundary for extending the old property line.
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9 Press ENTER. This action is important and easily forgotten. It separates the objects that serve as 
boundaries from the objects to be extended.

10 Click the old property line near the end to be extended as shown. 

11 Press ENTER to end the command.

12 Use the same method to extend the other property line to the lower border. 
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13 Erase the old property lines to open the long, narrow lot.

14 Draw a short property line using the endpoint object snap between the end points of the 
property lines as shown.
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The new property lines are complete. But how can you find the new areas of the lots?

Find the areas of the lots

1 On the command line, enter boundary.

2 In the Boundary Creation dialog box, click Pick Points. Then click inside each of the lots. Press 
ENTER to end the command.

A closed polyline object is created using the property lines for each lot. These closed polylines 
are superimposed upon the existing property lines and can later be erased.

Note As you move your cursor over the map, different polylines highlight. Where the polylines share 
a common boundary, only one of them is highlighted. To avoid these common boundaries, move 
your cursor around the outer edges of the map. Alternatively, you can press CTRL and click a shared 
boundary repeatedly to cycle through all objects at that location.

3 Click Modify menu ➤ Properties.

4 Click one of the boundaries and find the area listed in the Properties palette.

5 Press ESC to clear the selection.

6 Find the area of each of the other lots.

7 Close the map drawing without saving it.

Tutorial: Create a New Drawing with Precision

In the following tutorial, you will create a detail drawing of a type of jet engine mount used to attach 
jet engines to commercial aircraft. You will be happy to know that this part is made of a high-
strength, nickel-chromium-iron alloy.

NOTE Each step in this tutorial is not specified in detail. When in doubt, feel free to review earlier 
portions in this guide or use the Help system. You can access all the commands in this tutorial using the 
Draw and Modify menus.
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1 Start a new drawing using the drawing template file, Tutorial-mMfg.dwt.

This template is for mechanical design drawings using metric units. All distances are assumed to 
be in millimeters.

2 Click the Model tab.

3 Make sure that the Polar and Osnap buttons on the status bar are turned on. The current layer 
should be Model-Front.

Create the front view

1 Create a circle with a diameter (not radius) of 50 mm at the coordinates 180,100.

Note The precise location of this circle is not critical in this tutorial, but it’s a good idea to make sure 
that several significant features coincide with snap locations. For single-view drawings or 3D models, 
it’s a good idea to have a significant feature located at the origin (0,0). This is convenient when 
referencing a drawing from another drawing such as with assembly drawings.

2 Use the Center object snap to draw a circle with a diameter of 24 using the center point of the 
previous circle.

The Center object snap may not be a default running object snap. Press SHIFT and right-click to 
access the object snap menu.

3 Using PolarSnap to lock the angle at 0 degrees, copy the two circles to a location 125 mm to the 
right.

Command: copy
Select objects: Select the two circles and press ENTER
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Specify base point or [Displacement]: Click the center of the circles and move your cursor to the right

Specify second point or <use first point as displacement>: 125

Specify second point or [Exit/Undo]: Press ENTER

4 Offset the inner circle on left by 4 mm to the outside.

Command: offset
Specify offset distance or [Through/Erase/Layer]: 4

Select object to offset or [Exit/Undo]: Select the left inner circle

Specify point on side to offset or [Exit/Multiple/Undo]: Click anywhere outside the circles

5 Create a circle using the tangent-tangent-radius (Ttr) option. The radius should be 250 mm. 
Notice that the AutoSnap marker for tangent is turned on automatically.

Command: circle
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: t
Specify point on object for first tangent of circle: Select an outer circle near the expected tangent location
Specify point on object for second tangent of circle: Select the other outer circle as shown
Specify radius of circle: 250 (only part of the circle is shown in the illustration)

6 Trim the large circle as shown below.
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7 Use the Mirror command to mirror the arc using the center points of the left and right circles to 
define the mirror line. Again, use SHIFT and right-click to access the object snap menu.

There are often alternative methods for each step. For example, to create the lower arc, you could 
have used the Fillet command to fillet the two outer circles with a radius of 250 mm.

8 Trim the outer-left circle as shown.

The front view of the part is complete. Next, you will use the objects in the front view to create the 
top view of the part.

Create the top view

1 Set the current layer to Model-Top. You can use the Layer control on the Layers toolbar, or the 
Layer Properties Manager.

2 Use the Quadrant object snap to create a line starting from the left side of the part. With polar 
snap on, move the cursor upward and enter 100 to make the line 100 mm long. Create another 
100 mm line on the right side of the part.
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3 Use the Endpoint object snap to create a line connecting the upper ends of the vertical lines.

4 Offset the horizontal line downward by 12 mm.

5 Trim the lower ends of the vertical lines to create the rectangular outline of the top view.

6 Offset the topmost horizontal line upward by 3 mm. Create vertical lines from the quadrants of 
the other circles as shown.

7 Trim the four vertical lines representing the silhouette edges of the holes as shown. Don’t forget 
to press ENTER after selecting the horizontal boundary line for the trimming.
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8 Trim the other vertical lines as shown. Zoom and pan as needed.

9 Trim the topmost horizontal line as shown. 

10 Create a vertical line that starts from the endpoint of the arc and ends perpendicular to the 
horizontal line as shown. This line will be the trim boundary for the runout on the part.

11 Trim the horizontal line to the boundary line as shown.

boundary line 
for trim

boundary line 
for trim
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12 Erase the vertical trim boundary line.

13 Extend the remaining vertical line as shown.

14 Add 1 mm fillets to the outside corners.

The top view is almost complete. You still need to change the hidden silhouette edges of the holes 
to a dashed linetype.

To change the linetype of the four vertical lines, you will override the linetype property currently 
assigned to the lines. As you remember, you can select the objects and then use either the Properties 
palette or the Properties toolbar to specify the required linetype.

Change linetypes

1 Select the four vertical silhouette edges of the holes. 

2 Click Modify menu ➤ Properties.

Notice that because you selected more than one object, only the common properties are listed.

3 On the Properties palette, click Linetype. Click the arrow and, from the list, click 
ACAD_ISO02W100.

boundary line 
for trim

erase line

extend line

silhouette edges
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4 Click Linetype Scale. Type 0.3 for the new linetype scale and press ENTER. 

5 Move your cursor off the Properties palette and press ESC to clear the selection.

The four lines are now displayed with a dashed linetype.

NOTE Instead of changing the linetype of the four lines individually, you could have created a new 
layer for hidden lines. The linetype property of that layer could then be set to ACAD_ISO02W100. Then, 
to change the linetype of the four lines, you would change the layer assignment of the lines to the new 
layer.

6 The tutorial is complete. If you want to keep this drawing, save it now.

Match Properties

You can easily copy properties of one object to other objects. You can choose to match color, layer, 
linetype, linetype scale, lineweight, thickness, plot style, and in some cases dimension styles, text 
styles, and hatch patterns.

Try it: Copy the properties from one object to other objects

1 Start a new drawing.

2 Draw several objects with different color properties.

3 Click Modify menu ➤ Match Properties.

4 Click the source object from which you want to copy properties.

5 Click the objects to which you want to copy the properties.

You can also use the Settings option of the command to select the properties you want to match and 
clear the ones you don’t. 
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Use Editing Aids

The following editing aids help you modify drawings efficiently:

■ Grips edit objects using your cursor and a shortcut menu.
■ Revision clouds identify areas that have been updated.

Edit with Grips

Grips are small squares and arrows that appear on an object after it has been selected. They mark 
control locations and are powerful editing tools. 

After you select an object, you can click a grip and move it with your cursor. For more options, click 
a grip and right-click to display a shortcut menu. Then choose a grip edit mode.

select line click grip
move grip to end of 
horizontal line

1

2

Grip edit modes

Grip edit mode options
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Try it: Edit objects using grips

1 Draw several objects.

2 Click several objects to select them and to display their grips.

3 Click a grip on an object and click its new location. This is the default stretch mode.

■ Notice the grip behavior when object snaps are turned on.
■ Notice the grip behavior when you stretch a grip onto another grip.

4 Click a grip on an object and then right-click.

5 Choose a different grip mode such as Move, Mirror, Rotate, or Scale.

6 Press ESC to exit grip editing.

Create Revision Clouds

If you review or redline drawings, you can increase your productivity by using revision clouds to 
highlight your markups. You draw the revision cloud around the objects you want to emphasize, 
creating a polyline in the shape of a cloud, as shown in the following illustration.

Try it: Create a revision cloud

1 Click Draw menu ➤ Revision Cloud.

2 Click anywhere in the drawing area and move your cursor to encompass an area.

3 Repeat the command and see whether the revision cloud always creates the arcs outward or if 
you can trick it.
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Analyze Drawings

You can extract information from your model using the inquiry commands. The most commonly 
used one is the DIST command.

Use DIST to quickly determine the relationship between two points. You can display the following 
information for two points you specify:

■ Distance between them in drawing units
■ Angle between the points in the XY plane
■ Angle of the points from the XY plane
■ Delta, or difference, between the X, Y, and Z coordinate values of each point

Try it: Find the distance and angle between two points

1 Click Tools menu ➤ Inquiry ➤ Distance.

2 Use an object snap to locate a point on an object.

3 Use another object snap to locate a point on a different object.

4 Review the data displayed in the command window.

5 Press F2 to see the data in a larger window called the Text window.

To get started

Action Menu Toolbar

Erase objects Modify ➤ Erase Modify

Extend objects Modify ➤ Extend Modify

Trim objects Modify ➤ Trim Modify

Copy objects in a drawing
Copy objects between drawings

Modify ➤ Copy
Edit ➤ Copy

Modify
Standard

Offset objects Modify ➤ Offset Modify

Mirror objects Modify ➤ Mirror Modify

Move objects Modify ➤ Move Modify

Rotate objects Modify ➤ Rotate Modify

Fillet objects Modify ➤ Fillet Modify

Edit properties Tools ➤ Properties
Modify ➤ Properties

Standard
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Help system

ERASE, EXTEND, TRIM, COPY, COPYCLIP, PASTECLIP, OFFSET, MIRROR, MOVE, ROTATE, UNITS, FILLET, 
PROPERTIES, MATCHPROP, OPTIONS, REVCLOUD, DIST

Review and Recall

1 What is the difference between a crossing selection and a window selection?

2 What is the fastest way to create several parallel lines?

3 What is the easiest way to create an arc that is tangent to two other objects?

4 When creating or modifying an object, what do you do to display the object snap menu?

5 What is an easy way to find the distance between two points in a drawing?

Match properties Modify ➤ Match 
Properties

Standard

Create revision clouds Draw ➤ Revision 
Cloud

Draw

Extract information from objects Tools ➤ Inquiry ➤ 
Distance

Inquiry

To get started

Action Menu Toolbar



Hatch to fill areas with patterns or solid colors 
that help identify the subject matter or material

Create blocks when you want 
to use drawings or parts of 
drawings repeatedly

These symbols, called blocks in AutoCAD, 
represent standard items such as trees or bushes



Add Symbols and Hatches

Overview of Blocks. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .118
Benefits of Blocks. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118
Sources of Blocks. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118

Insert Blocks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .119
Tutorial: Adding Blocks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119

Overview of Hatches  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .121
Use Standard Hatch Patterns. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121
Associative Hatches . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121

Insert Hatches or Solid Fills  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .121
Define Hatch Boundaries. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122
Tutorial: Add Hatches to a Drawing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122



118 | Chapter 8 Add Symbols and Hatches

Overview of Blocks

In AutoCAD, symbols are called blocks. A block is a collection of objects that are associated into a 
single object. A block can be used to represent an object such as a tree, a fastener, or a door.

Blocks are typically defined and stored in drawings called block libraries, or symbol libraries, from 
which they can be inserted into other drawings. An entire drawing can also be inserted as a block.

Blocks may also include block attributes, which store data such as part numbers, dates, and 
performance ratings.

Benefits of Blocks

Using blocks makes it easier and faster to get your work done:

■ Create drawings efficiently by inserting, relocating, and copying blocks rather than individual 
geometric objects.

■ Build a standard library of frequently used symbols, components, or standard parts.
■ Store associated data with block attributes which can be extracted to create reports.
■ Manage blocks with DesignCenter. DesignCenter provides convenient organization and access to 

thousands of symbols on your computer, on your local network, and on the World Wide Web.

Sources of Blocks

There are several sources of blocks that you can use in your drawings.

■ Your computer. AutoCAD provides over 300 standard blocks in 15 symbol library drawings in the 
DesignCenter folder.

■ Your company network. You can also create your own blocks and block libraries, or your 
company may already have its own standard libraries.

■ The World Wide Web. Numerous Autodesk and commercial symbol libraries containing 
thousands of blocks are available, including several that are available free by using the DC Online 
tab in DesignCenter.

NOTE Creating blocks, block attributes, or block libraries are more advanced topics and are not 
covered in this guide.

block references 
of fastener 
inserted into a 
drawingblock definition for 

fastener
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Insert Blocks

AutoCAD provides the following three methods for inserting blocks into drawings:

■ Insert dialog box. Place a block by specifying its insertion point, scale, and rotation angle.
■ DesignCenter. Locate symbol libraries and place or drag a block into a drawing or onto a tool 

palette. Use DesignCenter to locate and manage a large number of blocks and block libraries.
■ Tool Palettes window. Place or drag a block into a drawing. Use tool palettes to organize and 

access your most commonly used blocks.

Tutorial: Adding Blocks

1 Open MyDesign, the drawing that you created and saved in a previous tutorial.

2 Offset the lines to create walls (if it’s a health spa or motor housing) or ridges (if it’s a catch for 
a window lock). Use a value for the offset distance that is appropriate for what you are creating. 
Clean up the corners using Fillet with the fillet radius set to 0.
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Open a block library

1 Click Tools menu ➤ DesignCenter.

The DesignCenter window is divided into the tree view on the left side and the content area on 
the right side. 

2 On the DesignCenter window, click the Folders tab if necessary. In the tree view, navigate to the 
Help\Tutorials\Symbol Libraries folder.

3 Click the plus sign (+) on the block library that’s appropriate for your drawing:

■ Fasteners - Metric.dwg
■ Fasteners - US.dwg
■ Office - Metric.dwg
■ Office - US.dwg

4 Click the Blocks item under the drawing that you just expanded. The blocks become visible in 
the Content area of DesignCenter.

Place and relocate blocks with DesignCenter

1 Drag one of the blocks from DesignCenter into your drawing. The precise location is not 
important.

2 Click the block. Notice the colored grip that displays. Drag the grip to move the block into place.

3 Click the grip and right-click. On the shortcut menu, click Rotate. Rotate the block either with 
the cursor or by entering a rotation angle.

4 In DesignCenter, double-click a different block.

5 In the Insert dialog box, under Rotation, click Specify On-Screen. Click OK.

6 Click a location in your drawing. You are prompted to specify a rotation angle. Rotate the block 
either with the cursor or by entering a rotation angle.

7 Close the DesignCenter window.

Place blocks with the Insert dialog box

1 Click Insert menu ➤ Block.

2 In the Insert dialog box, click the arrow next to the Name box. These are the block definitions 
currently stored in your drawing. Click one of them and click OK. Specify the location for the 
block.

3 Add several more blocks to your drawing. Save the drawing.

Access block libraries from the Web

1 Open DesignCenter again.

2 Click the DC Online tab. If you have an Internet connection, you can explore the commercial 
symbol libraries that are available.
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Overview of Hatches

A hatch pattern is a standard pattern of lines or dots used to highlight an area in a drawing, or to 
identify a material such as concrete, steel, or grass. In AutoCAD, a hatch pattern can also be a solid 
or a gradient fill.

Use Standard Hatch Patterns

AutoCAD supplies more than 60 industry-standard ISO and imperial hatch patterns. You can use a 
pattern supplied with AutoCAD or one from an external pattern library. Hatch patterns are stored 
in hatch pattern files with PAT extensions.

Associative Hatches

By default, hatches are associative. Associative hatches are linked to their boundaries and are updated 
when the boundaries are modified. You can remove associativity from a hatch at any time.

Insert Hatches or Solid Fills

You can hatch or fill objects in a drawing using one of these methods:

■ Choose Hatch from the Draw menu or toolbar to create hatches and solid fills.
■ Use DesignCenter to drag hatches into the drawing or onto a tool palette. 

Industry-standard 
hatch patterns

ANSI31

INSUL

AR-CONC

Hatched object Result of editing 
boundary with 
nonassociative hatch

Result of editing 
boundary with 
associative hatch
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■ Use a tool palette to drag commonly used hatches into a drawing quickly.

Define Hatch Boundaries

Hatch boundaries can be any combination of objects such as lines, arcs, circles, polylines, text, and 
blocks. Hatch boundaries must enclose an area, but they can include islands (enclosed areas within 
the hatch area) that you choose to hatch or leave unhatched.

Tutorial: Add Hatches to a Drawing

In this tutorial, you will hatch part of your drawing to look something like this:

1 Open MyDesign, the drawing that you created and saved in the previous tutorial.

2 Click Draw menu ➤ Hatch.

3 On the Hatch tab, under Type and Pattern, notice the name of the hatch pattern and the swatch. 
Choose a different hatch pattern.

4 Under Boundaries, click Add: Pick Points. Then click anywhere between the parallel lines for the 
walls and press ENTER.

ResultBoundaries detectedInternal point selected

internal point

islands
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5 At the bottom of the dialog box, click Preview. 

There are probably several things that you’ll want to change, including the circle being hatched, 
the hatch angle, and the hatch spacing. 

6 Press ESC to return to the dialog box.

7 Click the > (More Options) button at the bottom-right corner of the dialog box.

8 Under Islands, click Outer. Then click the < (Less Options) button.

9 Under Angle and Scale, change the values for the angle and for the scale. If the hatch is too dense, 
increase the value for the scale by a factor of 10.

10 Click Preview. If the hatch is still not acceptable, return to step 6. Otherwise, right-click or press 
ENTER to accept the hatch.

11 Save your drawing file.

Help system

ADCENTER, BLOCK, EXPLODE, INSERT, TOOLPALETTES, HATCH

Review and Recall

1 What is a block?

2 What is a block library?

3 How can you use object snaps with blocks?

4 What are three ways to hatch an area in a drawing?

5 How do you fill an area with a solid color?

To get started

Action Menu Toolbar

Insert a blocks Insert ➤ Block Draw

Open DesignCenter Tools ➤ DesignCenter Standard

Open the Tool Palettes 
window

Tools ➤ Tool Palettes Window Standard

Hatch an area Draw ➤ Hatch
Tools ➤ DesignCenter
Tools ➤ Tool Palettes Window

Draw
Standard
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Create and Modify Text

AutoCAD provides a text editor to add text to drawings. The In-Place Text Editor displays the 
bounding box with a ruler at the top and the Text Formatting toolbar.

With the In-Place Text Editor, you can choose formatting that affects the entire text object or only 
selected text. You can also control indents.

Before creating the text, you define the width of the text by specifying the two opposite corners of 
a text boundary. Only the width of the box has an effect. AutoCAD inserts the text you enter in the 
dialog box within this limit and wraps words that don’t fit to the next line.

When using the text editor, you can easily change the width by dragging the right side of the ruler. 

NOTE The fastest way to make changes to an existing text object is to double-click it. This opens the 
In-Place Text Editor and displays the text to be changed.

display menu options

display ruler

save changes and 
close

set width of 
multiline text 
objects

rulerparagraph 
indent

first-line indent

tab stops
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Additional features that are available for text in drawings include

■ A spell checker with customizable dictionaries
■ The Find and Replace dialog box for locating and correcting text
■ The ability to create mirrored text

Try it: Create multiline text objects

1 Start a new drawing.

2 To display the text at a convenient size, zoom into a small area above the title block.

3 Click Draw menu ➤ Text ➤ Multiline Text.

4 Click two points to determine the width of the text object.

5 In the In-Place Text Editor, type your text.

6 Highlight a word and click some of the formatting options.

These options are nearly identical with those in word processing applications.

7 Click OK on the Text Formatting toolbar.

Try it: Modify an existing text object

1 Double-click the text object.

2 Highlight more words or the entire paragraph and click more formatting options.

3 Click OK on the Text Formatting toolbar.
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Work with Text Styles

All text in an AutoCAD drawing has a text style associated with it. When you enter text, AutoCAD 
uses the current text style, which determines the following properties:

■ Font controls the shapes of the characters
■ Font style controls the italic and boldface formatting for TrueType fonts
■ Height controls the size in drawing units of the text
■ Obliquing angle controls the forward or backward slant of the text 
■ Orientation controls the vertical or horizontal alignment of single-line text
■ Other text characteristics controls effects such as wide text and backwards text

Create and Modify Text Styles

Except for the default STANDARD style, you must define any text style that you want to use. Once 
you’ve created a style, you can modify its settings, change its name, or delete it when you no longer 
need it. When you create or modify a text style, you use the Text Style dialog box. 

If you change an existing style’s font, all text in the drawing that uses that style is regenerated using 
the new font.

NOTE If you create notes and labels directly on a layout in paper space, no scaling is necessary. Notes 
and labels created in model space must be sized to accommodate the scale of the layout viewport.

choose a different 
text style

create a new 
text style

sample text 
shows the 
changes you 
make

specify a different 
text font to be 
used by the text 
style
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Set Text Size for the Viewport Scaling

With AutoCAD, you can create text either in model space or on the layout in paper space. The space 
in which you create text depends on the circumstances.

■ If the text is more closely associated with the layout, you should create the text in paper space. 
With this option, there are no scaling considerations and you create the text at its full size (1:1).

■ If the text is more closely associated with the model, and you anticipate referencing the model 
and the text from other drawings or other views, you should create the text in model space. With 
this option, the text must usually be scaled.

Preparing one or more views on a drawing layout usually involves displaying them in layout 
viewports at various scales other than 1:1. If you create text in model space, you must size it for 
correct display and plotting in paper space.

Set Text Size in Model Space

Set the text size in model space using the following formula:

Text size in model space = desired text size/scale of the layout viewport

■ Example 1: If the desired text size is 3 mm and the viewport scale is 1:4 (0.25), 
then use 3/0.25 = 12 mm for the text size in model space.

■ Example 2: If the desired text size is 1/8 inch and the viewport scale is 1”=4’ (1:48), 
then use (1/8)/(1/48) = 48/8 = 6 inches for the text size in model space.

Obviously, creating text directly on the layout is much easier because no scaling is required. It is 
recommended that you create view-specific text in model space, and general notes, tables, and labels 
in paper space.

Help system

FIND, MTEXT, MIRRTEXT, MTEXTED, SPELL, STYLE, SCALETEXT, JUSTIFYTEXT, STYLE, SPACETRANS

To get started

Action Menu Toolbar

Create multiline text Draw ➤ Text ➤ Multiline Text Draw, Text

Modify text Modify ➤ Object ➤ Text Text

Check the spelling in a drawing Tools ➤ Spelling

Find and replace text Edit ➤ Find Text

Creating text styles Format ➤ Text Style Text
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Review and Recall

1 What is the fastest way to open the In-Place Text Editor when you need to change existing text?

2 What are some advantages to creating additional text styles?

3 How do you decide whether to create text in paper space or in model space?

4 What text height should you use in model space if the desired text height in paper space is 2.5 mm 
and the display scale of the layout viewport is 1/50 (0.02)?
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Dimensions Overview

Dimensions show the geometric measurements of objects, the distances or angles between objects, 
or the location of a feature. AutoCAD offers four general types of dimensions: 

■ Linear. Measures distances using horizontal, vertical, aligned, rotated, baseline (parallel), and 
continued (chain) dimensions.

■ Ordinate. Measures the distance of a point from a specified origin point.
■ Radial. Measures the radii and diameters of arcs and circles.
■ Angular. Measures the angle formed by two lines or three points.

Parts of a Dimension

Dimensions have several distinct elements: 

■ Dimension line. Indicates the direction and extent of a dimension. For angles, the dimension line 
is an arc. 

■ Extension line. Extends from the feature being dimensioned to the dimension line.
■ Dimension text. Reflects dimension value and may include prefixes, suffixes, and tolerances. 

Alternatively, you can supply your own text or suppress the text entirely.
■ Arrowhead. Indicates an end of the dimension line. Several types of arrowheads are available, 

including architectural ticks and dots.
■ Leader. Forms a solid line leading from an annotation to the referenced feature. Depending on 

the dimension style, leaders can be created automatically when dimension text won’t fit between 
extension lines. You can also create leader lines to connect text or a block with a feature.

Associative Dimensions and Leaders

By default, AutoCAD creates associative dimensions. The measurements displayed by associative 
dimensions are updated automatically as you modify the objects with which they are associated.

Leader objects are composed of text, a leader line, and an arrowhead. 

■ If the text portion of a leader object is moved, the leader line is also adjusted.
■ If a leader object is associated with a geometric object, and the object is moved, stretched, or 

scaled, the arrowhead and the leader portion of the leader object are also updated.

dimension line

extension line

dimension text

arrowhead

leader
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Create Dimensions

You can dimension lines, arcs, circles, and several other types of objects. There are two primary 
methods for creating dimensions:

■ Select an object to dimension (1) and specify the dimension line location (2) as shown in the 
following examples.

■ Use object snaps to specify the extension line origins, and then specify the dimension line 
location. The extension line origin points can be on separate objects.

Tutorial: Create Dimensions

In this tutorial, you will set the scale for your drawing and add several dimensions to your design.

1 Open MyDesign, the drawing that you created and saved in previous tutorials.

2 Click the layout tab near the bottom-left of the application window.

Result of selecting a line 
for a dimension

Result of selecting a circle 
for a dimension

1

2

1

2
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Set the display scale of the viewport.

1 Click the blue layout viewport border to select it.

2 Click Modify ➤ Properties.

3 On the Properties palette, click Display Locked and then No.

Note It is strongly recommended that you keep the display in layout viewports locked unless you’re 
setting the display scale of the viewport. This prevents you or someone else from accidentally zooming 
in or out and changing the display scale.

4 Double-click inside the layout viewport. You are now accessing model space from the layout.

5 Click View menu ➤ Zoom ➤ Extents.

This step centers your view.

6 Double-click outside the layout viewport to return to paper space.

You can now specify the precise scale for the floor plan or part.

7 Click the blue layout viewport border to select it. On the Properties palette, under Misc, click 
Standard Scale.

8 Click the arrow to display a list of scales. Click the one that seems the most appropriate for the 
sheet size and the size of your floor plan or part. You can always choose a different scale if 
necessary.

9 Lock the layout viewport.

Add dimensions

1 Change the current layer to the Dimensions layer.

It is a good practice to use a separate layer reserved for dimension objects.

2 Double-click inside the layout viewport to access model space.

There is a good reason why you are creating dimensions from the layout tab rather than the 
Model tab. When you dimension in model space from the layout tab, the dimensions are 
automatically scaled relative to the viewport scale.

3 Click Dimension menu ➤ Linear. Follow the prompts to create several linear dimensions.
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4 Experiment with several other types of dimensions.

NOTE Automatic dimension scaling is not turned on in all drawings or drawing template files. It works 
only when the system variable DIMSCALE is set to 0. You can enter DIMSCALE on the command line. 
Check the Help system topic on DIMSCALE for more information.

Add Text

1 Double-click outside the layout viewport to return to paper space.

2 Change the current layer to the Text layer.

3 Create several notes using multiline text.

4 Save your drawing.
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Use Dimensioning Options

In addition to the basic types of dimensions, AutoCAD provides these options on the Dimension 
menu and toolbar:

■ Center marks and centerlines locate the exact center of circles or arcs.
■ Leader lines connect annotation to drawing features.
■ Geometric tolerances show deviations of form, profile, orientation, location, and runout of 

drawing features.

Create Center Marks and Lines

You can easily create a center mark or centerline on a circle or arc. The size and style of center marks 
and centerlines are controlled by the dimension style.

Try it: Create center marks and lines

1 Start a new drawing and click the Model tab.

2 Draw a small circle.

3 Click Dimension ➤ Center mark and click the circle.

Two lines in the shape of a plus are created at the center of the circle.

You can also create center marks with the radius and diameter dimensions.

center mark

centerlines



Use Dimensioning Options | 139

Create Leaders with Annotation

You can create a leader from any point or feature in a drawing. Leaders can be straight line segments 
or smooth spline curves. Leader color, scale, and arrowhead style are controlled by the current 
dimension style. A small line known as a hook line usually connects the annotation to the leader line. 
Leader annotations can be multiline text, a feature control frame, or a block reference.

The simple leader in the example was created by specifying the From (1) and To (2) points of the 
leader, pressing ENTER, and then entering the leader text.

2

1
leader line

hook line
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Create and Modify Dimension Styles

Every dimension has a dimension style associated with it. Dimension styles help you establish and 
enforce drafting standards. Dimension styles also make changing dimension formats and behavior 
easy. A dimension style defines

■ Format and position of dimension lines, extension lines, arrowheads, and center marks
■ Appearance, position, and behavior of dimension text
■ Rules governing text placement and dimension lines
■ Overall dimension scale
■ Format and precision of primary, alternate, and angular dimension units
■ Format and precision of tolerance values

New dimensions use the current settings in the Dimension Style Manager dialog box. The default 
STANDARD style is assigned to dimensions until you set another style as current.

Overrides allow for style modifications to the current dimension style. Overrides apply to all 
subsequent dimensions created with that style until you make a new style current. They do not 
permanently modify a dimension style. You can also override properties of dimensions using the 
Properties palette.

Regardless of whether you choose New, Modify, or Override in the Dimension Style Manager, the 
same set of options are available: 

■ Lines sets the appearance and behavior of dimension lines and extension lines.
■ Symbols and Arrows sets the appearance and behavior of dimension arrowheads, center marks, 

and centerlines.
■ Text sets the dimension text appearance, placement, and alignment.
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■ Fit sets options governing placement of dimension lines, extension lines, and text. It also 
includes the setting for automatic dimension scaling.

■ Primary Units sets the format (for example, scientific, decimal, architectural) and precision of 
linear and angular dimension units.

■ Alternate Units sets alternate unit format and precision. This feature supports dual dimensions 
that display, for example, both metric and imperial units. 

■ Tolerances sets tolerance values and precision.

NOTE Creating a dimension style to conform with industry or company standards requires agreement 
on over 70 settings. It is important that your organization creates and maintains one or more official 
dimension styles.
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Modify Dimensions

You can modify dimensions with grips or with the AutoCAD editing commands. You can also 
modify or override dimension styles, as discussed in the previous topic. For significant modifications 
to a dimension, it is usually easier to erase and re-create the dimension.

The easiest way to make minor modifications in a dimension is to use grips. For example, you can 
easily drag a dimension line to align it with another dimension line.

You can also drag dimension text to a different location.

To get started

Action Menu Toolbar

Create linear dimensions Dimension ➤ Linear

Create aligned dimensions Dimension ➤ Aligned

Create ordinate dimensions Dimension ➤ Ordinate

1 Click dimension
2 Click grip at end of 
dimension line

3 Move grip to new 
dimension location

1 Click dimension
2 Click grip on 
dimension text

3 Move grip to relocate 
dimension text
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Help system

DIMALIGNED, DIMANGULAR, DIMBASELINE, DIMCONTINUE, DIMDIAMETER, DIMJOGGED, DIMLINEAR, 
DIMORDINATE, DIMRADIUS, DIMSCALE, DIMSTYLE, DIMEDIT, DIMTEDIT, DIMOVERRIDE, DIMCENTER, 
QLEADER, DIMSTYLE, DIMREGEN

Create radius dimensions Dimension ➤ Radius

Create diameter dimensions Dimension ➤ Diameter

Create angular dimensions Dimension ➤ Angular

Create baseline dimensions Dimension ➤ Baseline

Create continued dimensions Dimension ➤ Continue

Create and modify a 
dimension style

Dimension ➤ Dimension Style

Update an existing dimension to 
reflect a style change

Dimension ➤ Update

Create a center mark Dimension ➤ Center Mark

Create leaders with annotation Dimension ➤ Leader

To get started

Action Menu Toolbar
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Review and Recall

1 What is the behavior of associative leaders and associative dimensions?

2 Why should you lock layout viewports?

3 To ensure that dimensions are scaled according to the layout viewport scale, what dimension variable 
should be set to 0?

4 What is the easiest way to modify the location of a dimension feature such as the dimension line or 
dimension text?
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in layout viewports

Layout
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title block, one 
or more layout 
viewports, and 
text objects

Layout viewports
Display one or more views of the model, each of which 
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Page Setups
Save plot settings by name and 
associate them with a layout
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Work with Layouts

You use a layout to compose the plotted page. A layout typically includes the following objects:

■ General notes and tables
■ View-specific label blocks and callout blocks (this is an advanced topic not covered in this guide)
■ Layout viewports

Layouts show the page border and actual printing area. The page size and actual printing area 
depend on the printer or plotter assigned to the layout.

Create a New Layout

The two most common reasons for creating a new layout are

■ Creating a new drawing template file that includes a different paper size and orientation.
■ Adding a layout with a different paper size, orientation, and title block to an existing drawing.

The easiest way to create a new layout is to use the Create Layout wizard. Once you create a layout, 
you can replace the title block and create or delete layout viewports.

page borderprintable 
area

layout tab layout viewport, displays 
a view of model space
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Try it: Create a layout

1 Start a new drawing.

2 Click Tools menu ➤ Wizards ➤ Create Layout.

3 Follow the steps in the wizard to create a layout with a different paper size and matching title 
block.

4 Right-click the layout tab. On the shortcut menu, click Rename. In the Rename Layout dialog 
box, enter a new name for the layout. Click OK.

To save this drawing as a new drawing template file, click File menu ➤ Save As. In the Save Drawing 
As dialog box, under Files of Type, specify a DWT extension.

Use Layout Viewports

Layout viewports on a layout tab display views of model space. The following points summarize the 
relationship of layout viewports and model space:

■ The majority of the objects in your drawings are created in model space on the Model tab.
■ To display and scale views of model space in a layout, you create layout viewports.
■ You enter model space through a layout viewport primarily to pan the view and to set layer 

visibility.
■ You can control the visibility of layers separately in each layout viewport.
■ For any significant editing of your drawing, use the Model tab.
■ To create correctly scaled dimensions, enter model space from the layout tab and then dimension 

the model.

Create and Modify Layout Viewports

When you create a new layout, a single layout viewport is added by default. You can add more layout 
viewports for independent views such as details and 3D views. Each viewport can have its own scale, 
plot properties, and layer visibility settings.

Tutorial: Work with Layout Viewports

In this tutorial, you will practice the most common operations used with layout viewports.

Change the display scale of a view in a layout viewport

1 Click File menu ➤ Open.

2 In the Select File dialog box, find the /Help/Tutorials folder in the AutoCAD installation folder 
and open arbor.dwg.

3 In the Layer Properties Manager, click the light bulb icon on the Viewport layer to display the 
objects on that layer. Click OK.

The blue borders of the layout viewports are now visible.

4 Click Modify menu ➤ Properties. Then click the blue border of the upper-right layout viewport.

Notice that the Properties palette contains the property settings for the layout viewport.
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5 In the Properties palette, under Misc, click Display Locked. Click the arrow and click No.

The display properties for the layout viewport are now unlocked. Next, you will change the 
precise scale of the view displayed in this layout viewport.

6 In the Properties palette, click Standard Scale.

7 Click the arrow to display a list of scales and click 1:40.

Notice that the view changes immediately to reflect the new display scale.

8 Double-click inside the layout viewport to enter Model Space. Pan the view as needed, but do not 
change the view scale with Zoom. Then double-click anywhere outside the layout viewports to 
return to Paper Space.

9 Use the Properties palette to lock the layout viewport.

You lock the layout viewport to prevent accidental panning and zooming in it. Thus, the view 
position and scale in the viewport are protected.

Erase a layout viewport

1 Click Modify menu ➤ Erase.

2 Click the border of the upper-right layout viewport and press ENTER.

A layout viewport is an object. Like other objects, it can be moved, copied, and erased.

Create a new layout viewport

1 Make the Viewport layer the current layer.

2 Click View menu ➤ Viewports ➤ 1 Viewport.

3 Click two points in a blank area on the layout. The two points are the diagonal corners of the 
new layout viewport.

The new layout viewport can overlap an existing viewport.

4 Click the border of the layout viewport to display its grips.

5 Adjust the size of the layout viewport by clicking a grip, moving the cursor, and clicking a new 
location. Move the layout viewport with the Move command.

6 Use the Properties palette to set the display scale of the view in the layout viewport.

7 Double-click within the layout viewport and pan the view. Double-click outside of all viewports 
to return to paper space.

8 Use the Properties palette to lock the layout viewport.

9 Turn the Viewport layer off.

10 Close the drawing without saving it.

NOTE Make sure that you create layout viewports on their own layer. When you are ready to plot, turn 
off the layer to prevent the viewport borders from being plotted.
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Choose and Configure Plotters

AutoCAD supports a wide range of printers and plotters. Devices with a Windows printer driver 
installed are available automatically when you plot unless the plotting option to hide system 
printers has been selected. Many plotters that do not have Windows drivers (nonsystem plotters) can 
be configured for use with AutoCAD using drivers provided either by Autodesk or by the plotter 
manufacturer.

You can also configure drivers to save drawings in several file formats. Formats include DWF™ 

(Design Web Format) files to view drawings in a web browser or external viewer, PostScript files for 
use with page layout programs, and raster files.

If an output device is not listed in the Plot or Page Setup dialog boxes, or if its settings are incorrect, 
you can easily add or edit printer and plotter configurations.

Add a Plotter Configuration

The Plotter Manager is a folder that provides a method for adding, deleting, and changing plotter 
configurations. Plotter configuration files have a .pc3 extension and are stored in the Plotters folder. 
To display the Plotters folder, click File menu ➤ Plotter Manager.

The Plotter Manager includes plotter configuration (PC3) files for every nonsystem printer that you 
install. Plotter configuration files can also be created for Windows® system printers if you want the 
program to use default properties different from those used by Windows.

To add a plotter configuration, double-click the Add-A-Plotter wizard in the Plotter Manager. The 
Add-A-Plotter wizard prompts you for information about your plotter, including

■ Whether the plotter is attached to your computer or on a network
■ The type of plotter, including manufacturer and model
■ Whether to use a plotter configuration file from previous versions of the product
■ Whether to output to a computer port or file, and which port to use

The Plotter Manager
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■ Raster and vector graphics quality settings
■ Custom properties that depend on the plotter type
■ A unique name for the new plotter configuration

Once a new PC3 file is created, the plotter configuration is available for layouts and plotting.

Change a Plotter Configuration

The Plotter Configuration Editor is used to

■ Edit the port or file output information
■ Change or add paper sizes and layouts
■ Control vector and raster graphic output
■ Calibrate your plotter

Set any of your plotter’s custom properties to start the Plotter Configuration Editor, either double-
click the PC3 file or choose Properties in the Plot dialog box.

Use Plot Styles to Override Properties

A plot style is an optional method to control how each object or layer is plotted. Assigning a plot style 
to an object or layer overrides properties such as color and lineweight for plotting. Only the 
appearance of plotted objects is affected.

Plot style tables collect groups of plot styles and save them in a file that you can later specify when 
plotting. The Plot Style Manager is a folder that contains all the available plot style tables and the 
Add-A-Plot Style wizard.

There are two types of plot style tables:

■ Color-dependent plot style tables. An object’s color determines how it is plotted. The files have 
the extension .ctb. You cannot assign color-dependent plot styles directly to objects. Instead, to 
control how an object is plotted, you change its color. For example, all red objects in a drawing 
can be set to plot with a 0.50 mm lineweight.

■ Named plot style tables. Plot styles are assigned directly to objects and layers. The files have the 
extension .stb. Using them enables each object in a drawing to be plotted differently, 
independent of its color.

Use the Plot Style Manager to add, delete, rename, copy, and edit plot style tables. You can access 
the Plot Style Manager from the Files menu.



Plot from a Layout | 153

Plot from a Layout

After you have completed your drawing, you are ready to plot. In the Plot dialog box, you select the 
printer or plotter and many other settings.

Before you plot your drawing, it is a good practice to generate a full plot preview. If the image is not 
correct, make changes to the plot settings, page setup, and the plot style table attached to the layout.

Page Setups

To manage plot settings, you can name and save them as a page setup using the Page Setup Manager. 
When you are ready to plot, you can specify the name of the page setup in the Plot dialog box.

For example, let’s say you switch to a different plotter for color output. You can quickly restore all 
settings associated with that plotter by specifying the name of a previously saved page setup. To 
switch back, you can specify the name of the original page setup.

Each layout tab can have an associated named page setup. Page setups are saved in the drawing.

Try it: Create a page setup

1 Start a new drawing. If necessary, click a layout tab.

2 Click File menu ➤ Page Setup Manager.

3 Click New.

select the 
area of the 
drawing to 
plot

select a 
page
orientationgenerate a 

preview

specify a plot 
scale

position the layout on 
the page

select a 
page size

select a 
printer 
or a 
plotter

display or hide options

specify a plot 
style
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4 In the New Page Setup dialog box, enter My_New_Plotter. Click OK.

5 Change some settings in the Page Setup dialog box. Click OK.

The new page setup name is displayed in the Page Setup Manager.

6 Click My_New_Plotter and click Set Current.

The My_New_Plotter page setup is now associated with the current layout tab.

7 Click Close.

If you don’t specify all the settings in the Page Setup dialog box when you create a layout, you can 
set up the page just before you plot.

Tutorial: Plot a Drawing

In this exercise, you edit the page setup for an existing layout, create a new layout, insert a title block 
into the new layout, and plot the drawing.

Edit an existing layout

To prepare for plotting from a layout tab, you set up a layout, set up a viewport, and create 
dimensions. 

1 Click File menu ➤ Open.

2 In the Select File dialog box, locate the \Help\Tutorials folder and select plan.dwg.

3 Click Open.

This is a drawing of a floor plan and elevation.

4 Click the Elevation layout tab.

The Elevation layout uses a page setup that defines the plot area and page size. A specific plotter 
configuration is also associated with the Elevation layout.

5 Click File menu ➤ Page Setup Manager.

6 In the Page Setup Manager, click Modify.

7 Under Plot Style Table (Pen Assignments), open the drop-down list and click the monochrome.ctb 
file. If prompted, choose not to apply the plot style table to all other layouts.

8 Select Display Plot Styles. Click OK.

9 Click Close to close the Page Setup Manager.

The drawing is now black and white because the layout shows a preview of the drawing as it will 
be plotted with the monochrome plot style table.

10 Click the Model tab. Note that the model is still displayed in color.

Create a new layout

1 Click Tools menu ➤ Wizards ➤ Create Layout. 

The Create Layout wizard guides you through the creation of a layout.
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2 In the Create Layout wizard, on the Begin page, enter a name for the new layout. Type Elevation 
and Floor Plan. Click Next.

3 On the Printer page, select the printer that you want to use to plot this layout. Select DWF6 
ePlot.pc3. Click Next.

For this tutorial, you will plot the drawing to a DWF file rather than to a plotter. DWF (Design 
Web Format) files are convenient for distributing drawings using email, FTP sites, project 
websites, or CDs. They can be viewed using the free Autodesk®  DWF Viewer. DWF files are 
smaller, faster, and provide greater resolution than other popular options.

4 On the Paper Size page, the paper sizes available in the list are based on the printer that you 
selected. Select Letter or ANSI A (8.5 × 11.0 inches) for the paper size. Make sure that Paper Size 
in Units lists a width of 11.0 inches and a height of 8.5 inches. Click Next.

5 On the Orientation page, click Portrait for that orientation. Click Next.

6 On the Title Block page, click None from the list of available title blocks. Click Next. (You insert 
a title block once the layout is created.)

7 On the Define Viewports page, under Viewport Setup, click Array. Leave the Viewport Scale as 
Scaled to Fit. (You change the scale later.) In the Rows box, type 2. In the Columns box, type 1. 
In the Spacing Between Rows box, type 0.25. In the Spacing Between Columns box, type 0.1. This 
creates two viewports, vertically aligned, with a gap between them. Click Next.

8 On the Pick Location page, select Select Location. In the drawing area, click and drag to create a 
rectangular layout viewport that is just inside the printable area (the dashed lines).

9 On the Finish page, click Finish to complete the creation of the new layout and viewports.

Notice that two viewports have been created.

select the
Array option.

specify 2 rows 
with 1 column.



156 | Chapter 11 Create Layouts and Plots

Insert a title block into a layout

1 Make sure that you are on the Elevation and Floor Plan layout tab.

2 Click Insert menu ➤ Block.

3 In the Insert dialog box, in the Name list, click Letter (portrait).

4 Under Insertion Point, clear the Specify On-screen check box. Then, in the X and Y boxes, type 
0.4. The Z box should be 0.0.

5 Under Scale, clear the Specify On-screen check box. Then, in the X, Y, and Z boxes, type 1 to set 
the layout to be plotted full scale.

6 Under Rotation, clear the Specify On-screen check box. Then, in the Angle box, type 0 to keep 
the title block horizontal.

7 Click OK.

Set up the viewports to plot

Now that the layout viewports have been created, you specify the scale of the model space view 
displayed in each viewport. To change the scale of a viewport, you change the zoom magnification 
of the view. To change the portion of the model space drawing displayed in the viewport without 
changing the scale, you pan the view.

1 Select both of the viewports by clicking their borders.

2 On the Modify menu, click Properties. 

3 In the Properties palette, click Layer and select the Viewports layer from the drop-down list.
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4 In the Properties palette, click the Standard Scale box and select 3/32"=1' from the drop-down list 
of scales.

5 The model space objects are scaled correctly for plotting at 3/32"=1' (1:128).

6 Double-click inside the top viewport to switch to model space. Pan the image in the viewport 
until only the elevation view is displayed.

7 Click inside the bottom viewport to make it current. Pan the image in the viewport until only 
the floor plan is displayed.

8 Click Format menu ➤ Layer.

9 In the Layer Properties Manager, in the Name column, select the Viewports layer. In the Plot 
column, click the Plot/No Plot icon to turn off plotting for the Viewport layer. Click OK.

10 Double-click anywhere outside the viewports to return to paper space. Then lock both viewports.

Plotting is turned off for the viewport borders, but the objects displayed in the viewport are still 
plotted. Alternatively, you could have turned off the Viewport layer.

Plot the layout

Now that you have created a layout and have prepared the layout viewports for plotting, you are 
ready to plot the drawing.

1 Click File menu ➤ Plot.

The plotter you chose in the wizard is still selected.

2 If necessary, click the > button at the bottom-right corner of the Plot dialog box to display more 
plot options.

3 Under Plot Style Table (Pen Assignments), in the Name list, select the monochrome.ctb file.

4 Under Plot Area, click Extents.

This option plots all objects on the layout tab regardless of location.

5 Under Drawing Orientation, click Portrait.

6 Under Plot Scale, set the scale of the plot to 1:1.

7 Under Plot Offset, click Center the Plot.

8 Click Preview at the bottom of the dialog box. After previewing the plot, press ESC. Click OK to 
close the Plot dialog box and plot the drawing to the DWF file.

You could now send the DWF file to a client for review with the Autodesk DWF Viewer, which 
is available free on the Autodesk website.
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9 Click File menu ➤ Save As. In the Save Drawing As dialog box, enter Plan Complete in the File 
Name box, and then click Save.

Help system

LAYOUT, LAYOUTWIZARD, MVIEW, PLOTTERMANAGER, OPTIONS, PAGESETUP, PLOTSTAMP, PLOT, 
STYLESMANAGER, PLOTSTYLE, CONVERTPSTYLES, CONVERTCTB

Review and Recall

1 What types of objects are commonly found on a layout tab?

2 How do you specify the scale of a layout viewport?

3 How do you turn off the display of layout viewport borders?

4 How can you use a plot style table?

5 What is a fast way to save plot settings by name?

To get started

Action Menu Toolbar

Create a new layout Insert ➤ Layout Layouts

Create a layout viewport View ➤ Viewports ➤ 1 
Viewport

Layouts or 
Viewports

Scale a view in a layout 
viewport

Tools ➤ Properties Viewports

Add a plotter or modify a 
plotter configuration

File ➤ Plotter Manager

Override properties when 
plotting

File ➤ Plot Style Manager

Restore saved settings for 
plotting

File ➤ Page Setup Manager Layouts

Plot a layout File ➤ Plot Standard 
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Commands associated with definitions are shown in parentheses at the end of the definition.

Term Definition

absolute coordinates Coordinate values measured from a coordinate system’s origin 
point. See also origin, relative coordinates, user coordinate 
system (UCS), world coordinates, and world coordinate system 
(WCS).

aligned dimension A dimension that measures the distance between two points at any 
angle. The dimension line is parallel to the line connecting the 
dimension’s definition points. (DIMALIGNED)

angle override Locks the cursor for the next point entered. To specify an angle 
override, enter a left angle bracket (<) followed by an angle 
whenever a command prompts you to specify a point.

angular dimension A dimension that measures angles or arc segments and consists of 
text, extension lines, and leaders. (DIMANGULAR)

angular unit The unit of measurement for an angle. Angular units can be 
measured in decimal degrees, degrees/minutes/seconds, grads, and 
radians.

annotation Text, dimensions, tolerances, symbols, or notes.

array 1. Multiple copies of selected objects in a rectangular or polar 
(radial) pattern. (ARRAY) 2. A collection of data items, each 
identified by a subscript or key, arranged so a computer can 
examine the collection and retrieve data with the key. 

arrowhead A terminator, such as an arrowhead, slash, or dot, at the end of a 
dimension line showing where a dimension begins and ends. 

associative dimension A dimension that automatically adapts as the associated geometry is 
modified. Controlled by the DIMASSOC system variable. See also 
exploded dimension.

associative hatching Hatching that conforms to its bounding objects such that modifying 
the bounding objects automatically adjusts the hatch. (BHATCH)

attribute definition An object that is included in a block definition to store alphanumeric 
data about the block. Attribute values can be predefined or specified 
when the block is inserted. Attribute data can be extracted from a 
drawing and inserted into external files. (ATTDEF)
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Auto-hide A palette setting that causes palettes to hide automatically when the 
cursor moves off of it and to open automatically when the cursor 
moves onto its title bar.

baseline dimensions Multiple dimensions measured from the same baseline. Also called 
parallel dimensions. 

base point 1. In the context of editing grips, the grip that changes to a solid 
color when selected to specify the focus of the subsequent editing 
operation. 2. A point for relative distance and angle when copying, 
moving, and rotating objects. 3. The insertion base point of the 
current drawing. (BASE) 4. The insertion base point for a block 
definition. (BLOCK)

block A generic term for one or more objects that are combined to create 
a single object. Commonly used for either block definition or block 
reference. See also block definition and block reference. (BLOCK)

block definition The name, base point, and set of objects that are combined and 
stored in the symbol table of a drawing. See also block and block 
reference.

block definition table The nongraphical data area of a drawing file that stores block 
definitions.

block instance See block reference.

block reference A compound object that is inserted in a drawing and displays the 
data stored in a block definition. Also called instance. See also block 
and block definition. (INSERT)

B-spline curve A blended piecewise polynomial curve passing near a given set of 
control points. (SPLINE)

BYBLOCK A special object property used to specify that the object inherits the 
color or linetype of any block containing it. See also BYLAYER.

BYLAYER A special object property used to specify that the object inherits the 
color or linetype associated with its layer. See also BYBLOCK.

command alias A shortcut for a command. For example, CP is an alias for COPY, and 
Z is an alias for ZOOM. You define aliases in the PGP file.

command line A text area reserved for keyboard input, prompts, and messages.

command window A text area that displays the command line and a history of prompts 
and messages.

continued dimension A type of linear dimension that uses the second extension line origin 
of a selected dimension as its first extension line origin, breaking one 
long dimension into shorter segments that add up to the total 
measurement. Also called chain dimension. (DIMCONTINUE)

crosshairs A type of cursor consisting of two lines that intersect.

Term Definition
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crossing selection A rectangular area drawn to select objects fully or partly within its 
borders. See also window selection.

cursor See crosshairs.

cursor menu See shortcut menu.

CTB file A color-dependent plot style table.

default A predefined value for a program input or parameter. Default values 
and options are denoted by angle brackets (<>).

definition table The nongraphical data area of a drawing file that stores block 
definitions.

DesignCenter Browses, finds, and previews content, and inserts content, which 
includes blocks, hatches, and external references (xrefs). 
(ADCENTER)

digital signature Identifies an individual or an organization through a digital ID 
(certificate), and enables you to validate (verify the authenticity of) a 
file. (SIGVALIDATE)

dimension style A named group of dimension settings that determines the 
appearance of the dimension and simplifies the setting of dimension 
system variables. (DIMSTYLE)

dimension text The measurement value of dimensioned objects.

dimension variables A set of numeric values, text strings, and settings that control 
dimensioning features. (DIMSTYLE)

direct distance entry A method to specify a second point by first moving the cursor to 
indicate direction and then entering a distance.

drawing area The area in which your drawings are displayed and modified. The 
size of the drawing area varies, depending on the size of the 
application window and on how many toolbars and other elements 
are displayed.

drawing extents The smallest rectangle that contains all objects in a drawing, 
positioned on the screen to display the largest possible view of all 
objects. (ZOOM)

drawing limits See grid limits. 

drawing template file A drawing file with preestablished settings for new drawings. 
Drawing template files have a DWT extension.

drawing units The unit of measurement that is used in a drawing. Depending on 
the drawing, one drawing unit may equal one inch, one millimeter, 
one kilometer, one mile, or some other distance.

Term Definition
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DWF For Design Web Format. A highly compressed file format that is 
created from a DWG file. DWF files are easy to publish and view on 
the Web. See also DWG, DWT, and DXF.

DWT For drawing template. A drawing file that contains standard settings 
to be used when creating new drawings. See also DWG.

DXF For drawing interchange format. An ASCII or binary file format of an 
AutoCAD drawing file for exporting drawings to other applications 
or for importing drawings from other applications. See also DWF, 
DWG, and DWT.

explode To disassemble a complex object, such as a block, dimension, or 
polyline, into simpler objects. In the case of a block, the block 
definition is unchanged. The block reference is replaced by the 
components of the block. See also block, block definition, and 
block reference. (EXPLODE)

extents See drawing extents.

external reference (xref) A drawing file referenced by another drawing. (XREF)

fill A solid color covering an area bounded by lines or curves. (FILL) 

floating viewports See layout viewports.

font A character set, which includes letters, numbers, punctuation marks, 
and symbols of a distinctive proportion and design.

freeze A setting that suppresses the display of objects on selected layers. 
Objects on frozen layers are not displayed, regenerated, or plotted. 
Freezing layers shortens regenerating time. See also thaw. (LAYER)

geometry All graphical objects such as lines, circles, arcs, polylines, and 
dimensions. Nongraphical objects, such as linetypes, lineweights, 
text styles, and layers are not considered geometry. See also named 
object.

graphics area See drawing area.

graphics screen See drawing area.

grid An area covered with regularly spaced dots to aid drawing. The 
spacing between grid dots is adjustable. Grid dots are not plotted. 
See also grid limits. (GRID)

grid limits The user-defined rectangular boundary of the drawing area covered 
by dots when the grid is turned on. Also called drawing limits. 
(LIMITS)

Grip modes The editing capabilities activated when grips are displayed on an 
object: stretching, moving, rotating, scaling, and mirroring.

Term Definition
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grips Small squares that appear on objects you select. After selecting the 
grip, you edit the object by dragging it with the pointing device 
instead of entering commands.

i-drop A method by which a drawing file can be dragged from a web page 
and inserted into another drawing.

Info palette Quick Help in the Info palette continually monitors the commands 
in progress and displays information that is directly related to the 
active command or dialog box. (ASSIST)

instance See block reference.

island An enclosed area within a hatched area.

layer A logical grouping of data that are like transparent acetate overlays 
on a drawing. You can view layers individually or in combination. 
(LAYER)

layout The tabbed environment in which you create and design paper 
space layout viewports to be plotted. Multiple layouts can be 
created for each drawing.

layout viewports Objects that are created in paper space that display views. See also 
paper space. (VPORTS)

limits See grid limits.

line font See linetype.

line width See lineweight.

linetype How a line or type of curve is displayed. For example, a continuous 
line has a different linetype than a dashed line. Also called line font. 
(LINETYPE) 

lineweight A width value that can be assigned to all graphical objects except 
TrueType® fonts and raster images.

mirror To create a new version of an existing object by reflecting it 
symmetrically with respect to a prescribed line or plane. (MIRROR)

mode A software setting or operating state. 

model A two- or three-dimensional representation of an object. 

model viewports A type of display that splits the drawing area into one or more 
adjacent rectangular viewing areas. See also layout viewports and 
viewport. (VPORTS)

model space One of the two primary spaces in which objects reside. Typically, a 
geometric model is placed in a three-dimensional coordinate space 
called model space. A final layout of specific views and annotations 
of this model is placed in paper space. See also paper space. 
(MSPACE)

Term Definition
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named object Describes the various types of nongraphical information, such as 
styles and definitions, stored with a drawing. Named objects include 
linetypes, layers, dimension styles, text styles, block definitions, 
layouts, views, and viewport configurations. Named objects are 
stored in definition (symbol) tables.

node An object snap specification to locate points, dimension definition 
points, and dimension text origins.

NURBS For nonuniform rational B-spline curve. A B-spline curve or surface 
defined by a series of weighted control points and one or more knot 
vectors. See also B-spline curve.

object One or more graphical elements, such as text, dimensions, lines, 
circles, or polylines, treated as a single element for creation, 
manipulation, and modification. Formerly called entity.

object properties Settings that control the appearance and geometric characteristics 
of objects. Properties that are common to all objects include color, 
layer, linetype, linetype scale, and 3D thickness. (PROPERTIES)

Object Snap markers A geometric symbol that is displayed when the cursor moves over 
an object. See also object snap mode.

object snap menu The menu that is displayed in the drawing area at the cursor 
location when you hold down SHIFT and right-click the pointing 
device. Also called a shortcut menu, it is defined in the POP0 section 
of aclt.mnu. See also shortcut menu.

Object Snap mode Methods for selecting commonly needed points on an object while 
you create or edit a drawing. See also running object snap and 
object snap override.

object snap override Turning off or changing a running Object Snap mode for input of a 
single point. See also Object Snap mode and running object snap.

origin The point where coordinate axes intersect. For example, the origin 
of a Cartesian coordinate system is where the X, Y, and Z axes meet 
at 0,0,0. 

Ortho mode Limits pointing device input to horizontal or vertical (relative to the 
current snap angle and the user coordinate system). See also snap 
angle and user coordinate system (UCS). (ORTHO)

page setup A method of naming and saving plot settings. See also zoom. 
(PAGESETUP)

pan To shift the view of a drawing without changing magnification. See 
also zoom. (PAN)

Term Definition
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paper space One of two primary spaces in which objects reside. Paper space is 
used for creating a finished layout for printing or plotting, as 
opposed to doing drafting or design work. You design your paper 
space viewports using a layout tab. Model space is used for creating 
the drawing. You design your model using the Model tab. See also 
model space. (PSPACE)

pick button The button on a pointing device that is used to select objects or 
specify points on the screen. For example, on a two-button mouse, 
the pick button is the left button.

pickbox The square cursor used to select an object in the drawing area.

plan view A view orientation from a point on the positive Z axis toward the 
origin (0,0,0). (PLAN)

pline See polyline.

point 1. A location in three-dimensional space specified by X, Y, and Z 
coordinate values. 2. An object consisting of a single coordinate 
location. (POINT)

pointing device A device, such as a mouse or a digitizing puck, that can be used to 
interact with the interface and create and edit drawing objects in 
the drawing area. A pointing device usually has several buttons, 
some of which may be customized to perform commands you 
specify. 

polar array Objects copied around a specified center point a specified number 
of times. (ARRAY)

PolarSnap A precision drawing tool used to snap to incremental distances 
along the polar tracking alignment path. See also polar tracking.

polar tracking A precision drawing tool that displays temporary alignment paths 
defined by user-specified polar angles. See also Polar Snap.

polyline An object composed of one or more connected line segments or 
circular arcs treated as a single object. Also called pline. (PLINE, 
PEDIT)

plot style An object property that specifies a set of overrides for color, 
dithering, gray scale, pen assignments, screening, linetype, 
lineweight, endstyles, joinstyles, and fill styles. Plot styles are applied 
at plot time.

plot style table A set of plot styles. Plot styles are defined in plot style tables and 
apply to objects only when the plot style table is attached to a 
layout or viewport.

prompt A message on the command line that asks for information or 
requests action such as specifying a point.

properties See object properties.

Term Definition
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properties palette Lists and changes properties of the selected object or set of objects 
or, if no objects are selected, the values of default properties 
common to all objects. (PROPERTIES)

purge A feature that removes unused definitions such as block definitions, 
layers, and text styles from a drawing. (PURGE)

relative coordinates Coordinates specified in relation to previous coordinates.

running object snap Setting an Object Snap mode so it continues for subsequent 
selections. See also Object Snap mode and object snap override. 
(OSNAP)

scale 1. The proportional size of an object compared with other objects. 
2. The display size of the components of noncontinuous linetypes 
and hatches. 3. The apparent size of objects in a view with respect 
to a drawing sheet. (SCALE, HPSCALE, LTSCALE, CELTSCALE, 
ZOOM) 

selection set One or more selected objects that a command can act upon at the 
same time. 

shortcut keys Keys and key combinations that start commands; for example, 
CTRL + S saves a file. The function keys (F1, F2, and so on) are also 
shortcut keys. Also known as accelerator keys.

shortcut menu The menu displayed at your cursor location when you right-click 
your pointing device. The shortcut menu and the options it provides 
depend on the pointer location and other conditions, such as 
whether an object is selected or a command is in progress.

snap See snap angle, snap grid, snap resolution, and Polar Snap.

snap angle The invisible grid that locks the pointer into alignment with the grid 
points according to the spacing set by Snap. Snap grid does not 
necessarily correspond to the visible grid, which is controlled 
separately by GRID. (SNAP)

snap grid The invisible grid that locks the pointer into alignment with the grid 
points according to the spacing set by Snap. Snap grid does not 
necessarily correspond to the visible grid, which is controlled 
separately by GRID. (SNAP)

Snap mode A mode for locking a pointing device into alignment with an 
invisible rectangular grid. When Snap mode is on, the screen 
crosshairs and all input coordinates are snapped to the nearest point 
on the grid. The snap resolution defines the spacing of this grid. See 
also Object Snap mode. (SNAP)

spline See B-spline curve and NURBS.

status bar The area at the bottom of the application window that contains 
buttons controlling the mode of operation of the program and 
displays the coordinates of the cursor location in the drawing area.

Term Definition



Glossary | 167

strings A sequence of text characters entered at a prompt or in a dialog 
box.

STB file For plot style table file. Contains plot styles and their characteristics.

symbol A representation of an item commonly used in drawings. See block.

symbol library A collection of block definitions stored in a single drawing file. See 
also block library.

symbol table See definition table and block definition table.

system variable A name similar to a command used as a mode, size, or limit. Read-
only system variables, such as DWGNAME, cannot be modified 
directly by the user.

template drawing A drawing file with preestablished settings for new drawings such as 
aclt.dwt and acltiso.dwt; however, any drawing can be used as a 
template. 

text style A named, saved collection of settings that determines the 
appearance of text characters—for example, stretched, compressed, 
oblique, mirrored, or set in a vertical column.

thaw A setting that displays previously frozen layers. See also freeze. 
(LAYER)

tiled viewports See model viewports.

tool palette tabbed areas within the Tool Palettes window that provide an 
efficient method for organizing, sharing, and placing blocks and 
hatches.

toolbar Part of the interface containing icons that represent commands.

tree view A hierarchical list that can be expanded or collapsed to control the 
amount of information displayed. Tree views are available in 
DesignCenter, the Purge dialog box, and the Help system.

UCS See user coordinate system (UCS).

UCS icon An icon that indicates the orientation of the UCS axes. (UCSICON)

user coordinate system 
(UCS)

A user-defined coordinate system that defines the orientation of the 
X, Y, and Z axes in 3D space. The UCS determines the default 
placement of geometry in a drawing. See also world coordinate 
system (WCS).

vertex A location where edges or polyline segments meet.

view A graphical representation of a model from a specific location 
(viewpoint) in space. See also viewport. (VPOINT, DVIEW, VIEW)

viewport See model viewports and layout viewports See also view. 
(VPORTS)
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window selection A rectangular area specified in the drawing area to select multiple 
objects at the same time. See also crossing selection and polygon 
window selection.

xref See external reference (xref).

zoom To reduce or increase the apparent magnification of the drawing 
area. (ZOOM)

Term Definition
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A
absolute coordinates, 78, 159
accelerator keys (shortcut keys), 166
actions, undoing, 39
Add-A-Plotter wizard, 151
aliases, command, 36, 160
aligned dimensions, 132, 142, 159
aligning text, 128
analyzing drawings, 114
angles

angle overrides, 84, 159
angular units, 159
calculating, 114
hatch patterns, 123
polar coordinates, 78
polar tracking, 83
rotation angles, 97
specifying for arcs, 72
text characters, 128

angular dimensions, 132, 134, 143, 159
angular units, 159
annotations, 134, 139, 159
architectural drawing unit format, 52
architectural templates, 51
arcs

drawing, 72
drawing polylines with, 70
filleting, 73, 98
regenerating view of, 46

areas
finding for objects, 104
selection areas, 90

arrays, 155, 159
arrowheads, 134, 140, 159

associative dimensions, 18, 134, 159
associative hatches, 121, 159
attribute definitions, 159
Autodesk DWF Viewer, 155
Auto-hide feature, 30, 36, 63, 160
AutoSnap markers, 80, 85
axes for coordinates, 78

B
B-spline curves, 160
backwards-reading text, 128
base points, 94, 97, 160
baseline dimensions, 132, 143
black-and-white plotting, 154
blank areas within hatches (islands), 122, 163
block attributes, 118
block definition tables, 160
block definitions, 160
block instances (block references), 160
block libraries, 118, 120
block references, 160
blocks, 116, 118, 160

block attributes, 118
block definition tables, 160
block definitions, 160
block references, 160
inserting, 119
moving, 120
overview, 16
sources of, 118
title blocks, 156
typical uses, 118
See also block libraries
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bold fonts, 128
boundaries

editing, 100
extending objects, 92
hatched areas, 122
polylines, 104
text objects, 126
trim boundaries, 109

buttons, toolbar, 35
BYBLOCK property, 160
BYLAYER property, 65, 67, 68, 160

C
calculating distances, angles, or coordinates, 114
calibrating plotters, 152
callouts (leader lines), 18, 134, 139
Cancel command, 39
Cartesian coordinates, 78, 79
center marks, 132, 138, 140
center snap, 82
centering views, 136
centerlines, 138, 140
chain dimensions (continued dimensions), 132, 

143, 160
chord length, specifying for arcs, 72
circles, 38, 46, 72, 98, 106
circumscribed polygons, 71
closing polylines, 70
color-dependent plot style tables (CTB), 152, 161
colors

applying to objects, 64
assigning to layers, 6, 56, 64
color-dependent plot style tables, 152, 161

command aliases, 36, 160
command line, 36, 160
command window, 32, 36, 160
commands

aliases, 36, 160
canceling or undoing, 39
choosing, 34
dynamic prompts, 37
editing commands, 90
ending, 39
help and information, 26
options, 36
repeating, 39
starting in command line, 36

context-sensitive Help, 29
continued dimensions, 132, 143, 160
coordinates and coordinate systems

absolute and relative coordinates, 78, 79, 159, 
166

calculating delta, 114
Cartesian coordinates, 78
dynamic input and, 79

coordinates and coordinate systems (continued)
origin point, 78, 105
overview, 78
polar coordinates, 78
specifying, 12

COPY command, 88
copying

multiple copies of objects, 95
objects, 88, 94
properties to other objects, 111

corners, filleting, 98
counter-clockwise rotation, 97
crosshairs, 160

See also cursors
crossing selection areas, 90, 161
CTB files (color-dependent plot style tables), 152, 

161
current layers, 56, 65
current linetypes, 66
current object scale settings, 67
cursor menus. See shortcut menus
cursors

dynamic prompts displayed by, 37
panning with, 45
pickbox cursor, 85
snapping to a grid, 76
zooming in or out with, 44

cutting edges, 92

D
DC Online tab (in DesignCenter), 120
decimals

drawing unit format, 52
rounding on screen, 53

defaults
defined, 161
property settings, 63

definition tables, 161
deleting objects, 91
delta, calculating, 114
deselecting objects, 90
Design Web Format (DWF) files, 151, 155
DesignCenter, 32, 161

accessing and inserting blocks, 16
DC Online tab, 120
hatch patterns in, 121
sources of block libraries, 118

diameter dimensions, 132, 143
diameters, 72
digital signatures, 161
dimension lines, 134
Dimension Style Manager dialog box, 140
dimension styles, 140, 161
dimension text, 134, 161
dimension variables, 161
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dimensions and dimensioning
accuracy, 12
associative dimensions, 18, 134
center marks and centerlines, 138, 140
creating, 135, 142
dimension styles, 140, 161
dimension variables, 161
editing dimensions, 142
editing properties, 64
elements of dimensions, 134
grips, 142
layers for, 135, 136
moving dimensions, 142
overview, 134
saving styles in templates, 8
scaling, 149
standards for, 141
text, 140, 161
types of, 18, 134, 142
units of measurement, 141

DIMSCALE system variable, 137
direct distance entry, 83, 95, 161
displaying

command options, 37
display scale, 136
grid, 76
Info palette, 30
layers, 57
properties, 63
Properties palette, 63
regenerating jagged display, 46
toolbars, 35
viewport properties, 150

DIST command, 88, 114
distances

calculating, 114
direct distance entry, 83, 161
measuring, 88
polar coordinates, 78
polar tracking, 83

dividing polylines, 71
docking

toolbars, 35
Drafting Settings dialog box, 77, 81
Draw toolbar, 32
drawing area, 32, 161
drawing extents, 161
drawing interchange format (DXF) files, 162
drawing limits (grid limits), 76, 162
drawing objects

arcs, 72
circles, 38, 72
filleting, 98
lines, 37, 69
overview, 10
polygons, 69, 71
polylines, 69
rectangles, 70

drawing scale. See scales and scaling

drawing templates. See templates
drawing units, 2, 51, 52, 161
Drawing Units dialog box, 53
drawings and drawing files

coordinate systems, 78
displaying entire drawings, 44
grids, 76
inserting blocks, 119
new drawings, starting, 50
panning view, 45
plotting, 153
revising, 20
revision clouds, 113
Snap mode, 76
templates, 50
touring, 58
zooming in or out, 14

drivers, printer, 151
DWF (Design Web Format) files, 151, 155, 162
DWT files. See templates
DXF files, 162
DYN button, 79
dynamic input, 79

E
editing objects

associative hatches and, 121
copying properties, 111
dimensions, 142
duplicating objects, 94
erasing objects, 91
extending objects, 92
filleting, 98
grip edit mode, 112
mirroring, 96
object boundaries, 100
offsetting copies, 95
overview, 20
precision editing, 98
properties, 63, 110
revising drawings, 20
revision clouds, 20, 113
selecting objects to edit, 90
text, 126
text styles, 128
trimming objects, 92

editing plotter configurations, 152
editing text, 126, 128
ellipses, 98
ending commands, 39
Endpoint object snap, 82, 108
endpoints, 70, 72
engineering drawing unit format, 52
entities. See objects
ERASE command, 91
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erasing
layout viewports, 150

ESC key, 34
EXPLODE command, 71
exploding objects, 71, 162
EXTEND command, 92
extending objects, 92, 102
extension lines, 134, 140
extents, drawing, 162
external references (xrefs), 161, 162

F
FILLET command, 73, 88
filleting objects, 73, 88, 98
fills, 121, 162
fitting options for dimensions, 141
flipping objects (mirroring objects), 88, 96, 107
floating toolbars, 35
floating viewports (layout viewports), 146, 163
fonts, 128, 162
formatting

dimensions, 140
drawing units, 52
Text Formatting toolbar, 126

fractions, 52, 53
freezing layers, 57, 162

G
geometry, 162
global scale factor for linetypes, 67
graphics area of screen (drawing area), 32, 161
grid limits, 76, 162
grids, 162

creating outlines with, 85
displaying or hiding, 76
grid limits, 76, 162
overview, 76
spacing, 76
turning off and on, 76

grip modes, 162
grips, 163

block grips, 120
displaying, 90
editing dimensions, 142
editing objects, 112
grip modes, 162
viewport grips, 150

H
handles (move handles), 35
hatches and hatch patterns, 116, 121

associative hatches, 121

hatches and hatch patterns (continued)
inserting, 121
islands within boundaries, 122
points for creating, 122
sources of, 121

height of text characters, 128
Help

command Help, 26
Help system, 24
procedural, 26, 29
Quick Help feature, 29
table of contents (Contents tab), 27
tutorials, 25

hiding
Info palette, 30
layers, 57, 65
Properties palette, 63
toolbars, 35

hook lines, 139
horizontal alignment of text, 128
horizontal dimensions, 132

I
i-drop, 163
imperial measurement drawing template files, 51
Info palette, 24, 30, 163
In-Place Text Editor, 126
inquiry commands, 114
inscribed polygons, 71
Insert dialog box, 120
inserting blocks, 119, 120, 156
instances (block references), 163
intersection snap, 82, 100
islands, 122, 163
ISO standards, 50, 121
italic fonts, 128

J
jagged display, 46
JIS standards, 50
JOIN command, 71
joining polylines, 71

K
keyboard shortcuts (shortcut keys), 166
keywords in Help system, 24

L
labels in model and paper space, 128
Layer Properties Manager, 56, 57, 65, 149
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layers, 163
color assignments, 6, 56, 64
current layers, 56, 65
dimensions on, 135, 136
editing properties, 64
freezing, 57
hiding or displaying, 57, 65, 149
Layer Properties Manager, 56, 57, 65, 149
Layers toolbar, 32, 63
linetype assignments, 6, 66
locking, 57
naming, 6
organizing drawings with, 48, 56
overview, 6, 56
plot styles, 6
properties and, 62, 64
rearranging, 56
viewports layer, 156

Layers toolbar, 32, 63
layout tab, 54
layout tabs, 32
layout viewports, 146, 163
layouts, 146, 163

compared to models, 54
display scale, 136
linetypes in, 67
overview, 4, 54
page setups and, 153
plotting from, 153
scale vs. drawing units, 2, 52
switching to model space, 55
text size and, 129
viewports, 146, 163

leader lines (callouts), 18, 134, 139
leader objects, 134
left mouse button, 34
lengthening objects, 92
libraries

block libraries, 16, 118
DesignCenter, 120
DesignCenter Online, 120

limits, grid, 76, 162
line fonts. See linetypes
line widths (lineweights), 6, 48, 68, 163
linear dimensions, 132, 134, 142
linear measurements, 52
lines

angles, 84
centerlines, 138, 140
dimension styles, 140
drawing, 37, 69
exact length, 83
extension lines on dimensions, 134
filleting, 98
hook lines, 139
leader lines, 134, 139
linetypes. See linetypes
lineweights, 6, 48, 68, 163
offsetting, 10

lines (continued)
parallel, 69
perpendicular, 83
polylines, 69
tapering, 71

Linetype Manager, 66
linetypes, 163

editing properties, 110
global scale factor, 67
identifying objects with, 48
layer assignments, 6, 66
Linetype Manager, 66
overview, 65
saving styles in templates, 8
scaling, 66, 67

Lineweight Settings dialog box, 68
lineweights, 6, 48, 68, 163
locking

layers, 57
toolbars, 35

M
magnifying view in viewports. See zooming in or out
markup revision clouds, 113
matching properties between objects, 111
measurement units, 2, 51, 52, 141
mechanical drawing templates, 51
mechanical drawing unit format, 105
menu bar, 32
menus, 34, 35, 166
metric measurement template files, 51
midpoint snap, 82
mirroring objects, 88, 96, 107, 163
Model tab, 32, 54
model viewports, 163
models and model space, 4, 146, 163

analyzing drawings, 114
compared to layouts, 54
dimensioning and, 136
drawing in model space, 54
formulas for text size, 129
linetypes in, 67
notes and labels in, 128
scale vs. drawing units, 2, 52
switching to layouts, 55
switching to paper space, 150
text size in, 129
viewports, 163
zooming in or out, 156

modes, defined, 163
mouse devices, 34, 165
move handles on toolbars, 35
moving

blocks, 120
dimensions, 142
objects, 97
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moving (continued)
panning view, 45
rotating objects, 97
text in dimensions, 134
toolbars, 35

multiple copies of objects, 95

N
named layers, 6
named objects, 164
named plot style tables, 152
navigation

Help system display, 26
Info palette information, 29

New Features Workshop, 24
New Page Setup dialog box, 154
nodes, 164
nonuniform rational B-spline curves, 164
notes, in model and paper space, 128
NURBS (nonuniform rational B-spline curves), 164

O
object properties, 164
object snap markers, 164
Object Snap menu, 35, 80, 164
Object Snap mode, 164
object snap overrides, 164
object snaps

accuracy and, 12
AutoSnap markers, 85
creating outlines with, 85
cycling through snap points, 80
dimensions and, 135
markers, 164
overriding, 164
overview, 76
running object snaps, 81
snap angles, 166
snap grid, 166
Snap mode, 164, 166
spacing, 76
types of, 82

objects, 164
associative dimensions, 134
colors, 64
copying properties, 111
displaying on layers, 149
drawing, 10
duplicating, 94
editing properties, 63, 64
erasing, 91
filleting, 98
grips, 112
hatch patterns, 121

objects (continued)
linetypes, 65
lineweights, 68
mirroring, 96
moving, 97
offsetting copies, 95
properties, 62, 110, 164
rotating, 97
selecting, 90
trimming edges, 92

oblique text, 128
OFFSET command, 69, 88
offsetting objects, 10, 69, 88, 95, 106
opening

block libraries, 120
templates, 51

ordinate dimensions, 132, 134, 142
orientation

pages, 153
text, 128

origin points, 78, 105, 164
Ortho mode, 164
overlays, 6
overriding dimension styles, 140

P
page orientation, 153
Page Setup Manager, 153
page setups, 146, 153, 164
page size, 153
PAN command, 45
panning, 14, 45, 164
paper size, 152, 155
paper space, 4, 165

compared to model space, 54
notes and labels in, 128
scaling linetypes in, 67
switching to model space, 55, 150
text size and, 129

parallel dimensions (baseline dimensions), 132, 143
parallel lines, 69
PAT files, 121
PC3 files, 151
perpendicular lines, 83
perpendicular snap, 82
pick button, 34, 165
pickbox cursor, 85, 165
plan views, 165
plines. See polylines
Plot dialog box, 153
plot scales, 153
Plot Style Manager, 152
plot style tables (STB) files, 152, 165, 167
plot styles, 6, 146, 152, 165
plotter configuration (PC3) files, 151
Plotter Configuration Editor, 152
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Plotter Manager, 151
plotters and plotting

calibration, 152
configuring plotters, 151
driver support for, 151
page setups, 153
plot styles, 146, 152
Plotter Configuration Editor, 152
plotting from layouts, 153
previewing, 153
printing viewport borders, 150
scaling in model space, 157
setting up, 153

Plotters folder, 151
pointing devices, 34, 44, 46, 165
points, 165

absolute coordinates, 78, 159
AutoSnap markers, 80, 85
calculating distance or coordinates, 114
coordinate systems. See coordinates and 

coordinate systems
origin points, 78, 105, 164
polar coordinates, 78
relative coordinates, 79, 166
specifying for arcs, 72
specifying for circles, 72

polar arrays, 165
polar coordinates, 78
polar tracking, 12, 83, 165
PolarSnap, 105, 165
polygons, 69, 71
polylines, 69, 165

closing, 70
dividing or joining, 71
filleting, 98
highlighting boundaries, 104
widths, 71

ports, 152
PostScript files, 151
previewing plot areas and settings, 153
printers

calibrating, 152
plot styles and plot style tables, 152
Plotter Configuration Editor, 152
selecting plotters, 153
support for, 151

procedural Help, 26, 29
prompts, 36, 37, 165
properties, 62

assigning, 62
copying to other objects, 111
editing, 64, 110
layer assignments, 62
matching, 111
Properties palette, 63, 110, 166
Properties toolbar, 32, 63, 110
viewing, 64

Properties palette, 63, 110, 166
Properties toolbar, 32, 63

pull-down menus, 34
purging, 166

Q
Quadrant object snap, 82, 107
Quick Help feature, 29
Quick Leader dimensions, 132
Quick Reference card, 24

R
radius

filleting objects, 98
specifying for arcs, 72
specifying for circles, 72
specifying for polygons, 71

radius dimensions, 132, 134, 143
raster files, 151
raster graphics quality, 152
rectangles, 70
rectangular selection areas, 90
redline drawings, 113
regenerating jagged display, 46
relative coordinates, 79, 166
relative values, 78
removing objects, 91
repeating commands, 39, 95
resizing

linetypes, 67
text objects, 126
toolbars, 35
viewports, 150

revising drawings, 20, 113
See also editing objects

revision clouds, 20, 113
right mouse button, 34
right-clicking actions, 34
rotating objects, 97, 120
running object snap, 81, 166

S
saving

files as DWF files, 155
files in other formats, 151

scales and scaling, 166
dimensions, 137
drawing units compared to scale, 2, 52
hatch patterns, 123
linetypes, 66, 67
lineweights and, 68
overview, 2
plot scales, 153
setting display scale, 136



176 | Index

scales and scaling (continued)
text, 129
views in viewports, 4

scientific drawing unit format, 52
secondary dimension styles, 140
Select Template dialog box, 51
selecting

deselecting objects, 90
objects, 90

selection areas, 90
selection sets, 90, 166
sharp corners on objects, 98
shortcut keys, 166
shortcut menus, 34, 35, 166
shortcuts

cycling through snap points, 80
editing text, 126
shortcut keys, 166

sizing
linetypes, 67
text objects, 126
toolbars, 35
viewports, 150

slant of text characters, 128
smoothing display, 46
Snap and snapping. See object snaps
snap angles, 166
snap grids, 166
Snap mode, 166
solid fills, 121, 162
spacing

grid and snap settings, 76
hatch patterns, 123

splines, 98, 160, 164
STANDARD style, 128, 140
Standard toolbar, 32
start points, 70, 72
starting drawings, 50
status bar, 32, 166
STB files (named plot style tables), 152, 167
strings, 167
styles

dimension styles, 140, 161
drafting standards, 8
extension lines, 140
overriding, 140
plot styles, 152
text styles, 128

Styles toolbar, 32
switching

between model space and paper space, 150
between models and layouts, 55
between page setups, 153

symbol libraries, 118, 167
DesignCenter Online, 120
opening, 120

symbols
defined, 16, 167
in dimensions, 140
See also blocks

system variables, 167

T
table of contents in Help system, 27
tangent method for drawing circles, 72, 106
tangent snap, 82
tapering lines, 71
templates, 50, 161, 167

drafting standards and, 8
DWT files, 162
opening, 51
sample files, 51

text
annotations, 134, 139
dimension text, 134, 140, 161
In-Place Text Editor, 126
model vs. paper space, 128
saving styles in templates, 8
styles, 128, 167
Text Formatting toolbar, 126
viewports and, 129
width of, 126

Text Formatting toolbar, 126
Text Style dialog box, 128
text styles, 8, 128, 167
thawing, 57, 167
tiled viewports (model viewports), 167
title blocks, 156
tolerance options for dimensions, 141
tool palettes, 32, 167
Tool Palettes window, 32
toolbar buttons, 35
toolbars, 32, 167

docking, 35
hiding or displaying, 35
Layers toolbar, 63
locking, 35
moving, 35
overview, 35
Properties toolbar, 63
resizing, 35

tooltips, 35, 80
topics in Help system display, 26
transparency of palettes, 30
tree views, 167
trim boundaries, 109
TRIM command, 88, 92
TrueType fonts, 128
tutorial drawing templates, 51



Index | 177

U
UCS (user coordinate system), 167
UCS icon, 167
undoing actions, 39
units of measurement

in dimensions, 141
drawing units, 2, 52
template files, 51

updating dimensions and leader lines, 134
upside-down text, 128
user coordinate system (UCS), 167
user interface elements, 32

V
variables

dimension variables, 161
system variables, 167

vector graphics quality, 152
vertical alignment of text, 128
vertical dimensions, 132
vertices, 167
viewports, 146

changing settings, 155
creating, 149
display scale, 136
displaying layered objects, 149
erasing, 150
grips, 150
linetype scaling in, 67
model space and paper space overview, 54
modifying, 149
multiple viewports, 155
overlapping, 150
overview, 4
panning, 45

viewports (continued)
plotting borders, 150
properties, 150
scaling views, 4, 44
sizing, 150
zooming in or out, 156

views, 44, 167
displaying entire drawings, 44
panning, 14, 45
repositioning, 45
See also viewports

visibility of layers, 57

W
wheel mouse, 34, 44, 46
width

polylines, 71
text characters, 128
text objects, 126

window interface elements, 32
window selection areas, 90, 168
Windows printer drivers, 151

X
X and Y values, 78
xrefs (external references), 168

Z
ZOOM command, 44
zooming in or out, 168

overview, 14, 44
scaling views in viewports, 4, 156
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